Question about 1999 Ford Escort

1 Answer

1999 Ford Escort Won't start after replacing Plugs and cables.

1999 Ford Escort 2.0L SOHC. Was running rough. Replaced plugs and cables. Made sure to keep them in the correct order. Used pre-gapped Bosch plugs. Now car will not start. Nothing is firing. I hear one loud click and then nothing.

Posted by on

  • glennc630 Apr 17, 2009

    No. The engine is not turning over.

  • arun rebello May 11, 2010

    is the engine turning over?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 104 Answers

Check the battery if its ok, check for power at the starter with a meter or a test light. it sould have a constant power source and one that has power when you turn the key to start. if those are there you need a starter

Posted on Apr 17, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Why would engine run rough after tunr up?


Are plug wires connected in the right firing order to the plugs? Also are the spark plugs gap correct? Was vehicle running rough before tune up or only after?

Jul 05, 2014 | 1998 Ford Escort

1 Answer

2002 ford escort zx2 replaced fuel filter, air filter, plugs, and MAS...why won't it stay running?


it could be down to your spark plug leads take the leads out one by one and get somebody to hold the lead to the engine [to earth it] NOT WITH YOUR HAND with something thats not conductive like something plastic then try starting the engine to see if a spark jumps from the lead and repeat this please dont do this with your hand its very dangerous enouf voltage to knock you out!

Aug 06, 2012 | 2002 Ford ZX2

1 Answer

1999 ford escort zx2 cranks but won't start


As with any no-start issue, you will need to figure out if you have a problem with fuel pressure to the injectors, or spark to the plugs.
I would also check the computer for trouble codes.
Let me know what you find out.

Jul 30, 2012 | 1999 Ford Escort

1 Answer

1997 ford escort 110968 miles replaced parts as fallows: plugs,plugwires, EGR selinoid, timeingbelt, waterpump,MAF sensor. check engine light came on ,idle dies or is rough, loss of power, won't downshift...


sorry but this advice is based on 35 years as a Ford dealer technican and 1000's of repairs. i still say time to trade it in on another low miles used one, not new used, it will nickel and dime u to dealth if you don't, trust me on this. put the fuel filter on check the fuel pressure (spec is 45 PSI) and keep your fingers crossed

Apr 27, 2010 | 1997 Ford Escort

1 Answer

99 escort SOHC engine. Idles rough at start up. Smooths out some when it warms up but still idles erratically and surges. Changed the plugs and put new air filter in, but no change. Plugs are fairly black...


If you can find the IAC valve(idle air control) on the throttle body-it should be replaced or try to clean..If you put in new plugs and they turn soot black in a short time period, you have other issues-possible internal engine,such as valve train problems, or a partial exhaust blockage, or the fuel your buying is not good...

Nov 08, 2009 | 1999 Ford Escort

1 Answer

My 97 ford escort will start but misses and runs rough


When was the last time you replaced the plugs and wires. Sounds like it needs a tune-up. Replace the spark plugs and wires also run a good fuel treatment thru it.

Jul 08, 2009 | 1997 Ford Escort

1 Answer

1999 ford explorer misfire in cylninder 6 code


you might try changing the engine coolant temp sensor. could also have defective spark plugs. check the fuel filter, lines and pump.

Apr 09, 2009 | 1999 Ford Explorer

Not finding what you are looking for?
1999 Ford Escort Logo

302 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

fordexpert

Level 3 Expert

5626 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...