Question about 1998 Volvo S70

2 Answers

Last 14 months - 4 new batteries & new alternator fitted. Car still not starting and had to be returned to garage! Any ideas!

Oved the last 14 months - 4 new batteries and new alternator fitted last week. Volvo battery still flat and had to be returned to the garage again! Any ideas?

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Volvo Master
  • 599 Answers

Sound like you have a parasitic drain on the battery,needs to be tested with an amp draw meter with engine off, something is drawing amperage from the battery

Posted on Apr 15, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Volvo Master
  • 6,982 Answers

You need to have your electrical system checked for excessive draw. If the shop that worked on it has not done so, bring it to another shop...This is a routine procedure which definitely should have been done at least after the second battery! I can't offer a solution or "quick fix" because without doing that procedure I'd only be guessing!!!

Posted on Apr 15, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

New Battery last six months then gradually wont start in the end wont start at all without jumping it.


it sounds like your alternator is either intermittent/on its way out/or is not working at all ? find a garage that dose free quotes and get them to check your alternator

May 21, 2015 | Cars & Trucks

1 Answer

Rover 75 forum


the car as a wire connected to the chassis and he is descharging the battery. you have to go to a car electrician and look wall the cables to see where he is not isolated.

Mar 11, 2014 | Cars & Trucks

2 Answers

Is replacing an alternator belt the same as replacing the alternator


Well the alternator is driven by a belt. You should be able to look at the alternator and tell if it has been replaced by how clean it is.

Apr 24, 2013 | Cars & Trucks

1 Answer

Car battery goes dead after car sits for more the 24 hours. It will start when jump started. Battery charges if a trickle charger is used. All new belts have been put on the alternator. The ABS light will...


As a simple preliminary test, try disconnecting the battery before you let the car stand for a while and see if it will start when reconnected. (If this will not affect radio codes and alarm systems). This will give you an idea if it is the battery or something in the car that is draining the battery.

Jan 31, 2011 | 1992 Saab 900

1 Answer

Going through alternators


Hi there, I am a girl (i.e. not car savvy), but I have a 1998 Altima as well, and the first time (4 months ago) I noticed the brake and battery lights on simultaneously, I took it to a Nissan service shop. Everything seemed fine until about a month ago when the symptoms returned. I ignored the problem for 3 days and the car just stopped running, period. Took it back to the shop, figured out it was a fauly alternator, got it sorted, no problem. Today (1 month after replacement), I see the same bloody problem, and I'm taking it back to the shop in the morning. I am wondering... is it the alternator, or something connected to the alternator that is malfunctioning? The 2 alternators put in were "rebuilt" since they didn't have genuine Nissan alternators available. I really hope the dealers aren't taking me for a merry ride.

Jul 13, 2010 | 1999 Nissan Altima

1 Answer

Yesterday when I went to work the battery and brake light were on when I got off the exit to get to work the battery and brake lights went off. Approxmitaly 12 hours later when I started the car to go home...


Try a day time running light modual,these things are notorious for messing up,and since they are supposed to work when the car is charging it seems like the logical solution.

Jan 13, 2010 | 2001 Mitsubishi Montero Sport 4WD

1 Answer

Loss of charge on 91 loyale station wagon


the regulator is in the alternator. it sounds like it isn't charging the battery anymore. battery voltage should be around 14 volts with engine running. also check connections at alternator to battery. have seen corrosion here keep the battery from charging

Aug 04, 2008 | 1991 Subaru Loyale

Not finding what you are looking for?
1998 Volvo S70 Logo

Related Topics:

254 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...