Question about 2003 Chevrolet Suburban 1500

1 Answer

I have a broken defroger pin how can i make it hold on to the rear windscreen

Posted by on

  • Richard Scordino May 11, 2010

    frog glue??? Actually, iv'e had some success with mirror glue on those.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 6,674 Answers

They also have what is called "grid repair" kit. It's like brushing on paint, it may work too.

Posted on Apr 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Suggest causes for the 4L80E transmission not to reverse


No Reverse

Checks

Cause

Case (7)

The rear band anchor pin is broken or the pin is not positioned.

Center Support (640)

Leaking at the case, or the support is broken.

Center Support Seal (639)

Leaking

Center Support Bolt (25)
?€¢
The bolt is loose or broken.
?€¢
The feed hole is blocked.

Rear Band (657)

Broken, worn, or not anchored

Rear Band Apply Pin (73)

The pin is too short or the pin is binding in the case.

Piston (65)

Binding in the case

Seal (66)

Leaking, damaged, or worn

Gasket (63)

Damaged or displaced

Cover (62)

Damaged

Bolts (61)

Broken, loose, or missing

Checkball

Missing

Fluid Pressure

Too low

Direct Clutch Components

Reaction Plates (618)

The splines are worn.

Friction Plates (611)

The splines or the friction are worn.

Spring Assembly (607)

Jammed

Housing (623)

Cracked

Piston (619)

Leaking

Seal (620, 621, 622)

Leaking

Ball Check

Leaking

Dec 18, 2015 | 2001 Chevrolet Silverado

1 Answer

Rear window defroger does not work, lite on switch does not work so i feel it's a relay or fuse under the hood. I checked the fuse boxs but came up empty.


I had the same problem, from lifting the rear hatch cause the wires to the defroger break. some quick wire splices and it was back working.

Jan 12, 2012 | Chevrolet Metro Cars & Trucks

1 Answer

Locating any fuse or relay fuse for rear window defroger


- The fuse for rear window defoger is run with the AC circuit, since you would not run both at the same time. This normally in the standard fuse block under the dash

Jan 12, 2012 | 2001 Chevrolet Metro

1 Answer

Windscreen Washers - 2000 Daewoo Lanos 1.4


take the plastic hose off and blow through the hose it could just be a block hope this helps regards Jim

Apr 18, 2009 | 2000 Daewoo Lanos

1 Answer

I knocked my rear view mirror of the windscreen and can't get it


there should be a very small screw you have to loosen to put the mirror back in place and then tighten it back up again. i think it takes a very small allen wrench

Jan 22, 2009 | 2001 BMW 3 Series

2 Answers

Horn plus rear windscreen wiper not working


i presume you mean wiper water pump... first locate the relays for the horn and rear wiper and replace them... usually found in the fuse panel under the dash... then fill up the rear water resevoir for the back wiper and try it again.

Robert

Jan 11, 2009 | 2000 Ford Focus

3 Answers

How to reset oil life on 1994 cadillac sedan deville


To reset the engine oil life, do this: push info button till oil life comes up, then push inforeset, to reset to 100%


To reset the transaxle oil life do this: early models; press off and rear defrog button simultaneously.
later models; press info till the oil message shows up then, press and hold info reset.


Some models have both, but my 94 Deville only monitors the transaxle

Sep 24, 2008 | 1994 Cadillac DeVille

1 Answer

Climent controler


May be a problem in the defogger / antena module, or the grid in the back glass has a broken line or two. Broken grid lines can be VERY difficult to locate.
May want to ask a tech here....

http://www.greatautohelp.com/more_chevy_questions/html

Jul 30, 2008 | 2006 Chevrolet Impala

Not finding what you are looking for?
2003 Chevrolet Suburban 1500 Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...