Question about 1999 Ford Expedition

2 Answers

99 ford expedition 4.6 misses / egr? vacuum?

Hi there, my expedition has had a problem for a couple of days. Check engine light on, flashes when trying to go up a hill. It also hesitates to go up hill, have to ease up on gas pedal. Auto zone told me it was EGR valve, removed it, cleaned it with a cleaner and put back but not change at all. Even though EGR wasnt clogged or had much build up in it. new spark plugs, wire set, fuel filter, air filter and pcv. Now for the weird part, whenever trying to go up a hill on the highway or when i accelerate over 3k rpm's, the a/c goes up to the defrost vents and wont come back to normal until it goes back down to under 3k rpm. I was thinking it could be a vacuum since a/c and egr valve work with vacuum's but cant find any broken vacuum lines. How can I check my vacuum lines? or does anybody have a vacuum diagram for this? thanks for your great help guys...

Posted by on

  • yadayada
    yadayada May 11, 2010

    TO LONG FOR FREE FORUM, IF U WANT A QUICK ANSWER USE THE PREMIUM POST OPTION

×

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 145 Answers

It's getting to much egr the egr has gone bad and needs replaced.
the diaphragm in the egr is leaking, and default position for air is defrost.so when you hit 3000 rpm you don't have enough vacuum.

Posted on Apr 30, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Look for your evap solenoid under the truck in the rear an also can be a coil pack the 2 main things when u got to pull off or give it gas. the a/c is vacuum an electric so when the rpms hit a limit the valve will change it also has to do with your controls be faulty

Posted on Aug 27, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Where is the egr valve on a 99 Ford expedition


The EGR valve is in a very difficult spot to work on. If the EGR is bad it will set off the check engine light and make the vehicle run rough or stall at idle. It really doesn't make it run rough while driving or accelerating. What are the conditions when the car runs rough?

Mar 01, 2014 | 1999 Ford Expedition

2 Answers

In my 1999 ford expedition 5.4 l engine i replaced the egr valve but thw check engine light came back after 4 days what could be causing this


Check code free at auto zone, If it is still telling you the EGR is the problem and you replaced it with a new unit not a used unit check your vacume lines for leeks.

Jul 03, 2011 | 1999 Ford Expedition

1 Answer

1997 ford expedition 5.4. no suction on vacum hose pluging into my egr valve.


Follow the hose it runs to the DPFE (egr position sensor). See if hoses are cracked, shrunk or missing. There is an in & out. They need to be a special silicone vacuum hose made for this setup. Usually the replacement silicone vacuum hose is orange. It is available at most autoparts stores. If all sections of hose are ok, either DPFE (egr position sensor) or egr solenoid is bad. There should be a check engine light on for any one of these problems as they each have their own code.

Jan 17, 2011 | 1998 Ford Expedition

1 Answer

The engine hesition sometime 04 expedition 5.4


Most likely you have a bad COP (Coil On Plug) .
Maybe more than one. Very common ford problem for last 12 years.
If you get a MIL Light on the dash (the wrench),check for a PO300 Code.
A PO304 would be coil #4,PO306 #6 Etc.
Cyl 1 thru 4 on pass side
Cyl 5 thru 8 on driver side,front to back

Also hills cause a hi engine vacuum and thus a possible EGR Valve going bad. You can unplug the vacuum lines and plug, to diagnose that issue.

Also leave the EGR disconnected if your working on coil issues. Just note the MIL light will stay on all the time,and remember to check your 300 codes if you feel a hesitaton or miss.

Jul 28, 2010 | 2004 Ford Expedition

1 Answer

Hi i have a 99 expedition engine light is due to the egr valve i replaced it and turned the code off with a obd2 scanner and it ran fine for like a week went on a 4 hour drive and came back and the code...


Check codes again Egr code does not mean its shot. Just means it not reading what it needs to, Could be miss fire and sending gas out exhaust and in turn tripping egr the exhaust is rich. That may not be it but something on those lines

Apr 17, 2010 | Ford Expedition Cars & Trucks

3 Answers

I REPLACED EGR BUT LIGHT STILL ON SAME CODE


Hi:
I am not sure what code you have, but there is also an EGR sensor code that is tripped, and it isn't the EGR valve, but the EGR pressure sensor. Did you clear the codes off of your vehicle, or just replace the part? If you didn't clear them, then it can take 50 start cycles to get the light to go out by itself.

Apr 15, 2010 | 2000 Ford Expedition

1 Answer

I change the egr valve and the hoses from the egr and then i reset the it the light came off then I drove it for a couple of days and the light came back on what next.


"Check Engine" light comes on, there is always a DTC (Diagnostic Trouble Code) stored in the ECM (Engine Control Module). You'll need an OBDII (On-Board-Diagnostics) scanner to retrieve any codes recorded/set in ECM. Once you do this and let us know what, if any codes are set, then we can go from there.

Jun 28, 2009 | 2000 Ford Expedition

1 Answer

01 Ford Expedition. Check Engine light and failed Smog check.


whoever installed the egr valve, if it wasnt you, just cleared the engine codes, thus giving you this problem once again. Get it scanned at autozone, and go from there.

May 18, 2009 | 2001 Ford Expedition

Not finding what you are looking for?
1999 Ford Expedition Logo

1,098 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...