Question about 1998 GMC Jimmy

2 Answers

98 jimmy gauges glitch & tranny slams into gear

Weird problem, starts fine, all gauges and lights come on, but soon after tach. speedo gas and temp gauges drop out. sometimes even while driving.

While parked sometimes key gets stuck, i removed the key release solenoid from circuit, and all gauges come back to life, i tried plugging it back in and out, gauges kept turning off when it was connected. Thought problem was solved. 1/2 hr. later gauges glitched out again even with key release disconnected.

When gauges are out the tranny will slam into reverse and into fwd. while driving and come to a stop the tranny seems to slip when accelerating, if i shift it to second gear it will slam into it and then will allow me to follow through into 3rd and 4th manually.

When gauges work the transmission softly shifts into fwd and rev, untill today, gauges work for a while but transmission seems to slip/ stuck in too low of a gear, almost like if it was manual the clutch is screwed, rev it like hell but not much drive.

I have cleaned the fuses really good and battery is clean, just not too sure it there is a few problems or one main issue.

No check engine light or even check gauges light will stay on. I'm going to get codes checked later today anyway just to see.

If you have any ideas please let me know, Thanks Chad

Posted by on

  • 3 more comments 
  • toolbox42 Apr 14, 2009

    do you know if i need to have the park interlock switch connected? or is it just there, it was just really weird when the gauges stop when it is connected and work when disconnected. it seems like every time i start the truck i get different remarks, a half hour after finding the switch was the problem, it didn't seem to shut down the gauges when it is connected, the gauges still frap out whenever they want to, i'll go right now to get the codes, and keep you posted.
    Thanks, Chad.


  • toolbox42 Apr 14, 2009

    also yes this is a 4x4, W vin#

  • toolbox42 Apr 15, 2009

    alright, the inital codes which must have been old codes were P0404, P0405 & P0452. we cleared these codes and restarted test the following codes came up twice after clearing and restarting:
    P0740 & P1860.

    That seems possible for the tranny performance issue, but still only messes up when the gauges fault out.

    I had reconnected the park interlock solenoid but it is just hanging now not mounted.

    during checking codes the gauges would glitch on and off at different times.

    After clearing the codes i left mechanics and the gauges worked fine all the way home and transmission worked great, i'll see with time if the gauges work still.

    any guesses?

  • toolbox42 Apr 15, 2009

    hey guess what, problem continued this morning, still need to shift to 2nd, then once its going i'll shift to 3rd adn can tour around at city speeds. sometimes the gauges work fine but i'll need to shift to 2nd, but the gauges go out, untill i shift to 3rd. and sometimes the gauges come back on. still regardless most of the time i need to shift.

  • toolbox42 Apr 15, 2009

    sorry hommz, i was at work all day, i'll pull'er right now and let you know. I found today that if gauges not working, i press the trip meter button the gauges turn on, but no help with the tranny.

    If you start it enough times the park interlock solenoid will work and at that time the transmission will work properly. whatever is giving the prk intrlk solenoid power is goofing up, i just don't know what exactly turns this on and off.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

There is a switch on the brake pedal that engages the shift interlock solenoid.
The switch MAY be out of alignment or has failed. (keep reading)

But your main shifting problem seems to be speed sensor related.

p0740 = torque convertor clutch solenoid circuit failure

p1860 = TCC PWM Solenoid Circuit Failure - Pulse width modulated torque converter clutch solenoid did not respond to PCM commands.

However - using THIS electrical schematic of your vehicle - you will find that the VCM is what is common to all the things wrong with the vehicle.

Before chasing sensors and throwing parts blindly into your truck - i wouldnt hesitate to suggest your VCM (vehicle control moduule - computer - ) is faulty.

The VCM Uses info gathered from all your sensors to...
1. tell the cylinders when to fire.
2. calculate the vehicle's speed and cam/crank shaft positions
3. tell which gear the vehicle is in.
and more!!

a faulty board - cold solder joint etc. could very well react the way you have described. Info and power goes to and from the gauge cluster - and if the VCM doesnt know how to interpret the voltages recieved - it doesnt know the next step in the logic.

It is my experience that all these sensors do not fail at the same exact time - so my diagnosis is that your computer has issues.

Replace the VCM, and your problems (or most of them) will go away!!

Posted on Apr 16, 2009

  • blueextc3221
    blueextc3221 Apr 16, 2009

    if you have additional clarifications about your question please use the "continue working with this expert" option before moving on to another expert.

    Thanks!!

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • GMC Master
  • 76,846 Answers

You need to check the connector at the back of the instrument cluster for a loose or poor connection to the printed circuit board of the cluster, I think when u were fooling around with the park interlock solenoid you may have moved a bad connection to the cluster. also the speed sensors on these trucks cause al kinds of problems so get the trouble codes checked and see if u have a speed sensor code..

Posted on Apr 14, 2009

  • 2 more comments 
  • yadayada
    yadayada Apr 14, 2009

    Is this a 4X4?

  • yadayada
    yadayada Apr 14, 2009

    the speed sensor in the transfer case can be the source of the trans shifting wow's

  • yadayada
    yadayada Apr 15, 2009

    they will act up again.

  • yadayada
    yadayada Apr 15, 2009

    HAVE YOU PULLED THE CLUSTER AND CHECKED THE CONNECTOR AS I ADVISED?

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My cars gauges just stopped working last weekend.


Could be a fuse. Have somebody who knows about cars look at the instrument cluster fuse to see if the wire inside is broken.

Jun 07, 2016 | 2004 Saturn VUE

1 Answer

Gmc jimmy cuts out when at stop lights and in park give it gas gos away?


98 GMC Jimmy tranny problems - YouTube

? 1:55
www.youtube.com/watch?v=oYaUfykzfG4
Oct 31, 2007 - Uploaded by mrockerrock
Fixing my transmission. ... 98 GMC Jimmy tranny problems. mrockerrock ... Never had to replace that and my 98 jimmy has 118000 miles on it.

Aug 19, 2015 | GMC Cars & Trucks

1 Answer

Instruments don't work, key stuck in ignition, doesn't shift correctly


Sounds like you need a new car.
With joking aside, the problem with your speedo, tach, gas guage, temp gauge and odometer can probably be one of two things. Check your fuses. If they are fine you may need to replace your cluster panel. I had to have the entire thing changed over my speedo not working right. It was not cheap. You might want to check the relay box under the hood. Does your transmission leak? Check the fuses and relay on it also. Get a new ignition switch and replace the old one if your key is stuck. You can try WD40 on that key but don't expect any miracles. The bearings are likely shot. Sorry I posted all of this bad news. Good luck.

Jan 05, 2014 | 1998 GMC Jimmy

1 Answer

Tach & speedo not working


Had same problem with my 2000 dodge stratus 2.4 liter and transmission would not shift out of 1st gear. Solution was ignition fuse under the hood was blown, one side of fuse working, replaced 10 am fuse everything works, tach, speedometer, gas gauge and transmission started back to shifting.

May 27, 2010 | 1996 Oldsmobile Achieva

1 Answer

Screwed up dash in 98 wrangler


i have seen this before its the igntion switch . on the lock and key but the switch its self wich is located under the plastic cover on the steering colume

Oct 28, 2009 | 1998 Jeep Wrangler

1 Answer

Instrument Panel Problem - Electrical


check all wiring and maby youl get it right

Sep 18, 2009 | 2005 Chrysler PT Cruiser

1 Answer

Speedo and tach not workingin 1999 elentra


2000 elantra started shifting wierd now it jump in and out of gear when in drive, any thoughts

Sep 16, 2009 | 2000 Hyundai Elantra

1 Answer

98 Nissan Pathfinder with gauge glitches


Its very common on a lot of cars, the instrument cluster has a number of connectors soldered onto the circuit board, the solder joints get loose or are bad to begin with and you will get these kinds of intermittent display issues. They are a pain to fix because the entire cluster has to be removed, just to solder the joints! The soldering is the easy part, re/re of the unit is the real pain. If you go through the trouble make sure you also inspect every solder joint on the board while its out..you don't want to do it a second time!

Jun 20, 2009 | 2000 Nissan Pathfinder

1 Answer

Instrument cluster damaged after battery shorted out.


4 resistors on the back of cluster bad get them at radio shack.

Dec 14, 2008 | 1998 Buick Regal

Not finding what you are looking for?
1998 GMC Jimmy Logo

Related Topics:

116 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...