Question about 2006 Suzuki Forenza

1 Answer

MY ENGINE LIGHT COMES ON AND THE CAR IDLES ROUGH AND THEN IT MOVES SLOW AS I STEP ON THE GAS. I TURN OFF THE CAR FOR A FEW MINUTES AND THE CAR STARTS TO SHIFT CORRECTLY BUT MY ENGINE LIGHT STAYS ON AND I GET POOR GAS MILEAGE. I NEED THE LOCATION OF THE SENSOR ON THE VEHICLE. IE..RIGHT SIDE, LEFT SIDE, UNDER WHICH WHEEL.??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 4 Answers

If it continuously runs slow after stepping on the gas w/ poor milage it MAY be something clogged in your exhaust. However I'm having similar probs but a simple "turn engine off and restart" doesn't fix it as mine is misfiring...

Posted on Apr 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Idles roughly, then low when stopped or in park, then dies. Decreasing gas mileage. Slow to accelerate


Sometimes that's caused by a vacuum leak near the manifold area.

Sometimes air in the coolant will cause an idle problem. Air will keep the air temp sensor from sending proper info.
Hope this helps.

Jan 03, 2014 | 2004 Ford Taurus

1 Answer

Got a Code 43 on my 1992 Buick Regal Custom.


sometimes is hard to get there and cost a lot of money.

Mar 08, 2013 | Cars & Trucks

1 Answer

Engene dies when is started


It can be issue with fuel pressure,its low or the problem relates to faulty spark plugs.
There are few troubleshooting steps to confirm the problem.I suggest you few help links,with complete troubleshooting and solution for these types of issues.

1991 Toyota Trecel: Engine Starts fine but dies when gets Warm? http://whatisbyme.blogspot.in/2012/05/1991-toyota-trecel-engine-starts-fine.html

-----------
1994 Toyota Pickup: Starts fine but dies in few seconds?


http://howtobyme.blogspot.in/2012/05/1994-toyota-pickup-starts-fine-but-dies.html

-----------
1994 Lexus ES300: Engine Idles Rough and Dies? http://whatisbyme.blogspot.in/2012/05/1994-lexus-es300-engine-idles-rough-and.html

-----------
Stalls And Dies At Stop Sign? http://www.howtobyme.blogspot.com/2012/07/stalls-and-dies-at-stop-sign.html

-----------
Car dies when gas pedal is pressed? http://schematicsdiagram.blogspot.com/2011/12/car-dies-when-gas-pedal-is-pressed.html

----------
These help links will help you to troubleshoot and solve the issue.
Thanks.

Oct 21, 2012 | Cars & Trucks

1 Answer

Hi guys...my yaris is running rich, has poor gas mileage (360km on a full tank). and very slow and choppy idle (idles like a really old car) these are the things i have done so far : change air and fu


Do the following:
1. Clean the throttle body from inside.
2. Adjust the spark plugs gap to 1.00 mm.
3. Check fuel pump pressure. (44 Psi - 49 psi)
4. Remove the negative battery terminal for 5 minutes.
5. Connect the battery terminal.
6. Check the engine oil level and coolant level.
NOTE: Before starting the engine shut off all lights and loads for example room light, blower, radio, parking light etc.
7. Start the engine and hold the throttle at 3000 rpm till radiator fan comes on.
8. After the fan comes on release the throttle pedal and let it idle for 10 minutes.

May 08, 2012 | 2005 Toyota Yaris 1.3

1 Answer

Car runs great 45 minutes into ride it idles rough and stalls like bad gas or water. wait 15 minutes car starts runs 15 minutes stalls the same way.


It could be any number of things check your catalatic converter. Is the check motor light on? email me at mallanapril@msn.com with any other questions

Apr 07, 2010 | 2000 Suzuki Grand Vitara

2 Answers

Engine misfire, EGR replaced still rough idle! I recently got my camaro, 96 V6. I noticed a couple days ago that it was lacking power and then my check engine light came and it was flashing. After that it...


First, check the passageway to the egr valve to make sure it is clear (often plugs up with carbon) second, make sure that the egr control is working. Also a good idea to have any codes checked and old ones cleared.Computer may need to cycle a few times to "learn"new parameters.
In general, it is good to shut down your engine when check engine light comes on...The next step after that is to determine why the light came on.
If the cause is an oil related or coolant related item, you should drive no further 'till it's corrected...However, there are numerous sensors that can turn it on with no disasterous results if you continue to drive One example is the light coming on because a gas cap has not been put on correctly...On many vehicles this will turn on the light and set a code, but the car will suffer no damage if you drove to your destination before correcting it.So, if the light comes on and it is not overheating and you have good oil pressure, and you hear no noises from engine, have it looked at but don't put yourself in danger on the side of a major highway for a nonsense code.
Most major parts houses will read codes free...take advantage of that service and get yourself a basic repair manual, so you have an idea what all the stuff under your hood is and does.
Good luck with your car!!

Apr 26, 2009 | 1996 Chevrolet Camaro

1 Answer

Engine runs rough after about ten minutes /idles really low


Just trowing some suggestions out there, but, I would check the idle air control valve (solenoid) or the throttle position sensor. If they check out then my last guess would be the map sensor or the vaccuum to the map sensor. Hope I was able to help. Best wishes.

Jan 16, 2009 | 1991 Plymouth Laser

Not finding what you are looking for?
2006 Suzuki Forenza Logo

Related Topics:

461 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...