Question about 2000 Alfa Romeo 156

1 Answer

156 2.4JTD When i turn on the ignition, the pre-heater light comes on, goes out after normal warming period and the engine starts normally. With engine at idle the pre-heater light then flashes 10 times, then goes out. Does not come on again when driving, has anyone any idea of what may be causing this to happen?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Alfa Romeo Master
  • 881 Answers

It works automatically on cold weathers dont worry

Posted on Apr 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

HEATER PLUG COME ON AFTER PRE HEATING LIGHTS GO OFF ENGINE STARTS.


if it is momentarily, It is normal. When you start the vehicle, it turns off other things. Like this. The plugs come on because of the ECU. Notice when you turn it on, the light is on for a few seconds. After starting it is on for a split second.

Aug 30, 2016 | 2005 Fiat Doblo 1.9

2 Answers

Engine light on during ignition


Any car produce after 1996 can be scan with an OBDII reader.

Check the date code on the battery to rule out old battery.
All battery has a service life of 48 or more month.

Also check the belt tension. When the 2 arrow / dot meet the it is worn.

A worn tensioner will not create enough frication to the alternator pulley.

Jan 15, 2014 | 2010 Chevrolet Equinox 1LT

1 Answer

96 chevy cheynne 5.7 vortechas about 40to50 pounds oil pressure when first sart in morning and when it gets to temp. it drops to 20to25pnds and at a stop it goes to 0 and gauge light comes on until i give...


Well it could be the sending unit for the gauge.
But odds are the oil pump or engine bearings are worn out.
As the engine warms up, the metal spaces expand and the oil gets thinner. The oil pressure drops some under normal conditions, but not more than 10 or 15psi. Normal idle pressure with the engine warmed up is probably 25psi.
You could check oil pressure with a mechanical gauge to make sure its not the sending unit.
Once the oil pressure starts staying below 20psi for long periods you'll start hearing noises.

Apr 13, 2013 | 1996 Chevrolet C1500

1 Answer

Corsa dosn't start very well when warm


fuel heater fault. there is a heater in line with the with the glow plug wiring ing heats the fuel for a good fire. when engine temp get to normal it turns off. if not working the engine just floods. folloe the fuel line till it goes into the cacing and look round that area for some were coming out that will be were the heater is.

Jan 16, 2013 | Vauxhall Cars & Trucks

2 Answers

This Sign appears on the dashboard , What Is the problem? VW eurovan


I m not familiar with VW Eurovan but, assuming your vehicle is diesel powered, I would say that the sign indicates a fault with the "pre-heaters" which should only come on when cold starting a diesel. Normally, this sign appears on switching on, and you wait until it goes out before starting.
Does this happen on your vehicle and, has this symbol previously gone out after a few seconds? There is a relay, on the starting circuit, which should cut these pre heaters, after a short while.
I see that your temp gauge shows 90 degrees so, he engine is hot.
Try disconnecting the leads to the glow plugs, check that the engine starts OK and see if the warning symbol disappears In warm weather you can leave the leads disconnected and, if you have a meter, check if there is still power to the glow plug leads after the engine has started. (a 12 v bulb and wire would do). It they are still powered, there is a fault with the glow plug relay.

Oct 06, 2012 | Cars & Trucks

1 Answer

I have a 1996 Honda Civic, it only overheats after driving for about 45 minutes, then it goes from normal to in the red immediately, If I turn the heater on it return to normal. There is no smoke coming...


Might have air in the system. With engine cool, take radiator cap off and start car. Let it come to operating temp and ensure fan kicks on/off as it should. Keep hands clear of rotating parts - fans, belts, motors. Replace cap and make sure there is water in the overflow reservoir.

May 25, 2017 | 1996 Honda Civic

1 Answer

2004 vw Passat TDI 130bhp not starting after >8hrs


simplest answer first,and this does not apply to a hot engine,The engine heaters work from a time switch on the door(would you believe)and the routine is, open door,climb in,put on belt,put key in ignition and turn on when orange light goes out.this allows the cold start heaters time to work(about 20 secs).sounds a pain but the number of times this has been all it is,when you put key in ignition, the fuel pump charges the system.hence the squirt noise,also the car has to reccognise the key(immobiliser system)also try using wynns/redexe to clean injectors...

Mar 11, 2010 | 2004 Volkswagen Passat

1 Answer

I have a 1988 mk 2 golf when i start the engine the heater warms up as normal but when the engine warms up the heater starts blowing cold air out. also now that the cold weather has started after driving...


sounds like the thermostat stickng as when engine gets cold the choke will start workin again, causing the over reving or your electric fan is on all the time "over cooling" the engine

Dec 22, 2009 | 1988 Volkswagen Golf

1 Answer

Temp goes to red and warning light come on,but goes back to normal after a while when driveing


An overheating engine will often shudder and make a unique popping/rattling noise. Is it doing that? If it ever does that it's time to call a tow truck or further risk major engine repairs.
Try turning on your heater. Your heater makes its heat by blowing air through a mini-radiator (like the one at the front of your car) and pushing that hot air through to the inside of the car. Is the air coming out of the vents warm to normally hot or I-just-opened-the-oven make your skin tingle hot? Check and make sure you have coolant (when the engine is cool) and fill to where it should be. There may not be enough to circulate through the cooling system but enough to hit the temp. sensor and give you warnings.

May 30, 2009 | 1998 BMW 5 Series

1 Answer

2004 Tahoe Heater Problem


check coolant level ,must be low ,chck for coolant loss

Mar 04, 2009 | 2004 Chevrolet Tahoe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

881 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...