Question about 1992 Chevrolet C1500

1 Answer

Faulty instrument panel? (1992 Chevy C1500)

I own a 1992 Chevrolet C1500 4.3L V6. I have a number of problems but the most recent and important one is the instrument panel.

My tachometer, speedometer, odometer, and the tripometer have all stopped working. My "CHECK GAUGES" warning light has come on, but my fuses are fine. I've ripped the whole dash off looking for a problem and the actual gauge "block" looks fine with no visible damage and I can't think of anything else...

My current solution is try even harder to get a job and drop $200+ on a new/used cluster...

Any help will be greatly appreciated.

Posted by on

  • dad73192 May 08, 2009

    1992 Chev K1500 4.3L-- CHECK GAUGES" warning light has come on.

  • cychase May 21, 2009

    my spedometer reads 85 when im doin like 55 all my fuses are fine i dont kno whats up but i need to get it fixed b4 i get a damn ticket

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You could possibly have a bad ground connection.

Posted on Feb 08, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1170 Answers

SOURCE: My bmw 318is instrument cluster doesnt work

The fuse must have blown off. Replace the fuse.

Posted on Mar 24, 2009

lastech
  • 408 Answers

SOURCE: I have a 1997 Mercedes E320 and the instrument cluster guages

hello,good day,maybe your cluster nearly damage,send to your dealer,they have a testing procedure(simulation all the gauges), to determine if your cluster is defective,ty

Posted on May 14, 2009

  • 3 Answers

SOURCE: 2003 F-250 instrument cluster...

the battery is probably below 9.5 volts which will make it do that its just like unhooking your battery cable end

Posted on Aug 07, 2009

Testimonial: "Good call. Battery was the problem Thanks, Mike"

  • 297 Answers

SOURCE: I have a 1996 VW Jetta, odomoter and speedometer

Either you have a broken wire some where from the speed sensor to the cluster or you have connector at fault, the one which hookup the dash cluster to the main wire bundel. Check the connector, maybe a pushed back pin !!

Posted on Aug 08, 2009

  • 1 Answer

SOURCE: instrument panel cluster gauges and odometer has stopped working

I had all my analog instrument panel gauges stop working after they did the state emissions test. I found the proper fuse in the fuse block located under the hood. Simply unplugged the fuse, noticed it was still good, and plugged the same fuse (10A) back in and all the gauges started working again. Guess it needed a reset atfer they plugged in for the emissions.

Posted on Aug 14, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1992 chevy c1500 with light issues. Left turn signal works fine, right side blinks like 4 ways,along with license plate light.when head lights are on nothing for right side turn signals. Hazards...


It seems to be a ground defect on right side. Do you have the same bulb's number . What about the front flasher. remove right rear lamp assembly remove connector measure voltage between ground and current .reconnect it measure voltage at bulb socket. you should find your problems
hope it helps

Dec 07, 2014 | 1992 Chevrolet C1500

1 Answer

1996 CHEVY C1500 4.3 V6 stalls and backfires and check engine is on


You need to have the PCM scanned to find out what the code[s] are, the problem could be a number of things.

May 11, 2011 | 1996 Chevrolet C1500

1 Answer

Heater does not work. Possibly fuse, need to know which fuse is for the heater. 1992 Chevy C1500.


1992 chevy c1500 5.7 front speakers and horn wont work ( wrong fuse or what)

Jan 25, 2011 | 1992 Chevrolet C1500

1 Answer

Oil guage jumps up and down 92 gmc sierra v6


I have a 1992 chevy cheyenne v6. I had the same problem, It was the oil pressure sending unit, 25bucks at your local parts store. Hope that solves your problem!

Nov 07, 2010 | 1992 Chevrolet C1500

1 Answer

Used transmission installed and doesnt shift at the right rpms


Ck your trans modulator., and if not already done, you pan filter and fluids

Jun 06, 2009 | 1992 Chevrolet C1500

1 Answer

1992 chevy 1500 with 8mpg


a lot of shops don't check base timing on the distributor. it could be the timing is set too low, or the module is not advancing{inside distributor} or another comon problem is a tear in the fuel pressure regulator. so pressure is too high all the time.

May 26, 2009 | 1992 Chevrolet C1500

Not finding what you are looking for?
1992 Chevrolet C1500 Logo

483 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...