Question about 2000 Mitsubishi Eclipse

1 Answer

We just bought a 2000 eclipse and replaced crankshaft sensor still has no fire.......getting plenty of fuel starters good cables good fuses great and ya please help!!!! sick car if it was running

Posted by on

  • toekneegotsn Apr 17, 2009

    your dead sexy thanx

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If its the 4-Cyl it may be the coil packs. I had this problem not too long ago..

Posted on Apr 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have replaced the camshaft sensor, Crankshaft sencor, computer, crankshaft pully, and new spark plugs on my 1999 Mitsubishi Eclipse and it still won't start, what could it be?


Engine needs spark, fuel and air to run. I assume the starter is turning the engine over. Have you verified you have spark at the plugs? Have you verified you have fuel pressure? Can you hear the fuel pump when you first turn the ignition key? If, yes to those, check the timing belt settings to make sure something hasn't caused the timing to change.

Mar 22, 2012 | 1999 Mitsubishi Eclipse

1 Answer

No fuel


It could possibly be a faulty Crankshaft Position Sensor. If the computer doesn't see that the crankshaft is spinning, it won't activate the fuel pump.

Mar 05, 2012 | 2000 Mitsubishi Eclipse

2 Answers

Starts and will idle but smothers down and will not take fuel. It seems to have plenty of fuel pressure. Also does the same cold or hot. Installed two new fuel pumps...


replace your crankshaft postion sensor and cam sharf position sensor they tell you car when to fire spark and to what cylinder to fire to they work hand in hand also check your spark it should be blue not orange if orange replace distributor and rotor

if this helps please give me good rating

May 06, 2011 | 1986 Ford Bronco II

1 Answer

Car dies going down highway hard to start afterwards it is a 1997 gs eclipse. what could be causing this


assuming the starter is good and the engine turn over fine but will not fire or run. when the car die, check why is it so hard to start. check if you getting sparks and fuel, no sparks check coil and wires,and if both are good than the cam sensor is bad, no fuel, check the fuel pump, pump good check the crank sensor.

Dec 23, 2009 | 1997 Mitsubishi Eclipse

2 Answers

Car turns over fine just won't fire? where should i start? checked all plug wires and car does have gas, I am broke and without car, any help would be great.


check the ignition module fuse.if fuse is good.have car scanned to look for ignition control module fault codes or crankshaft sensor fault codes.by using or have somebody with diagnostic scanner to check for codes this way you wont spend extra money guessing.

Nov 26, 2009 | Oldsmobile Alero Cars & Trucks

5 Answers

When the 2000 impala cools down I try to start it and it just clicks, I replaced battery and starter


It's not your starter or battery it sounds like a fuel problem to me, check and see if your fuel pump is working alright or not it seems to me that your engine is vapor locking every time your get your engine up to temp. and turn it off it's vapor locking your fuel system have your fuel pump and complete system checked out.

Sep 28, 2009 | 2000 Chevrolet Impala

2 Answers

My 2000 eclipse wont start up all the way


I have the same problem on my 2002 Eclipse RS 2.4l 4 cylinder. Replaced the battery, starter, fuel pump(not at one time) . It started up when I had the starter put on as well the fuel pump. But everytime I started the car up it ran good till I turned it off the problem was still there. The car sounds like it wants to start but it sputters you can smell the gas so I know its getting fuel. it starts up fine with a cold start like in the morning.

Try getting a diagnostic thats what Im going to do next week.
good luck!!!

Jan 24, 2009 | 2000 Mitsubishi Eclipse

2 Answers

Long crank time for 2000 olds intrigue 3.5


first thing i would do is replace your fuel filter.
with a fuel filter restriction it take longer to provide enough fuel pressure to fire.
that would be the most common but there are also may other things that could have happened but would need more information to do a process of elimination
good luck
paul

Oct 02, 2008 | 2000 Oldsmobile Intrigue

Not finding what you are looking for?
2000 Mitsubishi Eclipse Logo

186 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...