Question about 1998 Chevrolet S-10 Pickup

1 Answer

I have 1998 s-10 5 speed, sometimes has no response on take off usualy in the mornings then after about 15 min. or so it runs fine then when im leaving work it does it again and theres no check engine light has new fuel filter air filtr and altenator...help

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Change your plugs wires and coilpacks

Posted on Aug 06, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

txkjun
  • 409 Answers

SOURCE: 2000 silverado 4.8 v8 runs bad when it is cold out side.

Try replacing the coolant temperature sensor for the injection system.

Posted on Jan 11, 2009

  • 2 Answers

SOURCE: '07 Tahoe; check engine light on steady. Just came

Have a dealer or garage check your Oxygen (O2) sensor. As a quick fix, try disconnecting and reconnecting your car battery. Sometimes this will reset the check engine light.Good Luck!

Posted on Aug 01, 2009

csmock132
  • 4669 Answers

SOURCE: 96 s10 2.2 4cyl. running lean

I know you said new fuel pump and filter but I would recheck the fuel pressure. Drive the vehicle with the fuel pressure gauge on it and see if the pressure drops after 10 minutes.

Posted on Sep 02, 2009

Testimonial: "Thanks for your suggestions. It was the new 2 wk old fuel pump that was bad. Problem solved!"

  • 14036 Answers

SOURCE: 98 camaro 3800series v6 engine will turn over but

CLEAN FUEL INJECTORS.THEY COULD BE DIRTY AND CLOGGED UP.FILL GAS TANK UP.PUT A BOTTLE OF FUEL INJECTION CLEANER IN FUEL TANK.DRIVE CAR AROUND ENOUGH TO ALLOW CLEANER TO CLEAN OUT FUEL INJECTORS.

Posted on Oct 25, 2009

  • 1 Answer

SOURCE: 1990 vette stalls after 10-15 min. please help!!

i have the exact same problem, please let me know what the fix is. thanks

Posted on May 06, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why would my jimmy cut off sometimes while driveing and than run fine after sitting for a few minutes


im not sure but my jimmy will run great then i go to the store and come back out it wont start i wait 15 min and it starts right up , my problem was security sensor , see if the security light comes on when it happens if it does i would look into that

Jan 04, 2013 | 1998 GMC Jimmy

1 Answer

Going over bumps or bump roads, stearing shakes,pulls, at any speed fine after 15 min park


Please have a check at your steering rack and your shocks.

But I have a strong belief it could be your steering rack.

Rate this

Apr 15, 2009 | Toyota Tacoma Cars & Trucks

1 Answer

No Power at all.


My suggestion would be to replace the fuel filter, iver had this problem in my vehicles and replacing the fuel filter always seems to fix it

Jul 28, 2008 | 2000 Chevrolet S-10

Not finding what you are looking for?
1998 Chevrolet S-10 Pickup Logo

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...