Question about 1988 Dodge Ram 50

1 Answer

It loses power after 25mph

It loses power after 25mph

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Dodge Master
  • 21,873 Answers

Have you checked fuel pressure ?

Posted on Jul 31, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I rebuilt the TBI, Changed every sensor in the truck and replaced the heads. I still cannot pass the CA smog test


Check everything that is connected to a vacuum line, check the CAT and the injectors and last run a compression test.

Mar 13, 2014 | 1988 Chevrolet K2500

1 Answer

My 96 Toyota Tacoma 4 cyl manual suddenly started losing power while going up hills and accelerating fast. I can slowly get my truck up to speed on flat ground but not over 50mph. When I press the gas...


i would agree with them, i had the same thing go wrong in my gmc sierra replaced fuel pressure regulator and works great now, although you could get lucky and it be the fuel filter

Aug 25, 2013 | Toyota Tacoma Cars & Trucks

1 Answer

Oil light stays on at idle shuts off when driving


my first guess would be oil pump. if the pressure got low enough to make noises and lose power like that..
dont run it anymore until its looked at, damage may already have been done to the engine cylinders/bearings.. you may be saved by low pressure cutoff sensor, i hope so.. good luck

Jan 31, 2013 | 1999 Chevrolet Cavalier

1 Answer

My engine light comes on and I get an


well you need to go to local part house and get the code out most will let you know what the codes are but sound like your truck is going in to limb mode to save tranmission or somthig any way come back with the code can help better

Sep 28, 2009 | 2003 GMC Yukon XL

1 Answer

1996 oldsmobile lose power atfer it reach 25mph the low traction


Per your description, it sounds as though there may be a wheel speed sensor problem or a tire that is low on air pressure.
The traction control system on your vehicle relies on four wheel speeds to determine if the vehicle is in a skid or not. If the traction control system sees one of the wheel speeds lower or higher than the rest, it thinks your in a spin or skid and will reduce power to compensate and straighten the vehicle.
So, first thing to do is check all four tires and make sure they are at the same inflation rate some where between 28 and 32 lbs.
Next, disconnect the negative battery cable for 5 minutes, this will clear the module and let you start fresh.
Try that first before any parts are replaced.
Good luck and let me know.
Regards,

May 06, 2009 | 1996 Oldsmobile Cutlass Ciera

1 Answer

Starts, but wont move


Sounds like a broken axle (CV joint) or your transmission has gone

May 01, 2009 | Mitsubishi Mirage Cars & Trucks

3 Answers

88 Nissan z24i backfires through throttle body and loses power when in gear


Check your intake and exhaust modules. I have a 1987 D21 and had the same problem (if I understand your post). I replaced the modules located behind the driver side headlights and it fixed the problem. Good luck! I hope this helps.

Nov 04, 2008 | 1987 Nissan Pickup

2 Answers

88 festiva problems


Make sure your exhaust isn't clogged. Check all your vacuum lines, too.

Oct 27, 2008 | 1988 Ford Festiva

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...