Question about Cars & Trucks

Open Question

My ML350 Mercedes Dash Board stopped working

My ML350 Mercedes Dash Board gauges stopped working

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: THE DASHBOARD

I am having the same problem as we speak with my 98 Grand Am. I purchased a Instrument Cluster from a salvageyard and it send it into 'Theft Mode'. My local garage said they are going to try and do this to it...they heard through the grapevine that it would work...I guess we will see.


  1. Replace old IC
  2. Turn key over and then turn it back immediately
  3. leave key in the 'on' position (with lights and such showing) and wait for 10 minutes
  4. Turn key to 'off' position for :30
  5. Should reprogram itself at this point and work
Like I said ...they are doing this as we speak, so hopefully it will work and I can report back to you shortly that I saved myself $200 not having to have the GM garage reprogram it!!

Posted on Aug 29, 2008

chryslertech
  • 115 Answers

SOURCE: `dash board gauges stopped working

The printed curciut board on the back of the cluster has failed. I have replaced many of these for this problem.

Posted on Feb 22, 2009

artbesio
  • 55 Answers

SOURCE: dash board gauges not working on 01 aztek

open the driver side door there should be a panel right inside the door crease. if not they are up under the dash It's been so long since we sold our aztek I don't remember exactly but one of those two locations.

Posted on Mar 09, 2009

lhjh86
  • 60 Answers

SOURCE: Gauges stopped working

you have a bad fuse inter, panel fuse check your manual

Posted on Jun 15, 2009

eric_sage
  • 58 Answers

SOURCE: dash board gauges not working on voyager 2000

You need to check your main fuses under the hood first and then check them under the driver side dash board.

Posted on Jan 25, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What does the yellow battery indicator light on my 2003 Mercedes Benz ML350 dashboard mean?


Info here

http://www.autoguide.com/auto-news/2015/07/what-does-the-light-on-my-dash-mean-.html

Apr 09, 2017 | Mercedes-Benz Cars & Trucks

2 Answers

2005 ml350 dash cluster stopped working


Quite possibly a failed cluster. There are auto electricians that MAY be able to repair it.

Jan 21, 2015 | 2005 Mercedes-Benz ML 350

1 Answer

Gauges stop working and all dash board lights come on


You don't say what the make model and year is, but generally the gauges get power from the same place the gas gauge does. Each gauge is grounded thru a sending unit or switch.
So my guess would be a problem inside the instrument cluster.

Mar 06, 2013 | Cars & Trucks

2 Answers

The heat on my 2007 ML 350 stop working suddenly. The blower to circulate the air does not come on. What is the likely cause of this? The fuse is OK.


Need to check the blower motor resistor and the blower motor itself. They should be located under the passenger side dash.

Dec 12, 2012 | 2007 Mercedes-Benz ML350

1 Answer

2009 ml350 front wipers stopped working. What to do?


check for power and ground to the wiper motor first. then check for signal from the wiper switch.

Jun 02, 2012 | 2007 Mercedes-Benz ML350

1 Answer

Brake lights on mb ml350 don't work even after installing new bulbs


Rick,
The brake lamps on your Mercedes are computer-controlled. I would recommend scanning your computer network for possible fault codes.

Nov 18, 2011 | 2007 Mercedes-Benz ML350

2 Answers

I have a 1997 Mercedes E320 and the instrument cluster guages


hello,good day,maybe your cluster nearly damage,send to your dealer,they have a testing procedure(simulation all the gauges), to determine if your cluster is defective,ty

May 12, 2009 | Mercedes-Benz E320 Cars & Trucks

2 Answers

Ml350 2003, the wipers aren't working, front and


I have ML350 SE and my front wipers stopped working overnight (back wipers are working ok). I changed the fuse but it did not help.

Mar 12, 2009 | 2007 Mercedes-Benz ML350

1 Answer

My 2005 Ml350 rear wiper fluid is low.


Hi, The rear and the front washers both use the same resevior. I think the fluid level sensor is at fault.

Mar 04, 2009 | 2007 Mercedes-Benz ML320 CDI

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...