Question about 1993 Ford Explorer Limited

Open Question

Multiple Sensor Failure

I haven't had this car long and it sat for a while before I owned it a week or two after getting it and driving it I dealt with a no fire situation it turned out to be the crankshaft position sensor also replaced fuel pump sender unit and fuel filter since then it has been all down hill I had a problem with the engine lulling while idleing and the smell of gas changed plug wires add did a compression check they where all relativly the same though I noticed that the plugs where not all gaped correcly gapped them all put them in went to drive away fro autoparts store and stalled the smell of gas was really strong at this point figured the engine had flooded lw let it run noticed that the rear drum brakes had seized got it home saw the master cylander had gushed a bunch of hydralic fluid everywhere replaced cylander and bled brakes rear brake still grabbing and idle slah peformance dropped way dowI have found that these failed tsrs is th anh ssadomn engnine started back firing and the smell of gas is stronger that ever both the mass air flow and 0^2and the o^2 failed tests and Im starting to see codes for coollant temparture (haven't checked ye) haven't replaced any of them yet no money I also pulled the plugs and noticed that they where covered in what looked like oil but the plugs on the other side where ok no black sludge sorry the question is so long wjust wanted to include all the the information so my question is this Is there something in particuler that would be causing these sensors to fail all at once and also wanted to know if these could be symptoms of a bad PCm. Also how do you initiate a cylandor balance mode after koer test I've tryed to initiate it probably three or four times and havn't been able to

Posted by on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 44 Answers

SOURCE: 2001 ford sport trac put

It sounds like you have a bad motor or transmission mount. Open your hood, and have a friend start your vehicle, and put it into drive. Observe the engine to see what is vibrating.
Matt

Posted on Jun 26, 2011

  • 3 Answers

SOURCE: what causes 2000 taurus engine rough idle but no codes

remove neg. cable from battery so the ECM will reset this may work. make sure the IAC is air tight. if this doen't fix your problem have someone check the IAC valve if it's bad the part runs $300.00 pluse

Posted on Nov 25, 2011

roniecon
  • 6826 Answers

SOURCE: After my car stalling and then starting and not

Remove the mass air flow,and clean it with intake cleaner spray,or mass air flow cleaner spray,if this does not help,reset the system again,by removing the negative battery cable for at least 20 seconds,then put it back on,if this does not help,replace the mass air flow sensor

Posted on Jan 17, 2012

  • 444 Answers

SOURCE: My 1995 Mustang GT won't run right!

Your problem is it is a ford,LOL:

Posted on Nov 03, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 PT Cruiser Turbo won't pass smog test because computer monitors haven't completely reset after battery failure. It's been driven 235 miles and only 2 monitors remain unset (oxygen and


The system has to see a wide range of conditions before a smog test can be done. On most brands you have to drive at least 50 miles, at various speeds including stop and go, let it idle for 5 - 10 minutes, and run at freeway speed for at least 25 miles. It also has to reach normal operating temp of 195 degrees.

Apr 22, 2013 | 2004 Chrysler PT Cruiser

1 Answer

Truck shuts off while in park idling.


Your car is 18 years old. It's likely history. Sell it as is for what you can get.

Jul 15, 2017 | 2000 GMC Yukon Denali

1 Answer

Car doesn't idle


could be the crank positioning sensor, they will act up after the car gets to operating temp.

Aug 07, 2012 | 1994 Toyota Corolla

1 Answer

Distributor sensor replaced but car started to shake


If the sensor is in the dist, the dist shaft could be worn and slowly damaging the new sensor.
Could also be a new problem.

Jun 24, 2012 | Cars & Trucks

1 Answer

I have a 1999 Navigator. The heat will not get warm. It blows out cold air for about 20 minutes and then changes to


well the system is ok your blender doors might not be opening or you your heater controls board is bad if your temp gauge reads at half way mark

Jul 21, 2017 | 1999 Lincoln Navigator

1 Answer

2000 toyota avalon v6 multiple random misfires.....and misfire number 4 cylinder


Sounds like HT Leads as you haven't mentioned them above? not being familiar with the car I would say distributer but by the sounds of it your leads go straight to the coils. Crank sensor might be playing up aswell.

Nov 26, 2011 | Toyota Cars & Trucks

1 Answer

2001 vw bora (equivalent to US jetta) 1.6. Every morning it requires 1 restart and some idle time before driving otherwise it cuts off as soon as i turn out my driveway. My mechanic says a O2 sensor needs...


First of all, there is no such thing as "cheating" an oxygen sensor. I don't care what other people may tell you or what claims may be on the packaging of whatever you are pouring into you tank. I have been in the business for 36+ years and I can tell you from experience that people that try to do things like this end up paying WAY more to get their cars fixed because of the damage that results from continuing to operate a malfunctioning vehicle while trying out all the "miracle cures". There is no such thing as "mechanic in a can" and the people that sell that junk are nothing more than modern day snake oil peddlers.

There is no way to "tweek" the idle RPMs on an engine that has computer controlled idle speed (which is what your vehicle has).

Continuing to operate the car with a defective oxygen sensor will destroy your catalytic converters which can also cause all kinds of drivability problems (if they haven't ALLREADY been desroyed). If you think you are strapped for money to get an oxygen sensor replaced, just wait until you see what it is going to cost you to replace your converters....you better start bankruptcy procedures now, while you still have wheels to get to the lawyer's office.

My recommendation: Bite the bullet and get the thing fixed!

Aug 11, 2011 | 2001 Volkswagen Jetta TDI

1 Answer

I replaced the MAF sensor on my 2004 camry 4cyl two weeks ago and cannot get the EVAP or Catalyst code to reset. I've had multiple techs drive to reset these and have had no luck! Do you think I...


what do you mean by reset?? are you talking about drive cycles not completing?? you tring to pass emissions? some veh will take up to 500 miles!! to go through all drive cyles ..or are you actually talking about a evap code I.E. p0440 and a cat codeI.E p0420??? if thats what your talking about those will need a repair to get those cleared

Jul 28, 2011 | Toyota Camry Cars & Trucks

2 Answers

Have a gmc 2005 sierra the 4x4 doesn't work. when I press the 4x4 button blinks a few times,and then makes like grinding sounds,it sounds that is coming from transfer case,but never engage and ligth goes...


Not good! there is a sensor in your transfer case that senses that you are now in four wheel drive if your transfer case does not lock in it will set a code and the light will flash and default back to two wheel drive. check the fluid level in the transfer case and front differential for a sign of internal failure. that is causing the grinding sound.

Feb 05, 2011 | 2005 GMC Sierra

Not finding what you are looking for?
1993 Ford Explorer Limited Logo

Related Topics:

74 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5481 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...