Question about 1999 Mitsubishi Montero Sport

1 Answer

Engine3.0 fuel studdering problens car starts car will not move transmission fuel is high gaspump works just goes nowhere

Posted by on

Ad

1 Answer

Does it Start
Does it idle nice
Does it go into gear
Does the motor increase in speed ok in park
Does it back up
Are you saying you have a transmission problem
Did you check for codes & google them
Has a repair shop worked on the issues

Posted on Jul 24, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Loss of power, studdering at high rpms when at temp.


Sound's like it break down due to no oil or water circulate
the engine. Or wrong spark plug gap. So it increase too much heat.

-Try this:
1. Flush the engine. Flush the coolant.
2. Check spark plug gap (Adjust to correct gap)
3. Check oil pressure. If it's low then new oil pump is need.

Good Luck

Mai

Mar 22, 2017 | 1996 Chevrolet S-10 Pickup

1 Answer

My 1999 4x4 4.3L blazer studders in gear after warm a few mins on city streets and highway, it comes and goes? i have done complete tune up and fuel filter and fuel pump. it studdered less i think af


Check owners manual or manually check to see if there is another fuel filter. Sometimes vehicles have more than one fuel filters which are overlooked until they have problems with them. Most have a filter right along the frame.

Aug 23, 2012 | Chevrolet Cars & Trucks

1 Answer

1998 ford escort 4cyl..5sp clutch slips in all gears ...RPMS shoot up 3500-4000+...car goes nowhere....shifter doesnt hang up or kick out of any gear/ no grinding noise...goes in & out 1 thru 5...


It seems like your clutch plates are not closing properly. This could be a problem with the linkage, or the plates might be worn out. If you are not trained or experienced in doing your own transmission work, I would recommend taking the car to a transmission mechanic to have it serviced. The clutch plates might be stuck in the neutral position (to test this, put it in gear with no parking break on and try to push the car while it is off. If the car moves while in gear but turned off, then your clutch plates are not connecting, and you will need to have it repaired. If the clutch is connecting, the car will not move when in gear with the engine off, and it is more likely an issue with the linkages (but this seems unlikely from your description).
I recommend you take the car to a mechanic either way, to make sure that (even if you get the problem to stop for a short while) you will not get stuck on the side of the road somewhere. I know transmission work is expensive, but it is worth the money to be sure you are going to make it all the way to your destination every time.

May 26, 2011 | 1998 Ford Escort

1 Answer

My 97 Legacy started to studder when stepping on the gas from a dead stop. It does not seem to studder at higher speeds. Do you thing the Fuel filter may need to be changed?


My 97 Legacy started to studder when stepping on the gas from a dead stop. It does not seem to studder at higher speeds. Do you thing the Fuel filter may need to be changed?

May 10, 2010 | 1997 Subaru Legacy

1 Answer

When driving car goes studders have to gas more


change plugs (make sure gap is right), plug wires, coil (if applicable) make sure you are using good fuel i rec'''d conoco gas...
if you had work recently done then i would also trace it back to that.

Jul 14, 2009 | 1997 Jeep Cherokee

1 Answer

On dash gaspump light


The sending unit in your tank is bad replace it.

Aug 06, 2008 | 2000 Dodge Intrepid

Not finding what you are looking for?
1999 Mitsubishi Montero Sport Logo

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8575 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...