Question about 2004 Kia Optima

1 Answer

P0201 My 04 Kia which just had the crank sensor changed as well as all the timing components is now not running and giving me a code of P0201. It ran ok after changing all these parts. It had a bit of a rough shake but only when you came to a stop and in the drive position. Once you shifted to park it ran smooth again. I drove it about 17 miles stopped it and now it will not start.

Posted by on

Ad

1 Answer

Have the shop pay to tow it back to them &
continue on & try & resolve things correctly
the second time around

Posted on Jul 18, 2013

Testimonial: "who said a shop did anything?? I changed the timing components myself. If a shop had done it I would have called them first. DUHH!"

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
robshow
  • 367 Answers

SOURCE: 2004 kia optima

Try the ignition switch,

For the Crank sensor there is a small metal disc that mounts behind the sensor if that is cracked or dammaged or installed backwards you will get same results as if it wasn't Make sure the timing marks line up on your timing belt. www.kiatechinfo.com

Posted on Jan 19, 2009

  • 4 Answers

SOURCE: 2000 kia sportage ex, 4 cyl.

Many of the Kia sportages have a problem with the coils.

There are 2 coils for each 2 cyl and they are located under the middle platic cap on the valve cover.

These coils will set a check engine light that blinks when misfiring and stays on steady when the motor is running smooth. Autozone or Advance auto have a scanner that can check all engine functions and will show a problem with # 2 and 4 cyl.

The coil packs are $39.00 to replace but check the codes first

Posted on Feb 17, 2009

  • 1 Answer

SOURCE: 2002 KIA Sedona running rough

i may have an answer for you i have an imported v6 3.8 it has recently developed similar problem, i have been looking on www.kiatech.com whcih is very informative, there is a technical bulletin on my model (06) that refers to possibility of faulty o2 sensors which may or may not be the cause of the problem, it also gives me part numbers, check out the site look up your own model it may give you the answers
you can check out the main manuls or look up past technical bulletins (tsb)
good luck

Posted on Mar 24, 2009

landsend
  • 1066 Answers

SOURCE: 2002 Kia Rio runs rough when idling

well spend some change and have a simple tune-up.  Plugs and filters and readjust the idle.

Posted on Apr 01, 2009

  • 40 Answers

SOURCE: my 98 kia sportage wont crank.

http://www.kiatechinfo.com/index.asp

Good source for Kia its free to register NO STRINGS

Posted on Jun 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kia carens 2008 crdi not starting when hot, turning over easy, new battery fitted, any ideas greatly appreciated, starts fine when cold.


run the fault codes
not starting hot indicates an electronic component problem when hot
could be faulty cam/ crank position sensors, immobilizer or ECM

Jun 16, 2016 | Kia Cars & Trucks

2 Answers

Engine rolling but not starting p0750, p0755 andc0701 diagonised what solution do u give


P0750 is the trans shift control solenoid valve A , P0755 is shift control solenoid valve B .C0701 can't find the trans codes wont keep engine from running. If crank sensor was replaced it should be ok it only tell witch two cylinders are up. The cam sensor tell witch cylinder is at tdc to fire. Check for fuel and spark , if both present check map/maf sensors tp sensor then ecm/pcm.

Jan 03, 2015 | 2008 Kia Rio

1 Answer

I have a 2003 kia sedona van 3.5 liter that jumped time. I reset the timing put a new belt on it and it ran good for 35-45 min. Then it cut off, and wouldn't start back up. It has an OBD2 code for cam...


cam sensor fail can be crank sensor fail engine will run with cam sensor fail but crank it will not fire. also recheck the timing belt settings you fit the timing belt and run engine till warm then recheck the belt adjustment to make sure its in line and at recommended tightness.

Aug 07, 2017 | Cars & Trucks

1 Answer

I have a 2007 jeep patriot. It stalled at stop sign started ran rough. Parked came back drove it home ran u- scan code p0017 replaced crank and cam sensors still runs rough changed plugs were bad. I was...


code p0017 refers to crank/ cam oosition sensor bank 1 sensor B -correlation ===causes --wiring--CKP sensor--CMP sensor--mechanical fault.
It also refers to control modules, cooling fan--no signal===causes -- wiring--ECM.
If it has a timing chain then the the advice that it will not be the chain is good. So I suggest checking out the cam/ crank sensors and wiring

Oct 22, 2013 | 2008 Jeep Patriot

2 Answers

2003 kia sedona replaced crankshaft position sensor 6months ago would start again same code plus p0431,0335,0300,o303,0302. replaced sensor still gives a hard code sensors bad. tightened timing belt ,...


first why and how did you tighten the timing belt. if was loose should just replace the timing belt that belt runs the timing.the code po335 is your crank position sensor and it is coming up the engine is fight to keep the timing. replace the timing belt. the codes po300,po302.po303 are for a rarandom misfire. when was the last tune up. change the sparks plugs

Nov 02, 2012 | 2003 Kia Sedona

1 Answer

Timming belts and OBD2 codes.


Its possible the gears are not on the right marks.
Have you checked cam timing since replacing the second belt ?

Sep 03, 2012 | 2004 Kia Optima

1 Answer

2002 optima no spark or fuel


indicates a failed timing belt
do a physical check that the rockers are moving when cranking the engine over

Jul 08, 2017 | 2002 Kia Optima

1 Answer

I have a 2003 Kia sedona ran out of igas now wont start the code I get say crank posistioning sensor will that cut or cause the fuel pump not to work cause I get no humming from it the code is p0335


No this does not affect the fuel pump. It will affect the spark though. Hit the gas tank in the center a few times. If it starts then replace the fuel pump. Unfortunetly pumps with a few yaers on them will die when ran out of gas. If it doesn't start pull one of the spark plug wires, insert a screwdriver and put it close to the engine. crank the engine and watch for a spark. if there is no spark then replace the crank shaft sensor. before you replace the fuel pump.

Jul 01, 2011 | 2003 Kia Sedona

1 Answer

P1320 code appeared and we replaced the cam position sensor. It ran OK, but started rough until warm and next code showed #1 cylinder misfire. Replaced #1 coil and it ran great. Then later the engine light...


i just had the same problem in my bmw 325i. Probably vaccum leak or exhaust leak. Check that nothing came loose in these areas. It takes time for your car to learn the new CPS (cam pos. sensor) so give it a few days and reset the code again and see if it works.

Mar 12, 2010 | 2000 Nissan Maxima

Not finding what you are looking for?
2004 Kia Optima Logo

208 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8274 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...