Question about Cars & Trucks

1 Answer

My speedo sensor is plugged in but my speedometer still doesn't work on my 2002 Mitsubishi lancer

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 14,036 Answers

VSS sensor faulty more likely.

Posted on Jul 14, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix the speedometer needle when it doesnt move from below zero?


no make or model or year so here is a guess
if it is a cable driven speedo --replace the inner cable
if it is an automatic ---replace the VSS on a later car or the sender unit on an earlier model

May 13, 2016 | Cars & Trucks

1 Answer

My 2002 Mitsubishi lancer won't start i changed my


Check that your plug leads are pushed all the way onto the plugs.
Check that your plug leads are connected to the correct plugs.
Check that your plugs aren't contaminated with oil after removal of the rocker cover gasket.

Did you remove the cam shaft sensor wire? Check that for it's connection.
If you removed any connectors at all, then check them all again.

Nov 11, 2012 | Cars & Trucks

1 Answer

One headlight doesn't work


have you tried replacing the bulb or checking whether it is seated correctly

May 07, 2012 | 2002 Mitsubishi Lancer

1 Answer

Sensors for speedometer


check the cable connected behind the speedo and see if it is turning while in motion. if it is then the speedo will need to be replaced. if it doesn't then look for the sensor which should be at the other end of the cable.

Mar 22, 2012 | 2000 Plymouth Voyager

1 Answer

What do you mean cluster contacts bad !Whats the solution?


Remove the speedometer head unit, and check the soldered joints on the back. It's a common problem with these and some Chrysler products. "Randomly" is when the crack closes and makes contact, like if you hit the top of the dash and it starts working again. The speedometer head cluster.

Feb 24, 2010 | 2002 Mitsubishi Lancer

1 Answer

99 lancer,speedo tacho n gauge problem.


probably burnt or cracked circuit board on back of gauge cluster

Jun 21, 2009 | 2002 Mitsubishi Lancer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...