Question about 2003 Chevrolet Silverado 1500

1 Answer

Abs light is on and no oil gauage is on zero - 2003 Chevrolet Silverado 1500

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 21,873 Answers

You can either start with checking the computer for trouble codes, or check the engine oil pressure by replacing the sending unit or hooking up a mechanical gauge.

Posted on Jul 14, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 95 ford tauraus rpm shifts up and down irradicly and the speedometer stopped working


Sound like a vehicle speed sensor go to bad. If this is right, the RMP dont showing details.

Feb 27, 2013 | Cars & Trucks

1 Answer

Gas gauage is not working


their should be a reset button on the dash push and hold it

Feb 16, 2012 | 2001 Oldsmobile Aurora

1 Answer

My oil pressure gauage reads 0 pressure and oil light is on yet my oil is full ?


chang your oil pressure sending unit that should fix u up

Dec 20, 2010 | 1996 Dodge Dakota

2 Answers

My ABS, brake and oil lights keep coming on at the same time, flashing for a few minutes and then going back off. This happens very randomly, sometimes lasting for seconds, sometimes lasting for up to 20...


Its exactly the abs module! and its keeping the ecu from communicating with the rest of the car, when you remove the module your tac will come back alive and the oil light will turn off. There is way to trick the ecu to thinking the abs module is working but it involves taking out the module, it is fairly simple. My email address is superbikevoodoo@yahoo.com, email me, and I will give you pictures and instructions on what to do. Its really easy, your abs and break light will go off along with the beeping!

Oct 16, 2009 | 1999 Volkswagen Passat

1 Answer

ABS light,brake light, tachometer to zero, oil light, a/c


i can guarantee that you have several shorts in your wiring harness that is leading to all of your accessories and switches. find the electrical shorts and you will fix your problem. also your sensors (idiot lights) are popping on because of defective connections in the wiring. also check all of your relay circuits and fuses.

Jul 26, 2009 | 1999 Audi A6

1 Answer

ABS light, brake light, tachometer to zero, oil light, A/C


This sounds like a bad ground or poor connection maybe in the main plug that connects at the firewall. The last thing to condemn would be the computer. I have come across a good many of this thing on the older model cars and trucks, and all you can do is search it out.

Jun 28, 2009 | 1999 Audi A6

2 Answers

Help me please.....


You must use 10W30 oil in the summer. On really hot days, when you are stopped and in drive, the oil pressure will drop to almost zero (according to the dash gauge).
If this is not happening under the above conditions, you need to place a shop gauge in the oil sensor sender port and test for proper pressure. If it is low (out of spec), you need to ensure the oil sump is not plugged in the crankcase. If it's not plugged, you need to replace the oil pump and fast!

The ABS issue is probably caused by the EBCTM module on the back of the ABS modulator, loose fuse, or bad connection to the module. Affects the cruise and PS as well.

Mar 15, 2009 | 2001 Cadillac Catera

1 Answer

1984 chevy S10 oil gauage


replace the sending unit, this is what the do when they fail.

Jan 29, 2009 | 1984 Chevrolet S-10

1 Answer

1984 S10 oil gauage on dash


The Sending unit or the Gauge is bad

Jan 28, 2009 | 1984 Chevrolet S-10

Not finding what you are looking for?
Cars & Trucks Logo

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...