Question about 1994 Toyota Camry

1 Answer

Po305 error code

A month ago I noticed my camry xle starting to run a little rough. A few weeks ago my check engine light came on, then it started flashing , but still stayed on. I noticed the car started running rough like a bad plug or something and it sounded like it was missing. I did a cheap diagnosis with a meter I have and it said po305. I changed the ignition coil. I drive the car after and it drove very smooth, better than it has in a long time, but after awhile the car started doing the same thing. The next day I started it and it was driving good.I had a friend with a very expensive diagnosis meter check out the engine and he said all cylinders and engine reading were good. My friend lives 10 minutes away. It seems it starts out good, but when it warms up it starts driving bad. I had a friend change the plug today, on the same cylinder and it still runs rough. I will have the fuel injector changed next. My car has 338,000 miles on the original engine. Can anyone give me advice on what this could be?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Toyota Master
  • 21,873 Answers

With that many miles, I would expect to find the injector as the issue. But it could also be a sticking valve. Or a valve that has problems opening as the oil gets hot. You may want to do a compression test hot and cold too.

Posted on Jul 12, 2013

Testimonial: "I use ngk plugs for the camry. I took the intake manifold off and cleaned the injector and switched it with one in the front. The car sounded good and the error message did not come back but I think something was not placed back right. The car makes a whistling sound now and it never did that, and the idle is high now. I guess I have to take it to the shop and someone go over my vacuum hoses now. I cleaned the injectors out pretty good, so I hope that was the problem. Oh yea, I cracked this piece that on the back of the manifold intake. I think it's some kind of valve or selenoid valve(not sure, but it has two hoses that go to it and at the top it has a hole where a allen wrech or something can be used on it). But I crazy glued it back together. Went to the wrecking yard but I couldn't find one.I guess my son will be happy taking apart that car again."

  • carl Jul 17, 2013

    The injector was removed from #5 cylinder and was cleaned. It was switched with another one. The car runs good, smooth and excellent. The error message went away. The only problem is the oil light came on and started flashing. It did not do this before the intake manifold and other parts were disassembled. If I accelerate the gas, the oil light goes off. But if I just drive regular the light stays on. I do have qa leak from the main seal, but it is not that bad and I keep oil in it. The oil was low a quart but I put more in and the light stayed on. I am having the oil pressure sensor changed, but I am having a hell of a time finding out where it is located. I think it it below the alternatror on the side of the engine. I tried to take it out, but there is a big black plastic switch with wires coming from it and I am having a hard time taking it off. Is this the right location for the oil pressure switch and do you have to lower the alternater belt to get to it?

  •  Stephen
    Stephen Jul 17, 2013

    The oil pressure switch should be on the side of the block above the oil filter.

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1861 Answers

SOURCE: check engine light on

Did you use the correct plugs? When I mean "correct", did you buy them from a Toyota parts dept? Those engines are designed for a specific plug, and if you have the wrong ones in it, expect problems. many times I have had customer come in with poor driveability, and it turns out to be that they installed aftermarket plugs.

Posted on Sep 09, 2008

emissionwiz
  • 75822 Answers

SOURCE: 1993 camry running rough

Make sure you don't have a faulty fuel injector, this may be the cause, also use a can of carb spray and spray around the intake gasket to check for leaks, if one is present you will notice a diff in the engine sound when the spray hits it.

Posted on Nov 02, 2008

  • 1861 Answers

SOURCE: 99 tacoma

Still need the codes.
Injectors can go "bad" in a couple of different ways; all they are is an electromagneticaly controlled nozzle. When the ECU "fires" the injector, it pulses a ground circuit for 4-8 milliseconds, the electromagnet powers up, the valve at the bottom of the injector opens, and the fuel shoots out, under pressure. The wire can be bad/chafed/corodded/ The electromagnet may be weak. The nozzle may be stuck. Lots of things. But, to put in an injector for a number 4 cylinder misfire (p-0304 code) would be one of the last things that I would do.

Posted on Nov 21, 2008

  • 12 Answers

SOURCE: 2000 toyota tundra #5 cylinder misfire

i think #5 is on driver side the front one....

Posted on Dec 30, 2008

michigan man
  • 3533 Answers

SOURCE: engine running rough and check engine light on

he plugged up the fuel filter try changing that first and if that helps then he won't need to replace the whole pump

Posted on Jan 18, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1991 Toyota Camry running rich after cleaning the throttle body and replaced the throttle positioning sensor. Checked for vacumm leaks but cant find any


92 camry failed smog because running rich. Why? - Toyota Nation ...

www.toyotanation.com/.../411132-92-camry-failed-smog-because-runni...

Apr 26, 2012 - 15 posts - ‎9 authors
off ignition timing, and the car was running to rich. the timing i will get fixed tomorrow but the rich .... Our 93 camry le with 4 cly engine failed agin a few weeks ago, both our toyotas always fail.. they are .... 1991 Toyota MR2 V6 91 MR2 N/A Rough Idle, Running Rich, No Accelleration
10 posts
Apr 24, 2012
Celica 1991- Insane gas consumption/running rich
10 posts
Jan 24, 2011
22RE Running Rich, didn't pass smog
10 posts
Apr 25, 2010
1998 Camry 5SFE 4-cyl idle long-term fuel trim
15 posts
Sep 11, 2007
More results from www.toyotanation.com

Toyota Camry running rich Questions & Answers - Fixya

www.fixya.com > Forum > Tags > running rich > Cars & Trucks > Toyota
... running rich I have a 1991 Camry that is running rich. I just replaced the O2 sensor and a new cat, oil change, new spark plugs. The car wont pass smog. it is ...

1992 Toyota Camry XLE V6 Excessive Running Rich ...

? 0:21
https://www.youtube.com/watch?v=WPTCtLwr61g
Aug 16, 2013 - Uploaded by StreetSports1
1992 Toyota Camry XLE V6 Excessive Running Rich ... 1997Toyota Camry V6 forward Oxygen (O2) Sensors .

Jan 11, 2016 | Toyota Cars & Trucks

1 Answer

1996 camry check engine light flashing,running very rough poor acceleration


Goto autozone/advance/pep boys and have them do a free OBD check with a scan tool. Most likely the O2 (oxygen) sensor(s).

Mar 08, 2014 | Toyota Camry Cars & Trucks

1 Answer

I replaced a new battery in my 2010 xle Camry and the car won't start. The security light keeps flashing


use a code reader to reset the CPU that was corrupted from the battery change over.

Jan 09, 2014 | 2010 Toyota Camry XLE

2 Answers

I began to have issues with my '05 Hummer H2 a few weeks ago.....


P0496 = "Evaporative emission system high purge flow"


At the dealership, we get a lot of complaints like yours and they all started with running too low on fuel or running out.


Start with replacing the fuel filter and get back to me.


Running low/out tends to suck up micro trash from the bottom of the gas tank and that gunk clogs the fuel filter.

Feb 02, 2013 | 2005 Hummer H2 SUV

1 Answer

Having multiple intermittent problems


I guess the overall answer is yes it could be the ECM.
Code 16 is high or low system battery voltage.
Code 21 and 22 are both for the throttle position sensor.
And code 43 is for the electronic spark control which controls engine spark timing.
The ECM grounds various relays to make things happen such as turning on the cooling fan. So a faulty ECM could cause all of the symptoms. But so could a wiring problem in one of the harnesses.
Especially a ground problem somewhere.
If the alternator suddenly starts overcharging the system the ECM can shut down the car to protect the circuits. Unusual, but possible.
This info may not help much, but somebody is going to have to test the circuits when the engine dies or when the symptoms happen.

Jul 11, 2012 | Cars & Trucks

1 Answer

1998 Plymouth Breeze


change your sparkplug wires that will salve yor problem

Sep 16, 2008 | 1998 Plymouth Breeze

Not finding what you are looking for?
1994 Toyota Camry Logo

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8201 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...