Question about Cars & Trucks

1 Answer

Cooling fans will not go off on 2005 mercury montego

When engine is cut off fans keep running, have to unplug fans to get them to go off. doesn't matter if engine is left over night they come on when you plug them up

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 21,873 Answers

Sounds like the fan relay is stuck on. Have you checked it ?

Posted on Jul 11, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
DJGray
  • 56 Answers

SOURCE: 2005 mercury montego message center

LOL!!! I had the same problem. I can't recall the exact steps, but there aren't that many options, so you'll get this. With the car running, press the Info button on the left side. It will cycle through the various statuses of the car. At one point, it will get to the Oil and will tell you something like "Press Reset if New." Press it and hold that darned button until it acknowledges that you changed the oil. It will reset that message from 0% to 100%. It took me a couple of tries to get that to reset. Just keep trying it till it resets. You'll get it.

Posted on Mar 02, 2009

  • 371 Answers

SOURCE: Change the oil on a 2005 Mercury Montego

Go to a automotive store and tell them you have a 2005 Mercury Montego and what engine it has if there is more then one model and get an oil filter and the oil. Put the car up on ramps and secure it making sure it won't roll back or fall while you are under it. get under the engine and look for the oil pan which should have a bolt in the bottom of it where you can drain the oil. Drain the oil in a proper container and then put the drain plug back in the pan. Then find the oil filter and unscrew it and remove it.. It could be full of oil so watch out and make sure the pan is underneath the filter. Wipe the base where the oil filter screws on and make sure the gasket from the old filter is not still on the engine. Get your new filter and take your finger and put it in one of your new containers of new oil and spread that on the gasket of the new filter. Screw on the filter until the gasket touches the base and then turn only a little more then a 1/4 to 1/2 turn tops. Do not over tighten the filter. Find out what oil the vehicle needs (probably 5-30) and look for the oil cap on a valve cover under the hood. It probably takes 5 quarts but check for sure in your manual or ask when you are at the automotive store. Put the oil in and put the filler cap back on. Now go start the vehicle and make sure you have oil pressure by either the oil pressure guage showing pressure or the oil pressure idiot light goes off and while running check under the car for any signs of leaks. If no leaks then back the car off the ramps and shut the car off on a level surface. Let it sit 10 minutes and check for leaks underneath the car and check the oil dipstick to make sure the proper level of oil is in the engine. Then you are set.

Always check your air filter when changing oil to make sure it is clean as that helps your engine run better and you save gas in the process. Good luck

It is also best to change oil when your engine is warmed up as well.

Posted on Mar 28, 2009

  • 371 Answers

SOURCE: Oil change light

Look up the light on the part of your owners manual that explains what each idiot light is for on your dash. That should give you a page where more information on it is available. Part of that section should state that if maintenance is done by someone other then your Mercury dealer, then do the following to reset the light. That should take care of ya.

Good Luck

Posted on Dec 15, 2009

  • 5537 Answers

SOURCE: Mercury Montego won't start. Started 10 minutes

You could check the Inertia switch and see if the fuel pump is cut off.
If that is Okay I would disconnect the battery and see if the system reboots.
If it starts after that, go to Autozone or Oreillys for a free scan.
If it does not start, then try putting in the security code if you have a keypad. If no keypad, then try your other carkey, your ID chip may have died.

Posted on Dec 27, 2009

  • 608 Answers

SOURCE: Why does the fan keep running on 2005 jetta after turning off

You are talking about the thermo electric cooling fan, its operation is independent of the car's electical system. It is switched on and off by the engine temperature. When you park, the engine heat soaks upward to heat the thermostat turning the fan on. It will run until the engine cools down and the thermostat switches it off. Quite normal operation.

Posted on Apr 19, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Need entry code for used 2005 mercury montego dealer went out of business


contact the manufacturer( ford) , engineer department and as them for the code
you will need vin number , year , rego number engine make etc

Jul 28, 2016 | 2005 Mercury Montego

1 Answer

2005 Mercury Montego AWD CVT engine mount how to tell if bad


If the mount is bad the engine will lift up when you hold the brake and add a little throttle, it will really jump up of the mount is broken, some movement of course is normal.

Jul 24, 2012 | Cars & Trucks

1 Answer

My mercury montego idels too fast and when you put it into gear it jerks the transmission


This car has an automatically controlled idle speed system, so when you have a problem like this you must have the dealer run what is called an active engine running test, the test puts the engine through the paces and returns data to show possible problems.

Jun 07, 2012 | 2005 Mercury Montego Luxury

1 Answer

Ext. temperature gage doesn't work on mercury montego?


Okay, the first thing is this may just be a bad sensor, the sensor is located on the front of the truck behind bumper area,Make sure the sensor is not unplugged or is touching the condenser or radiator. the sensor should be mounted so that it is not touching anything, the tip of the sensor is what reads the outside temp,
If the sensor is mount correctly and is plugged in then replace the sensor with a new one and that will solve the problem. good day.

May 06, 2012 | 2005 Mercury Montego

1 Answer

2006 Mercury Montego won't start. Not battery related, but just as it turns over and seems like it is going to start, it doesn't. Also, the check engine light stays illuminated. I don't know what to t


I have a Montero and it won't start with the key in the engine compartment but it will only start using my key pad what should I do i did just get another battery the other day could that be the problem

Dec 27, 2011 | 2006 Mercury Montego

1 Answer

I have a 2005 Mercury Montego. It is making a high pitch whining sound when the engine revs. It is louder when going up hills or when the engine is reving harder.


first thing to check is proper tension on all the belts, if they seem good and not worn,, check for vacuum leaks , a bad hose, or one that has come disconnected will cause this too

Sep 01, 2011 | 2005 Mercury Montego

2 Answers

How do I fix the problem of my cooling fan not turning off when the egnition isnt running for my 97 mercury cougar?


If the fan finally shuts down when after the motor is cool, then it is probably doing what it is supposed to.

Has it always done so?

If it hasn't always done so, or if it doesn't cut off, you could have a bad fan relay..... usually availablr at autozone or your local copy....

Jun 12, 2011 | 1997 Mercury Cougar XR7

1 Answer

Ac does not cool at slow speeds or at idle


check that the fans are running on slow speed all the time the AC is turned on ,if not this is your problem

Jun 15, 2010 | 2005 Mercury Montego

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...