Question about Cars & Trucks

1 Answer

My speedo and odo stopped working on my 91 s10 blazer? Is it the sensors or the gauge cluster?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 21,873 Answers

Usually when both stop working, the problem is the speed sensor in the transmission.

Posted on Jul 11, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

dennymulford
  • 1055 Answers

SOURCE: 91 s10 blazer engine surges warm and cold, stalls

tps sencor or maf sencor

Posted on Jan 24, 2009

rockitman187
  • 2559 Answers

SOURCE: S10 blazer speed sensor where's location for replacement

On the rear axle.

Posted on May 06, 2009

  • 7 Answers

SOURCE: 99 lancer,speedo tacho n gauge problem.

probably burnt or cracked circuit board on back of gauge cluster

Posted on Jun 21, 2009

  • 122 Answers

SOURCE: p0500 speed sensor code, odo and speedo not working

If one speed sensor goes out, it will make your speedo stop working. I believe the sensors are about 200 a piece. You'll have to take it to the dealership to find out which one is malfunctioning as there are 5 of them total (I'm pretty sure). They only charged me 30 to put it in as it is really easy and that way it is warrantied by them.
One other problem I had was with the electric brake controller on my truck went haywire and when I disconnected it, my speedo came back to life.
Hope this helps!

Posted on Jan 31, 2010

bbbman78
  • 680 Answers

SOURCE: What do you mean cluster contacts bad !Whats the solution?

Remove the speedometer head unit, and check the soldered joints on the back. It's a common problem with these and some Chrysler products. "Randomly" is when the crack closes and makes contact, like if you hit the top of the dash and it starts working again. The speedometer head cluster.

Posted on Feb 24, 2010

Testimonial: "Great that explains it well Thanks"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My speedo and odo stopped working on my 91 s10 blazer? Is is the sensors or the gauge cluster?


Easy way to tell if its a sensor that's bad is to try the cruse control

Jul 11, 2013 | Cars & Trucks

1 Answer

My mileage meter stopped working


If the speedo work and the odometer doenst you'll have to get a new instrument cluster. If speedo and odo both dont work, its likely the vehicle speed sensor in the transmission.

Jan 10, 2010 | 1995 Honda Accord

1 Answer

Speedo has suddenly stopped working also the mileometer has also stopped? please help


If you can hear it while your driving its the speedo and not the cable. Replace speedometer or whole gauge cluster.( What ever is easyer) You can find one on ebay. It could also be the speedo sensor on the top back half on the engine. REAL EXPENSIVE! Even for a used one. About $150 bucks for the sensor. And about the same for the Cluster.

Oct 06, 2009 | 1992 Toyota MR2

1 Answer

99 lancer,speedo tacho n gauge problem.


probably burnt or cracked circuit board on back of gauge cluster

Jun 21, 2009 | 2002 Mitsubishi Lancer

1 Answer

Speedo not working


try replacing the speed sensors.

Jun 20, 2009 | 1999 Chevrolet Venture

3 Answers

The oddometer works but the speedometer doesn't in my 1992 Dodge Ram pickup. The gear that sits inside the transmission is not stripped and engages fine. Can the problem be somewhere other than the...


Could be a bad cluster. If one is cable driven, and the other electric. You could have a bad speed sensor in the transmission which will make the speedo not work.

Jun 09, 2009 | 1992 Dodge Ram 250

3 Answers

Turn signal relay switch, 94 s10 chevy blazer


The Turn signal relay on a 94 s10 blazer is located under the cluster area right behind the panel that holds the parking brake release handle you will see it once a couple of trim panels get remove it will be to the right side of the brake release handle

Nov 18, 2008 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

68 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...