Question about Cars & Trucks

Open Question

This battery tester stopped working

Hi, I bought this tester from The Source a couple of years ago and it had been working. I hadn't used it for several months until the other day when I took it out of it's container to use it on some AA batteries I had. One of the batteries was new and the other two I wasn't sure about. The tester did not work on all three. The same thing happened when I went to The Source. I haven't mishandled the product and don't know why it stopped working. Thank you, Barbara Todd

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 32 Answers

SOURCE: Problem in 1st gear with manual transmission

if the idling of your engine only dies off at first gear, you may have a clutch problem. check first if you have fluid in your clutch fluid reservoir, or if its cable make sure that the cable is pulling the clutch lever for a reasonably long travel. there may be leaks in your clutch master or slave cylinders. If your engine behaves well during neutral. it has to be a clutch problem

Posted on Nov 09, 2008

  • 3 Answers

SOURCE: 2003 Dodge durango sport all four power windows not working

I know its not what anyone would want to here but sounds like a short. Best thing to do is first wiggle your key switch when the vehicle in in the on position then at the same time try to check to see if locks or windows are working. Then do the same in while the rig is running. If that dont work your ignition is fine and you need to take off door panels and check and wiggle all conections on window motors and lock motors and look for melted or burt wire or some that might have got hot. If all is good there you need to go to the back of the fuse box were the fuses to those items plug in and check there. As far as the service engine light goes either take it to the nearest Schucks or AutoZone and they will check it for free if not cycle the key on and off 3 times and on the 3rd time leave it in the on position look at your odometer light and it will flash a code remember that code and type Dodge then the code on yahoo search and it should tell you why your light is on Hintz whay sensor is bad. Hope this helps.

Posted on Apr 05, 2009

  • 320 Answers

SOURCE: BATTERY DIES OUT IN 2-3 DAYS.

are you saying that you got this battery from autozone? I went thru three batteries in a week from autozone because the lot# was bad. It,'s quite possible that you have either a short that is draining the battery or that the alternator isnt charging properly. To do a fast check, start the car then remove the positive battery cable with the car running. If it stays running, theres a chance its ok. If it dies, It's most likely the alternator or the voltage regulator Diods. On most cars, the voltage regulator is built into the alternator. I would take it to autozone and have the charging system checked

Posted on Jun 03, 2009

SOURCE: i bought an audi a3

Hi Anne,
With all vehicles using electronic computer management systems, there is always very low consumption of power from the battery, as these systems are running all the time. However even with those systems running you should be able to leave the car parked for a period considerably longer that one week.

As the AA has confirmed that the charge rate is correct from the alternator, I would suspect the replacement battery. Make sure that the size (The amp hour capacity is correct for your vehicle) If it's too small the systems may drain it during the time indicated....

I doubt very much that you have a short circuits in the vehicle, but to be on the safe side take it along to a shop who have an auto electrician and let them carry out the relevant tests.

I suspect the battery.

Regards Johngee10

Posted on Jan 25, 2011

  • 85 Answers

SOURCE: 2003 Nissan Altima car alarm

hand it over to a mechanic or Nissan. If you recently had an M.O.T and it went of quickly then ask for a refund, even better, ask him to take a look at the car again

Posted on Jul 02, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 Chevrolet Aveo hatchback - lighter/12v outlet fuse blows


it sound to me like the lighter plug itself is loose and when you released the parking brake wiggled the plug enough to short out and blow the fuse . check to see if the plug is loose .

Apr 20, 2013 | 2004 Chevrolet Aveo

1 Answer

My 2003 Mercury Mountaineer has an electrical problem. It started about a year ago with the key fob not working, I have bought 3 and all won't work even after re-programing. now tonight I went to


Could be a windshile leak down the A-Pillar & water
gets into the delayed accy relay for the GEM Module
(Body Computer as ford called it for a few years) & you
get what you have now

Try Goolge as I did a few weeks ago for a relative
He had the same issue with the blower being on &
killing the battery

No real fix I found for the windshield leak
Seem a robot didn't put the rubber sealant
on correctly at the factory fo about 5 years
on several fords.

If it isn't water related then the GEM Module
controls all those body features

If you get a used one & match up the numbers,
you supposedly can avoid buying a reman gem
& the expense of having to reflash it to your factory
built combination

Jan 27, 2013 | 2003 Mercury Mountaineer

2 Answers

My car won't start in the cold weather. I don not have Power Locks or Power Windows. What is the Problem?


That sounds like a battery issue. Batteries have whats called CCA (cold cranking amps) it is the main thing to pay attention to. This is a measure of how much current the battery can provide at 0 deg F. Batteries work better when they are warm, so the colder it gets, the less current it can provide.

Starting an engine requires a lot of current, over a very short time. Meanwhile, cold engines are harder to start, requiring more power to get them going. So look at your battery and its CCA and since u said u bought the car a few years ago. You probably didnt replace the battery yet have u? Batteries usually have a life of 4-6 yrs only. Hope this helped

Jan 23, 2013 | 2003 Saturn ION

1 Answer

Help! Changed battery but still don't work for a long time


you probably have a short in the amplifier under the driver's seat. I had the same problem. Bought mine used, but the amp had water damage due to the vents for it on the left side of the driver's seat letting in water, probably snow or something that fell in there. Was $1200 to replace. Basically your car will be fine for a couple weeks, maybe a month then the battery will die.

Aug 01, 2012 | 2004 Saab 9-3

1 Answer

2004 Chevy Cavalier engine light and trac off light


One year ago---your check engine light came on
The PO405 code was for an EGR Valve issue
No mention--- if you had that fixed

A Few Days Ago---you get Trac Light on,that is part of
the ABS Braking System
Now that system has to be diagnosed & repaired,not just
continue to use the car,actually make the repair, before
you do some damage or can't stop the car & worse things happen

Changing Trans Fluid---is NOT a FIX for anything,but should
be done on all vehicles every 3 years.

If the Engine Management System isn't working correctly,then
your trans won't work as it should either

You need to be proactive & immediately have any abnormal
operation or check light problems, at least diagnosed in a few days
of noticing them

You need to stop using any car that isn't 100% & have it
repaired as soon as possible.

Not wait weeks or years.
Being 9 years old, the trans may also have it's own issues

Jun 09, 2012 | 2004 Chevrolet Cavalier

1 Answer

No sound from radio


My FM band stopped working. AM and casset still worked. Found parts car, replaced radio, all is good. The FM display still worked-no sound.
Terry

Jun 02, 2012 | 1995 Jeep Grand Cherokee

1 Answer

2000 neon new battery starter clicking


could be a number of things. like the regulator for the altenator sticking. the memory on aftermarket radios could do it. Also amps if you have one.

Dec 31, 2011 | 2000 Dodge Neon

1 Answer

I hadn't run the car in a couple of years so, I went and got new battery. The dash and everything comes on but all I get is a clicking sound when I turn the key. I heard it could be a seized stater...


try putting the battery on charge for at least 24 hrs as i have a funny feelinjg it could be your new battery has been on the shelf for too long

Aug 01, 2011 | BMW 325 Cars & Trucks

2 Answers

Driver's side window will not roll up. All other windows work fine. Help


replace window regulater and moter...after you chech for power inside door on the plug in at window motor with a circuit tester...

Aug 09, 2009 | 2000 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...