Question about Cars & Trucks

1 Answer

I have a 92 bonnevile it cut off 15 minutes of driving I change the coil pack throttle position sensor upstream o2 sensor tune up camshaft sensor mass air flow sensor math sensor it is still cuts off

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 21,873 Answers

Are you loosing spark to the plugs or fuel to the injectors when the engine stops ? You have to know which system to troubleshoot the problem.

Posted on May 09, 2013

  • 2 more comments 
  • king owney May 10, 2013

    New fuel injections it don't have a spark to the plugs when the engine stops

  •  Stephen
    Stephen May 10, 2013

    Ok, well thats the system you need to check out. You may need a repair book to get the flow charts for the ignition system including wiring diagrams.

  •  Stephen
    Stephen May 10, 2013

    You did not mention the ignition control module the coils connect to. Did you have it tested or try a used module ?

  •  Stephen
    Stephen May 10, 2013

    And are there any trouble codes stored in the computer ?

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
grease16
  • 58 Answers

SOURCE: 92 CHEVY BLAZER K1500 WON'T START

try messing with the radiator because it is most likely overheating

Posted on Dec 02, 2008

  • 108 Answers

SOURCE: 96 tacoma 4x4 2.7 engine cuts out randomly, like

dont look for air when the car cuts out its most likley spark or fuel when it cuts out ranomly its usually a sensor or relay that is faulty check fuel pump relay and camshaft or crankshaft sensors but first narrow it down to spark or fuel if possible also if check engine lite is on check codes

Posted on Mar 26, 2009

c17hydro
  • 2984 Answers

SOURCE: MASS AIR FLOW SENSOR REPLACEMENT & DIAGRAMS

Very easy for the Mass Air Flow Sensor....it is in the duct between the throttle body and the air filter box. Just unclamp the tube and remove the old and replace with the new.

13d0cec.jpg

On your pack....I need the engine size.


Posted on Mar 26, 2009

redbeard00
  • 957 Answers

SOURCE: i have a 1997 lincoln continental v8 4.6l will not start

Just hearing the pump alone is not enough. You may be right and the fuel system could be fine. But you have to know what the line pressure is on fuel injected engines.
When the tune-up was done was the air and fuel filter changed. Sometimes people get a tune-up but the filters were not done or included in the service.
I would guess that it has to do with the fuel system.
Did the engine light come on and if so were any codes stored and/or retrieved?

Posted on Apr 30, 2010

  • 3 Answers

SOURCE: I have replaced the throttle position sensor, egr

Check the Idle accelerator valve located on front side of throttle body, it is either stuck or needs cleaning real bad, this is what controls your idle speed, by letting small amount of air in. It has a plunger on it that moves back and forth slowly to adjust amount of air mixture, it is controlled by computer. Unplug it and just turn on key and check for voltage.This valve gets real gummed up, probably need to take apart throttle body and clean. HUNT

Posted on Jun 07, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What does error codes 40 and 41 mean on my 1999 mitsubishi eclispe mean


11 Oxygen sensor fault.
12 Airflow sensor fault.
13 Intake air temp sensor fault.
14 Throttle position sensor (TPS) fault.
15 Idle speed control (ISC) motor position sensor fault.
21 Coolant temp sensor fault.
22 Crankshaft position (CKP) sesnor fault.
23 Camshaft position (CMP) sensor fault.
24 Vehicle speed sensor (VSS) fault.
25 Barometric (BARO) pressure sensor fault.
31 Knock sensor fault.
32 MAP sensor faulty.
36 Ignition timing adjustment signal fault.
39 Oxygen (O2) sensor fault.
41 Injector(s) fault
42 Fuel pump fault.
43 EGR fault.
44 Ignition coil (cylinders #1 & #4) fault.
52 Ignition coil (cylinders #2 & #5) fault.
53 Ignition coil (cylinders #3 & #6) fault.
55 Idle air control (IAC) valve position sensor fault.
59 Rear Oxygen (O2) sesnor fault.
61 Transaxle control module torque reduction signal fault.
62 Variable Induction control (VIC) valve position sensor fault.
71 Traction control (TC) vacuum valve solenoid fault.
72 Traction Control (TC) vent valve solenoid fault.

Sep 26, 2014 | 1999 Mitsubishi Eclipse

1 Answer

Service engine light flashs when accelerating to speed over 65mph.


Flashing check engine light means that the catalysator can be damaged. There is most probably something wrong with the O2 sensor(s). Did you check for any fault code set in the PCM?

Aug 12, 2014 | 2002 Jeep Grand Cherokee

1 Answer

Car starts thin cuts off after a couple of minutes driving spark plugs will be all black and worn down even if I put New ones in new coil pack camshaft camshaft sensor crankshaft sensor and wires timing is...


Hi. whats your car?. year, make, model ect. how long does it take to kill the soark plugs? have you got the wright coil pack? ie for electronic ignition, with/without ballast. need some mor details please. Jon

May 03, 2014 | Cars & Trucks

1 Answer

2002 GMC ENVOY 4.2L While the service engine soon light was on received code p0171 but the light didnt stay on. When going down the highway it loses acceleration and when you try to press the gas its as if...


Your vehicle has electronic throttle control .Position sensors in the gas pedal an throttle postion sensors at the throttle body tell the PCM/ECM -engine computer , how much your foot is pushing on the gas pedal an where the throttle plate is located . These postion sensors wear an can cause this problem ! I suggest you take your vehicle to a qualified repair shop an have it diagnosed .

Apr 17, 2017 | Cars & Trucks

1 Answer

Car is a 2004lincoln ls v8...its misfiring in cylinders..had a tune up didnt help,computer said throttle accelerater stuck closed and sounds like transmission is slipping?????


There is no tune -up for your car

I have the same car ,V8 --- only spark plugs


You have a bad COP Ignition Coil -- give us the code PO301 thru PO308

Change the front (2) O2 Sensors at 100,000 miles

Change spark plugs every 3 years or 60,000 miles

Clean MAF Sensor once or twice a year

If the Trans Slips ---STOP USING IT -- & change the solenoid pressure
control pack, inside trans oil pan

The bad coil is spiking the PCM & the signal comes back on the TPS
Sensor & you get throttle body (TACM) codes,forget that,work on the coils

Aug 11, 2011 | 2004 Lincoln LS

1 Answer

I have a 98 Hyundai accent. Won't accelerate over 50mph


the o2 sensor will cause overfuelling and an improper throttle position.
the heater circuit has 12v,and the other 2 wires are a reference voltage.
you need to use a scanner and look at the live data to see what the 02 sensor is doing.
after battery disconnect,the monitors have to set using a drive cycle of which you can get from hyundai.Typically to set the 02 heater circuit,the car has to idle for 2 minutes when cold,and then drive at 55mph for 3 minutes with the a/c on.

Feb 13, 2010 | Hyundai Motor 1998 Sonata

1 Answer

Engine light is on...


P0137--O2 Sensor Circuit Low Voltage-Bank 1 Sensor 2

P0139--O2 Sensor Circuit Slow Response-Bank 1 Sensor 2

P0152--O2 Sensor Circuit High Voltage-Bank 2 Sensor 1

P0300--Random Multiple Cylinder Misfire


I would suspect that the camshaft position sensor is bad. This is a quote from the tech manual:

The Powertrain Control Module (PCM) uses the camshaft position sensor to manage sequential fuel injection and as part of misfire diagnosis. The PCM constantly monitors the number of pulses on the signal circuit. The PCM compares the number of camshaft sensor reference pulses and the number of crankshaft position sensor reference pulses received. If the PCM receives an incorrect number of pulses, Diagnostic Trouble Codes (DTCs) should be stored in the PCM. Some PCM systems will then default to multi-port or "gang-fire" injector operation. The camshaft position sensor signal is required to sequence the injector operation to the proper cylinder timing. If the camshaft position sensor or circuit is faulty, most engines will start. However, the PCM misfire diagnostic will likely be affected.

aa26193.jpg
5ac44c6.gif
The part costs $50.....simple to change. It is NOT the O2 sensors so don't go wasting money on those. They are being affected due to related symptoms....they fault because the problem is happening upstream.

Oct 01, 2009 | 2002 Dodge Intrepid

1 Answer

92 CHEVY BLAZER K1500 WON'T START


try messing with the radiator because it is most likely overheating

Dec 02, 2008 | 1999 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...