Question about 1999 GMC Sierra 3500

1 Answer

I have changed my fuel pump about 6 months ago. But it was a used one. Anyway my truck started driving bad and my check engine light would blink on and off and at times would stay on. But it didn't happen all the time. So went to the store and went to get in truck and it would turn but not crank at all . So I had a guy come look at it and he said it wasn't my fuel pump it was my ignition switch now he is saying both are bad what are the odds of this happening

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 1,051 Answers

You can have someone stand by the truck and they should hear the pump kick on when you turn the key in the on position. Can you spray fuel into the throttle body and will it start that will tell you if the ignition is ok or not and also tell you if you have fire to the cylinders. If it start right up and shuts off you either have a bad fuel filter, fuel pump or a plugged catalytic converter in the exhaust system.

Posted on Jun 10, 2017

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: 1997 GMC K1500 4x4 5.7 ex.cab SFI injection system

Did you check the fuel filter?
or possably the catalitic converter is cloged, check the exhaust pressure.

Posted on May 27, 2008

emissionwiz
  • 76118 Answers

SOURCE: truck starts but won't stay running

You may have a problem with the contacts in the ignition switch (not key part), when you crank the engine a signal is sent to the fuel pump to run, when it starts and you let off the key another set of contacts keeps the pump getting power Through a relay), these are known as crank and run modes.

Posted on Aug 04, 2008

Mike258
  • 1498 Answers

SOURCE: 1997 GMC K1500 4x4 5.7 ex.cab SFI injection system

Hey there boatright33,

A few things things immediately come to mind.

There may be a problem with the engine controller. You could check the ODBII onboard diagnostics. Auto part stores will usually do this for you at no cost.

When you pulled the ones that were/went bad, how did the filters look? Could there be particulate matter still in the tank causing them to fail.

I always put this one off until last. Check the injectors. Are they gummed up?

Let me know what you find out
Mike


Posted on Aug 12, 2008

emissionwiz
  • 76118 Answers

SOURCE: shuts off while driving. no fuel pressure. pcm fuse blows/ fuel pump relay inserted.

Sounds like the fuel pump is shorted.

Posted on Nov 03, 2008

  • 2 Answers

SOURCE: 2000 GMC Jimmy will not start

The oil presure switch does have some bearing on the problem but my suggestion is to change the coil. I had a the same problem with an astro van. I changed everything that you have described and it fixed the problem just for a little while and then all of a sudden did it again. I changed the coild and the cold start swithch and never had the problem again.

Posted on Nov 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

P0302 #2 cyclider misfire


Sounds like the pintle in the #2injector is not properly seated allowing fuel to drip into that cylinder when the engine is off .

Dec 10, 2012 | 2000 Mazda Millenia

1 Answer

97 bonneville cylinder 6


I would say a zero chance of the fuel pump being the cause.
Could be the spark plug, wire or coil - or a vac leak or the fuel injector.

Sep 27, 2012 | 1997 Pontiac Bonneville

1 Answer

I got a 1999 ford ranger with a 2.5l it runs smooth at idle, an runs smooth while drive but bad fuel economy. when u rev up at idle an let go of the throttle it runs rough an then smooths out. ive...


You have two coils on this engine. Test each wire for spark with the engine running. You'll find at least one wire not sparking. replace the coil that has the wire that's not sparking.

May 14, 2011 | Ford Ranger Cars & Trucks

1 Answer

No fuel getting to engine. Possibe fuel pump. Replace fuel filter with aftermarket brand 6 months ago.


possibility that's it's the pump, the fuel pump relay, check the relay and pump for power/ground etc.
Although you changed the filter 6 months ago i wouldn't X that as a possibilty, i always try to change parts with Ac Delco or another OEM equivalent brand.
Could also be injectors, test the resistance at each one, however if none are giving gas then it's extremely rare that they all died at once.

Feb 07, 2010 | Plymouth Voyager Cars & Trucks

2 Answers

Couple of months ago would cut out when but start immediately


hallo
I dont belive it is air that is cousing your problem. Think it is more an electrical isue. I have had some problems with relay module (engine bay, near engine computer). And check fuel lift pump.
hope it helps
Marko

Sep 23, 2009 | 2006 Peugeot 604

2 Answers

1995 Camaro wont start


how did the car start back up if u said it never started back up ever since it got hot when u were driving up the hill? sounds like u need to get a compression check on the engine u might have blown the heads

May 25, 2009 | 1995 Chevrolet Camaro

2 Answers

2000 s10 Blazer dies very 3-6 weeks for no reason


i would check your ignition system. you would need a meter for this but look for broke or loose connections. if it was a fuel problem i dont think it would just start up after 20 minutes. or you might try your ignition switch. if its shorting or something then ya well it would cut your engine off real quick

Mar 20, 2009 | 2000 Chevrolet Blazer

1 Answer

3 problems speed sensor, check engine light, light on instrument panel


I have a 1991 Accord EX with the same problem.
The speedometer does not work at all and the "S" light continues to flash. I took a chance and went to my local auto wrecker and bought a used VSS (speed sensor) for $20 and that fixed my problem.
Ken
Canada

Jun 09, 2008 | 1991 Honda Accord

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...