Question about Cars & Trucks

1 Answer

Car is rough idling and shaking a little. Replaced plugs, air filter, coil. All made a little better but still not fixed. I looked at my injectors and one was wet and one was dry?? Not sure I'f that's normal. 03 dodge caravan v6 3.8 Any other ideas?? I think maybe bad gas but I got close to 20 gallons of it...

Posted by Anonymous on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 134 Answers

Take your car for a compression test to see if there is any vacuum leak causing the engine to run rough. Also, this could be due to a bad MAF sensor or an O2 sensor. If the check engine light is ON, you should better get the codes read.

Posted on May 03, 2013

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 2005 Mazda 3 idles rough at stop light and sometimes dies

The problem is a faulty solenoid in the vapor recovery system. The solenoid is sticking open and allowing fumes from expansion of fuel in the fuel tank to enter the air intake and smother the engine. This is how the Mazda service tech explained it to me. It is a known problem on the Mazda 3 in various trims which Mazda refuses to acknowledge. Usually the check engine light comes on and the engine diag code reads mass airflow sensor, which is incorrect. I dealt with this for 6 months on my wife's 2005 Mazda 3i before the dealership figured it out. My cousin bought a 2007 Mazda Speed 3 which developed the same problem after a few months and was cured by the same fix.

Posted on Aug 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix a multiple misfire with a rough idle and auto transmission that shifts rough. I have an obd 2 trouble code PO300?


need to find out why the misfire bad coil ,wire ,wrong plug gap etc check injectors and fuel presure --what ever is causing misfire is also probably causing problems with transmission shifting

Oct 16, 2016 | Cars & Trucks

1 Answer

Code 303 - not electrical, what should I look at next?


Check for either a leaking injector flooding the plug or a clogged injector causing a lean misfire. Also, the injector driver in the PCM may be bad not commanding the number 3 injector on and off.

Nov 17, 2015 | Geo Cars & Trucks

1 Answer

Replaced plugs and coil pack on 2001 ford taurus now car will not start


You will need to figure out if you have spark to the plugs, and if not- if you have voltage to the coil to proceed.

Aug 04, 2012 | Ford Taurus Cars & Trucks

2 Answers

Car is idling rough all coil packs have been changed along with spark plugs


Dont get another harness. If you are using Autozone supplied coil packs, the problem is most likely the coils from Autozone. I have went through this exact same thing before. I changed the coild because one had a burn mark on the boot between the plug and the coil pack. I noticed it when changing spark plugs. The new coil from Autozone made the vehicle struggle on take offs and idle rough and the vehicle had no power. I installed another coil from Autozone again which was supposedly a better model and costed more. The vehicle ran a little smoother but the rough idle and small misfire was still there. I installed another coil from the dealership and the problem was fixed immediately.
I also replaced one of the coil connectors for a different cylinder but only because i broke it when disconnecting the coil packs to remove the spark plugs.
And when I installed all my coils and the new one from Autozone, I used dielectric grease on all the connectors. But the rough idle and power loss was immediate following installing the new coil from Autozone.
Beware if you are using coils from another part store because many part stores get their parts from the same source.

Jul 18, 2012 | 1996 Volvo 960

1 Answer

I have just bought a 2001 Oldsmobile Alero. When I purchased it I found that it was shaking a little when in idle. I took it to a localAuto Zone and had then look at it and they said it was a misfire and...


did you change plug wires? try first,then try some fuel injector cleaner-LUCAS Brand if can get,if still the same- fuel filter ands air cleaner are next on list...

May 06, 2011 | Oldsmobile Alero Cars & Trucks

3 Answers

U i have a 97 ford escort that idles rough so i replaced the wires and plugs it still idles rough but runs a little better the coil shows spark on all cylinders any ideas


Often, on the Escorts of this vintage, rough idle can be due to a leak in the vacuum system. With the engine running, listen closely for any tell-tale hissing sounds coming from any of the vacuum hoses. Check that they are all securely in place and the end-clamps are all tight. Also check that the PCV valve and the hose connecting it to the manifold are securely in place. Another possibility is the Idle Air Control (IAC) valve. If it is clogged or sticking, it can cause rough idle. Refer to a service manual to diagnose the IAC valve. Other things to check: make sure that the air intake is unobstructed and clean. You might consider cleaning the manifold and throttle body. Check the air filter and replace if necessary. Let me know if you have any other questions.

Apr 02, 2010 | 1997 Ford Escort

1 Answer

1996 chevy cobolt 6 cyl. "engine power reduced" idols extremly rough shaking entire engine. When pushing on gas pedal car will sputter acting like it wants to die.


It sounds like you have a fuel issue or spark issue. Pull your spark plugs and see how they look. If they look fine then test the fuel pump. You could try to run to fuel system cleaner through the fuel system and see if there is an improvement in idle. Could be any of the following problems,

coil
spark plugs
spark plug wires
fuel filter
fuel pump
injectors
air filter

Check the easy stuff like plugs, wires fuel pump and air filter first.

Mar 03, 2010 | 2009 Chevrolet Cobalt

2 Answers

We just spent alot of money to get it fixed.


the valve train adjustment is off! what you are experiencing is a leaking valve issue check the compression it need's to be!! 125 psi per cylinder

Jan 22, 2010 | 2001 Nissan Quest

2 Answers

Hi, I have a 2006 Altima with 31,500 miles. Recently, the engine start shaking when car is Idle but I still feel the shake when driving or at red lights. My second problem is a weird loud (humming) noise...


You don't need to change the spark plugs since it has only 31.5 K. The plugs should last 60K. There is a an adjustment at the gas cable end at engine to increase the idle a little bit. You can increase rpm at idle to 600 RPM. Since your RPM at idle is low that why it is shaking at idle, red lights. Let me know it it is shaking at high speed ( 2500 RPM)

Sep 13, 2009 | 2006 Nissan Altima

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...