Question about Cars & Trucks

Open Question

1992 s10 power loss

The engine back fires .won't run smothly.. changed EMC.. Dist.. Coil.. wires.. coolant sensors.. EGR.. Dist Cap.. Plugs.. Rebuilt Throttle Body..changed Cat, Conv. Oxegen Sensor.. still back Fires..

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No fire thru coil wire


no,the pump wouldn't do that. Pull the dist cap and crank the engine,make sure the rotor spins,may have sheared the pin one the shaft.

Feb 09, 2014 | 1988 Ford F 150

1 Answer

1995 s10 4x4 truck runs rough at mid speeds


Are you getting any codes on it? There is two things you might want to change. The first is ya coil and then try it to see if that helps, if not then it could be ya pickup coil in the distrib. And another one is ya map sensor may not be reading air intake right.

Dec 01, 2012 | Chevrolet Cars & Trucks

5 Answers

Truck wont crank. we have put new distributor cap, rotor button, coil pack, plugs, wires, and fuel pump. we also checked our firing order.


you said you repl dist cap that means you don't have a crank sensor you have electronic ing module. remove your elec ing module have it tested most auto parts stores could test your module, or check your coil at the neg terminal. should have power. if not you lost your primary volt from your batt.your secondary power is coming from your electronic ing module from the module to the pos terminal on the coil, when the eng cranks,from the coil to the dist cap , from the dist cap center to the rotor then out to the plugs,this all happen pervided the timing belt or timing chain is ok. the cumbustion chainber needs 3 things , thats fuel, air, and spark.

Apr 17, 2011 | 1996 Chevrolet K1500

1 Answer

I have a 1991 ford f150, just changed dist cap, wires, plugs, tps, egr coolant temp sensor & the battery. started briefly then stopped. it cranks but won't start. cant afford to take it to the shop....


Make sure all your wires and connections are correct. Make sure everything is put back on. If everything is, it may be a cam sensor, crank sensor, ? Double check everything.

Mar 06, 2011 | Ford F-150 Cars & Trucks

1 Answer

My 1993 Taurus GL is experiencing a loss of power. Hesitates on acceleration and will lose power if I go over 40 mph. Spark plugs were changed, air filter, coolant sensor etc. No resolution. What can cause...


I have a 1993 Taurus GL V6 3.0L..I"am experiencing a loss of power. Hesitates on acceleration Only when It's cold.When is get hot it runs very good. I have Replace Spark Plugs Cap & rotor were change air filter & fuel filter & TPS/EGR..... & it has a rebuilt ENG in it...this could be a sensor. But which one could it Be?

What Can This Be?

Nov 02, 2010 | 1993 Ford Taurus

1 Answer

I have a 95 s10 4.3 which starts nd runs fines


spider injection is a common problem with these vehicles, is it consuming gas more than usual, is the oil smelling like gas? The spider is located under the upper intake plenem. There is also a fuel pressure regulator connected to the spider assembly that may be faulty.

Dec 31, 2009 | 2000 Chevrolet S-10

2 Answers

Weak spark from dist cap to plugs. spark from coil primary is as it should be. Plugs were carbon fouled from rich condition. this is a 92 bronco 5.8 windsor motor.changed out plugs,cap,rotor,and remote tfi...


The engine is definitely in an over rich fuel condition if you are blowing black smoke. I would suspect a bad 02 sensor, but the flooding condition you describe at starting could be other things. I would check the codes and proceed from there.

Jul 13, 2009 | 1992 Ford Bronco

1 Answer

There is no power going to the dist cap. I put a new coil in but this did not fix it. The spark plugs will not fire. Everything works but the plugs will not fire. The engine just turns. Ichecked the wires...


U have a power wire that has been breached ur gonna have to check continuity to ur power wire at the coil and dist hook one lead to the fuse that supplies power and other lead to to same circuit under hood at coil repeat step with all wires on coil and dist just to be sure.

Apr 03, 2009 | 1992 Plymouth Voyager

1 Answer

1992 Cadillac DeVille idling problem


Hi,you can run a fuel presure test to see if the fuel pump is working properly, you can also run a timing chain text ,this is a little complicated but you may be able to do it , take the distribuitor cap off,with a ratchet turn the crankshaft back and faward,if the rotor takes to long to move the chain is worn out,this can cause loss of power, I hope this will help.........

Jun 14, 2008 | 1992 Cadillac DeVille

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...