Question about 1992 Mazda MX-3

2 Answers

Alternator/battery problem ifferent alternators and 2 batteries in it. The belt on the alt is new. when its running the alt belt is not running fast enough to charge the battery. I just installed a new alternator and battery yesterday, and still the same thing can anyone help me I know this is an easy fix. When I jump the car the alt belt runs fast then when I take the jump cables off it slows down.. any advice?

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mazda Master
  • 14,036 Answers

Either drive belt too too big or drive belt tensioner broken or drive belt need adjustment if you have v type belt.

Posted on Apr 26, 2013

  • littlemisski
    littlemisski Apr 26, 2013

    Where is that located. I have two belts one for water pump and the other for the alt

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Mazda Master
  • 75,051 Answers

Duplicate questions

Posted on Apr 25, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 393 Answers

SOURCE: BATTERY LIGHT STAYS ON.

i believe your over charging ie; voltage regulator bad. should only have between 12-14.5 volts max when testing at bat with volt meter

Posted on Dec 03, 2008

  • 67 Answers

SOURCE: Battery replaced - won't hold a charge. Is the alternator the problem?

THE BATTERY IS ONLY FOR STAR THE CAR. WEND THE THE CAR IS RUNIG ALTENATOR IS CHARGING THE BATTERY FOR NEX TIME YOU NEED TO STAR THE CAR . CHECK CHARGE ON THE ALTENATOR . IF ALTENOTOR NO CHARGING REPLACE.

Posted on Apr 17, 2009

  • 574 Answers

SOURCE: Belts squealing

is your belt slipping? You may have a bad tensioner pulley. Check all pulleys make sure they will spin and not lock up, if they feel really tight or after rotating them around several times they get tight replace

Posted on Sep 16, 2009

  • 7353 Answers

SOURCE: charge light going out but not charging battery.

what is the voltage of the battery when running, voltage when turned off, voltage after headlights are on for 10 minutes. is the battery good? how do you know. these take a sealed gell cell battery.

Posted on Sep 18, 2009

1fastbob
  • 301 Answers

SOURCE: Battery dies after car is sitting for 2 days. Alt

I assume you have replaced the battery? If not have it tested.

Check to see if a glove box light, trunk light or under hood light is staying on. Also you can remove the negative battery cable and then reinstall it. When reinstalling it, if you see a spark (other than just a very small one) there is a current draw on the battery. This current draw can be isolated by pulling one fuse at a time to see when the battery stops sparking on reconnect. It is possible you could have a shorted voltage regulator causing the current draw also. Many things can cause this problem.

Posted on Sep 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 malibu battery light stays on replaced alternator and belt no help


Batt probly not chargn cause main wire in back of alt is wornout. Alternator tho sounds bad..it will drain a battery quik.Disconnect batt ovenite to confirm

Sep 26, 2016 | 2002 Chevrolet Malibu

2 Answers

Alt. charges 2or 3 min. then shuts down new alt. new comp.


Check wire going from alternator to battery could have a short. Did you replace belt and tensioner it

May 10, 2016 | 2005 Mazda 6 2.3

2 Answers

Charging problem


Check that your alternator is actually charging the battery. With volt meter and car running check for at least 13.5 volts at battery. If not check fuses, big red wire from alternator to battery and for actual output of alternator at bolt where big red wire attaches to alternator. Should have battery voltage with car not running and at least 13.5 when engine is idling(motor running)

Feb 06, 2016 | 1995 Geo Tracker

1 Answer

1999 3.2l. Why are battery and brake lights on?


was not on before the new alt,? is alt new or used.?
or came on only after the new ALT?????????
my guess, is 2 failures.! (one ignored and 2nd grew)
on with engine running, guess yes.
Good question and is same answer on all cars.
1: engine rpm too low, what is yours (below 80 rpm)
2: fan belt slips. bad tension pulley (weak and old???)
3: Alt bad, or its wires bad.
4: brake level low, (@MC) or hand brake switch stuck on, or other brake failures. a plenty, scan the PCM and ABS if you have ABS.
id not drive it with the brake lamp on (Savvy?)
the battery light is really the ALT charge lamp.
it glows anytime the Charge system can not charge the battery
if you drive far like that, the engine will stall and not crank.

5: the horn fuse power the alternator, so check the horn fuse
10amp , key on, 12vdc on both sides of fuse is needed/
fyi: the meter fuse runs the charge lamp, if said lamp is dead bingo.
6: fact 2, the PCM does NOT run the Alternator on the 3.2L .
7: alternator case not grounded right.
8: battery is bad, causing alternator to drop off line
9: battery cables bad, at the 4ends or they are bad.
10: the plug on the rear of alt is bad or its wires or pins rusty.


brakes:
the brake lamp has 3 inputs ("OR" logic) master cylinder level low.
the hand brake lever and the EBCM (electronic brake control module)
a technician unplugs each to see what causes the error.
if you unplug mC wire and hand brake wire
then the EBCM is UNHAPPY, scan it.

Jul 31, 2015 | Isuzu Rodeo Cars & Trucks

1 Answer

Overchanging alternater (ECU?)


The ECU has no control on the voltage. Does your vehicle have a separate voltage regulator? If so that's your fault. A lot of alternators have the regulator built into them. The alternator needs to be put on a test rig away from the vehicle and the output tested, this will eliminate the vehicle, You could disconnect the wiring to the alternator, run three fly leads to the alternator and to a separate battery and run the engine and test the voltage on the spare battery. Wire 1: Battery neg to case of alternator Wire 2: Battery pos to + terminal on alt (the thick wire) Wire 3: Battery pos through a 5 watt bulb to the ind terminal (ignition light) 17 volt will blow another battery for sure.

Jan 07, 2014 | 2002 Hyundai Elantra GLS

1 Answer

ALTERNATOR wont charge


What is the idle speed? Are you sure the belt is routed correctly?

Apr 26, 2013 | 1993 Mazda MX-3

1 Answer

Battery is new Alternator is new but, it seems the alternator is not maintaining the battery and the vehicle is running strictly off the battery. 2000 Mercury Mountaineer.


whats the condition of the drive belt tensioner? youll have to check with a volt meter should be anywere from 13.9 to 14.5 v ..if the drive belt is tight and you do not have 14 v at battery ...did you have the battery disconected when changing alt?? did you ground out the wrench and create sparks and possably blow the ALT fuse ?? need some more info..thanks

Jul 28, 2011 | 2000 Mercury Mountaineer

2 Answers

Why does my battery light stay on after i installed an alternator and new battery


Hi,

The Battery indicator light usually means the alternator is not charging the battery. Most common solutions would be a bad alternator, bad connection, or loose alternator belt.Since the battery and alternator test ok then check the connections to the alternator and battery.
The alternator should have 2 connections.

Good luck...

Aug 16, 2010 | 2000 Ford Taurus

1 Answer

My 1994 nissan, the alt/oil light, battery light keep flickering.


It could possibility be bad or loose connection on the alternator or battery wiring, or a loose alternator belt. All those lights come on when the battery isn't getting a charge, so the alternator is where I'd start looking.

Feb 08, 2010 | 1994 Nissan Pathfinder

2 Answers

Bad alternator


Disconnect the negative clamp on the battery. Remove the bolt on the adjustment arm (the one with the slot) of the alternator. Loosen the pivot bolt at the bottom of the Alt. Swing the alt inward to loosen the belt. Take the belt of the pulley. Take off the wires noting where they attach. Remove the pivot bolt. You should be able to take the alt off now. Reverse the sequence but when adjusting the belt tension pry the side of the alternator with a bar so the belt can only be deflected about three quarters of an inch. Tighten the adjustment bolt. Don't over tighten the belt. It'll prematurely wear your bearings. Don't under tighten. It'll squeal.

May 08, 2009 | Ford Explorer Cars & Trucks

Not finding what you are looking for?
1992 Mazda MX-3 Logo

158 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...