Question about Oldsmobile Cars & Trucks

1 Answer

Check engine light/evap leak

1999 Olds Cutlass...Have an evap leak check engine light issue for 3 years. changed bad fuel pump and light went out the same day. did a tune up and coil packs and car ran great. almost 6 weeks later, check engine light came back on for an evap leak. I need to know my options on what it could be. changing the fuel filter this weekend, and getting it smoked next week. already have a new gas cap, crank shaft sensor, upper half of engine rebuilt. and now just CONFUSED!!!

Posted by on

  • Roxanne Apr 24, 2013

    Gas cap is roughly 3 years old, but putting out like 26lbs of pressure. (just had it e-checked 4 weeks ago) Any input or ideas will help. I am for sure getting it smoked. Just hoping its a cheap easy fix.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Oldsmobile Master
  • 21,873 Answers

Getting a smoke test is the right direction to go in.
The computer vents the gas tank to the vapor canister while the engine is running. It also pressure tests the system for leaks. Some where between the gas tank and the vapor canister there may be a leaking hose or valve. Or it could be the gasket on top of the tank where the pump assembly went in.
The gas cap could have been a source for the leak, the other things are not involved.

Posted on Apr 24, 2013

Testimonial: "See, I thought maybe it was a line or something when the fuel pump got changed because it literally went out right after the pump got changed. the pump now is only 6 weeks old but the car is running great. better than it has in the 4 years i have owned it. that's why i am so confused. "

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 4 Answers

SOURCE: 2002 chevy express fuel pump/crank sensor?? not starting

i had a similar problem and called the dealer during lunch hour. i talked to a mechanic, the distributor in these vehicles is plastic, and is prone to cracking.not just the cap but the body also, I have been taking the cap off and wiping the moisture out of the cap. or replacing the cap but the problem is I need a new distributor. just a cheep way to get rolling is cleaning the inside of the cap, especially when it is very damp or the outside temp changes alot during the day. good luck.

Posted on Jul 03, 2009

SOURCE: 1999 pontiac grand prix . will not run

If wiggling the wires cured the code, then one of the wires is broken inside the insulation. Pull on each wire one at a time. look for the colored insulation to stretch, this will be the broken wire. For the other car that wont rev up, this is a common when the catalytic concverter is plugged up. This will also cause MAF codes, and in turn, TRAC OFF light.
See http://www.greatautohelp.com

Posted on Oct 17, 2008

  • 58 Answers

SOURCE: 91 LEGACY STARTED RUNNING ROUGH

The cylinders are numbered as on the spark pack you changed. You might have done better putting the seafoam in the tank as an injector cleaner. Not sure why you changed so many parts, you seem to know how to get the codes from test connector lead hookup and the blink pattern. You might also want to check the fuel rail pressure and the crank and cam angle sensors. Before replacing the injector, swap the #4 injector with the adjacent one and see it the code moves with the injector or stays put. If the code stays on #4, then check the injector wiring, if it moves clean or replace the injector.

Posted on Mar 21, 2009

  • 1 Answer

SOURCE: Engine cranks, won't start. Three days later, it starts???

probaly a fuel pump its common for vehicles to do that the best thing to do next is a fuel pressure check to verifiy its the pump

Posted on Apr 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What makes the fuel pump not kick on on a 92 Oldsmobile Cutlass


There is a red wire close to the battery in the front. It's not connected to anything. Apply positive voltage and that will run your pump for testing purposes.

Dec 08, 2015 | Oldsmobile Cars & Trucks

1 Answer

I replaced the fuel pump in my 1999 Oldsmobile alero in may of 2012 when I start my car I get a big smell of gas just like I did when it went out before could it be going bad already


I'd use a gage and check proper fuel pressure. Also, check for external gas leak, at the fuel pump--fuel lines--fuel injector/s--fuel pressure regulator, and check evap system.

Feb 20, 2015 | 1999 Oldsmobile Alero

1 Answer

I have a 1999 GMC YUKON. About a year ago I broke down in snowshoe WV the fuel pump was bad so after I installed new fuel pump this problem has occurrence ever sense. At a stop light it bucks bogs and...


Check the Oxygen sensors, as they control gas to air ratio. By spider do you mean the Coil Pack? Cam Sensor and Crank sensor? What about a vacuum leak?

You are going to cuss me for this but, according to your description, this did not occur BEFORE you changed the pump, and you have changed it twice. Are you sure you hooked up the external tank and EVAP lines correctly? Are any of the rubber hose's under there rotten? The EVAP system use's vacuum to pull fumes from the gas tank. The EVAP canister is probably behind one of the rear wheels, and up behind the rear fender. Check those hose's too. Check the intake manifold vacuum lines and connectors for leaks and cracks. Better yet, inspect all your vacuum lines.

Aug 27, 2011 | 1999 GMC Yukon

1 Answer

1999 olds alero is sputtering i replaced the plugs and wires its still sputtering i get a po300 code


CODE PO300 MULTIPLE ENGINE MISFIRE DETECTED CONDITIONS. POSSIBLE CAUSES.WEAK FUEL PUMP.STOPPED UP FUEL FILTER.CHECK FUEL PRESSURE SHOULD BE 41 - 47 PSI. THE MASS AIR FLOW SENSOR CONTAMINATED CAUSE VERY LEAN CONDITIONS.EGR VALVE STUCK OPEN OR PVC VALVE HAS VACUUM LEAK. THE EVAP SYSTEM CANISTER FUEL SOAKED.

Mar 12, 2011 | 1999 Oldsmobile Alero

1 Answer

My 1999 Olds Alero's Check engine light stays on. I had it in the shop and was diagnosed EVAP. Many of the fuel lines were replaced, yet light does not go out. Also replaced the gas cap and light is still...


SOUND LIKE EVAP PURGE VALVE CONTROL SOLENOID GONE BAD ITS LOCATION ON THE 4 CYLINDER ENGINES IS ON A BRACKET NEAR THE AC COMPRESSOR AND 6 CYLINDER ENGINE ITS LOCATION.NEAR REAR FIREWALL SIDE CYLINDER HEAD BELOW THE IGNITION COILS.CHECK THE EVAP PURGE VALVE CONTROL SOLENOID FUSE AND IT WIRES AND CONNECTOR BEFORE BUYING A NEW ONE.

May 06, 2010 | 1999 Oldsmobile Alero

4 Answers

1991 olds cutlass supreme with a 3.1 v-6 the engine


I am having a similar problem, but there is no check engine light. It seems that mine dies at the light or running, if the rpm's drop. I am wondering if the Idle air control valve is bad or possibly the ERG valve?

Feb 03, 2010 | 1991 Oldsmobile Cutlass Supreme

2 Answers

Falls dead when driving, will restart after awhile


Did you try checking or replacing the coolant sensor? I think you should replace it along with the thermostat. Are there any problems like sputtering or any unusual noises or symptoms? Smoke, anything?

May 06, 2009 | 1991 Oldsmobile Cutlass Supreme

1 Answer

1996 olds cutlass supremem runs bad after new fuel pump


go to an auto parts store and use there code reader it should point you in the right direction.

Mar 03, 2009 | 1996 Oldsmobile Cutlass Supreme Coupe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8499 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...