Question about 2005 Ford F-150

1 Answer

Why does my engine just rev when I go to accelerate after slowing down

2wd V8 5.4l

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 5,678 Answers

Could be problem TPS sensor[RPM] or IAC sensor.

Posted on Apr 24, 2013

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 11 Answers

SOURCE: Engine over revs

it all depends on what yr the ford is b/c my grandmas car dose it a lot when you go to shut the car off make sure it is in park and it is in a idle then when you start it it should be fine if not go under the hood and see if it accelator can be lossened a littel bit if so it will save you on gas and the idle wont be as high. if that dose not work then dont worrie about it it wont harm the car any and dont pump the gas pedall while the car is not running

Posted on Jul 28, 2008

  • 3600 Answers

SOURCE: 2002 Explorer. Driving about 50mph, take the food

defective crusie control.

Posted on Jun 18, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is it normal for the revs to stay up when changing gear in a 2002 4x4 3.0L turbo diesel navara?


do they revs drop off when taking pressure off accelerator pedal when out of gear? if only staying high during gear change it would suggest a worn clutch friction/pressure plate so the engine isn't slowing down when clutch is depressed .I'd also have the OBD codes read to see if there is a sensor/switch at fault , but sounds like the clutch to me

Jun 21, 2014 | Nissan Navara Cars & Trucks

1 Answer

Engine surge on slow acceleration


check tranny fluid level,if good,either pump in tranny is bad or cluthces in tranny is gone bad,how many miles?

Apr 15, 2014 | 2008 Chevrolet Silverado 1500 2WD

1 Answer

Problems accelerating


the engine tickover is too slow when the engine is cold its running on cold start, ie:choke,, after it warms up the engine slows down this is what is causing it to stall in gear,, get some one to hold the brakes hard on and with the engine running in gear ajust the tick over till its reving at 750 - 850 rpm the revs will go up a bit when its out of gear,, before you pick a gear to go into push the foot brake down to stop the car lurching,,,

Feb 19, 2010 | 1997 Cadillac DeVille

1 Answer

Vw polo maintains engine revs when foot is off the accelerator.


You need to check the cable the runs from the gas pedal to the engine, it might be rusty and need some drops of penetrating oil at the point it meets with the engine accelerator valve.

Feb 11, 2010 | 2007 Volkswagen Golf

1 Answer

Hi There, My Freelander loses power at about 70 mph on hills on motorways and slows down to 60-ish. I have no warning lights coming on, no drop in revs, no exhaust smoke and no overheating. After easing...


if your vehicle slows from 70 downto 60 with no change in revs ,then the transmission is slipping .. imust say i dont believe that the speed drops back without the revs dropping down too, i am not calling you a liar ,i`m saying you are not making accurate observations , and without those we are just guessing .

Nov 09, 2009 | 2005 Land Rover Freelander

1 Answer

2001 xg-300 stall when to cold,no acceleration,check engine on


I've got no diagrams on this car but I'd check mass air flow sensor if you have one. Often they can be cleaned off and work well afterwards, or replace it.

Feb 06, 2009 | 2001 Hyundai XG300

1 Answer

1998 Holden Rodeo TR series 5-speed manual 2WD


run the fault codes
look for ambient temp sensor or baro sensor problems

Jun 30, 2017 | 1992 Isuzu Rodeo

Not finding what you are looking for?
2005 Ford F-150 Logo

Related Topics:

20 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...