Question about 2000 Dodge Neon

1 Answer

Check Engine Light for 2 years.

Okay, so 2 years ago, I bought a car, its ran fine, until there was a problem that the battery kept draining. The check engine light also came on, and my guages didn't work. I found that there was a ticking sound coming from the relays, and after spending $2600 at the Chrysler dealer, to replace wiring harnesses and cpm's. After driving it for oh, about 30 miles. . .the computer, which obviously reset itself, found a problem and the check engine light came on and the odometer would say No BUS. . .and the guages stopped working. . . sometimes they would "pop" back on, I took it back and they charged me another $200 to run diagnostics, and tighten pins on the guages. After a couple miles of me driving it, guess what. . . it happened again. I took it to another mechanic, who began trying to find the problem, unfortunately after replacing the guages, the head unit and the air bag control model, it continues with the same problem, tried checking the O2 sensors, but with one out, the car still ran, and vice versa. The only thing that actually works is my gas guage. . . why only that one, I don't know, my odometer doesn't work, my speedometer, my tach, and my temp guage do not work. the check oil, seat belt, and a few other lights go on and off on their own (and I do wear my seat belt) My mechanic said that there may be a lose wire, or a stripped wire, and a srew or bolt may be making contact that is shorting the circuit and that he would need it for at least a week to take apart the dash and search for it, and driving it for 45+ miles to make sure it works before he gives it back, I'm hoping to find some help before I have to lose my car for yet another week!!!!!
. . .HELP ME!!!! We, nor my mechanic, and I gave up on the dealer (, b/c they were ripping me off,) can figure out what's wrong with it

The latest codes that come up for me are: p1684 & p1687

Posted by on

  • emsm2 Mar 13, 2009

    I don't have access to a DRB, I'm not sure if my mechanic does. I hope the wiring harness and all other items associated with it aren't bad, because the problem started back the same day I paid 2600 to replace ALL of them by Lehighton Chrysler Kia

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 115 Answers

The p1687 code is a NO MIC BUS MESSAGE( mechanical instrurment cluster). When replaced the guages did you replace the whole cluster? here is the diag for this code. 48 Turn ignition on, Engine not running.
Using the DRB, erase codes.
Cycle the ignition key on and off several times.
With the DRB read PCM trouble codes. LOOK for P1687.
Did the No PCI Bus Message from MIC trouble code return?

Yes ® Go To 50
No ® Go To 49
49 Turn the ignition key on, Engine not running.
Does the Odometer in the Instrument Cluster display No Bus?

Yes ® Go To 50
No ® Go To 51
50 Turn ignition off.
Disconnect the PCM.
Disconnect the Instrument Cluster Connector.
Using an ohmmeter, measure the PCI Bus Circuit between the PCM and the
Instrument Cluster Connector.
Is the resistance below 5.0 ohms?

Yes ® Replace the Instrument Cluster.
Perform Powertrain Verification Test VER-1A.
No ® Repair the open PCI Bus Circuit.
Perform Powertrain Verification Test VER-1A.
51 Turn ignition off.
Note: Visually inspect the related wiring harness. Look for any chafed,
pierced, pinched, or partially broken wires.
Note: Visually inspect the related wire harness connectors. Look for broken,
bent, pushed out, or corroded terminals.
(DRB is the factory scan tool you can use subtitute if you have access)

Posted on Mar 13, 2009

  • mike ryner
    mike ryner Mar 14, 2009

    Have your mechanic check the resistance of the wiring from the engine controller to the cluster.(The bus in a car is what the factory calls the communication circuit between computers) when that message ( no bus ) comes up it has lost that communication to that computer. I have seen many cluster failures in neons over the years. I really dont think its a wiring harness problem if it has been replaced. Still , checking it will help eleminate it. Also with the cluster out check the volage on the bus wires at the cluster it should be around 2.5 volts. Check and make sure you have your power and grounds to the cluster.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why is battery draining ford 2002 Taurus SES


Remove negative cable from battery, connect a test light to negative terminal, opposite end off light to negative battery post. ( let sit for 3 to 5 minutes). Then start pulling fuses, when the light goes out that's your bad circuit. God-Bless! Its worth a try.

Oct 01, 2015 | 2002 Ford Taurus

1 Answer

Van wont start...bought it 3 days ago ran fine..now it wont start...turn key all lights come on bright...fans on high...check engine light is also on....tried the old turn the wheel both ways and put


check battery connections all the way to there ends may be bad ground or alternator not charging when you get it running go to local auto parts store have them check voltage output or charging power

Jan 28, 2015 | 2000 Pontiac Montana

1 Answer

Check Charging system light illuminates, all electrical shuts down and engine still runs on 2004 Ford Expedition 5.4l until battery dies. The opposite has also happened with the engine shutting down and...


Try replacing the "convinence control module" and bad board can cause all elec issues explained and also cause engine to cut out and other things but that is where I would start, hope this helps-

Nov 29, 2013 | 2004 Ford Expedition

1 Answer

Battery light came on and car wont start now when i shut it off


will engine crank?? if not, recheck battery cable connections. if vehicle ran until shut off, tells me that your charging system kept vehicle running until vehicle was shut off. alternator light can be related to faulty alternator and or bad battery.

Jan 17, 2013 | 1998 Pontiac Sunfire

2 Answers

1990 JEEP Cherokee that won't start even after a new battery


It sounds kind of like you have bad alternator. The alternator uses the engines power to recharge the battery. When you replaced the battery the car ran off battery power untill it died. If the car will run while hooked up to another car while being jump started then the problem is deffinetely the alternator..

Please give a good rating, it is very importat to us..

Aug 01, 2009 | 1990 Jeep Cherokee Limited

2 Answers

Will not turn over trying to start ran fine around 4:00 and at 8:00 would not start


check your battery condition and all battery and starter connections.

Jul 30, 2009 | 1996 Ford Explorer

1 Answer

1996 Chrysler Sebring Conv.- Power Drain or Damaged Crank Sensor?


try checking the secondary ground wire that comes off the battery see if its loose or corroded might help

May 29, 2009 | 1996 Chrysler Sebring

1 Answer

91 tracker new engine been sitting wont start


1-check for strong battery
2-check for spark from the spark plugs wire
3-check for gas prusser
4-check if there is any after market alarm system build in your car

Mar 16, 2009 | 1991 Geo Tracker

1 Answer

Car battery keeps going down


You seem to have an electrical drain on your battery from what you are saying. However the drain can be coming form you alternator. With some skills I can tell you how to check for the source of this drain, Its an old technique that I learned years ago. Get a regular test light(the one with a bulb/light in it) disconnect your negative batter lead from the negative post on the battery. Connect clip end of test light to battery pole. Touch pointed tip to battery cable(negative one) With ignition key off and out of ignition and all doors locked and ALL OTHER ACCESSORIES OFF... this test light bulb should NOT be lit. If it is there is a drain. Go to main fuse boxes and remove fuses on at a time(MAKE SURE ALL DOOR ARE LOCKED AND ALL ACCESSORIES ARE OFF when doing this procedure) As you remove a fuse if light is still on replace in the same spot and move on to next fuse until light on test light goes OUT. when it does "Bingo" that's the circuit that has a drain in it. Some accessory in that circuit is draining your battery. Locating the source should be easy the fuses are marked by what they control. Contact if you need more help. Good Luck

Dec 27, 2008 | 2001 Saturn SL

Not finding what you are looking for?
2000 Dodge Neon Logo

567 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...