Question about 1999 Chevrolet K1500

3 Answers

Car dies when it gets hot just like you cut off the key.

When it cools off it will start. ihave had the coils and module tested but i stuck a screwdriver in the sparkplug wire when it quit and there was no spark what should i try next.

Posted by on

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,669 Answers

Even though you tested the module, it is likely bad. Replace it.

Posted on Mar 12, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 527 Answers

Sir,
Go through all the sites from this link, you may have fixed.
Link 1
Link 2
Link 3
Link 4

Thanks Good Luck
Appreciate to rate as "Fixya"

Posted on Mar 12, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,055 Answers

Bad power wire coming from the selonoid or fuesable link

Posted on Mar 12, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RE worded Hesitation issues on occasions tonight drove 15 miles stopped put in gas. Drove off got about 1000 yards engine just died had to cost to a space tried to start cranks but wont run?


Do basic testing. When in failed mode, check for spark. I suspect ignition module or coil, as these parts fail when hot and when you turn off running engine it gets hotter before it cools. Hard to diagnose because when you remove module to test, by the time you get to a parts store to test it's really cool again. Make them run test three times and tap with a pencil as you test.

Mar 27, 2015 | 1992 GMC Sierra K1500

1 Answer

1987 f 150 6 cyl starts and runs till hot then wont till cooled off


Probably a bad ignition coil or a bad TFI module (the ignition control module). Much testing could be done to find the faulty part, but I believe if you take the TFI module to a parts store, it could be tested.

Dec 26, 2014 | 1987 Ford F 150

1 Answer

Car dies when it gets warm wont restart until it completely cools off


ignition module may be getting hot and cutting out..

Dec 15, 2013 | 2001 Buick Century

2 Answers

Mazda 323 1985 runs fine when cold after the car heats up it will randomly die. Just cuts out completely. Won't start straight away but after 30sec it will start like nothing was wrong. Then it will...


This is going to be tough to fix. Chances are its a relay or the ignition module, but until it gets to where it will not start for several minutes or not at all, you won't know if you have fixed it or not.
Something is getting hot, cooling off, then getting hot again.

Jul 07, 2013 | Mazda 323 Cars & Trucks

1 Answer

1999 avenger cuts off when it gets warm


Hi there have you tried the ignition coil as this sounds like the coil is getting hot and creating an open circuit thus no hi tension voltage to the spark plugs,once it has cooled done the car will start again until
it repeatedly gets hot and shuts down very common in pre coil pack vehicles,easy test try a spare coil and drive for same or more distant if not fault them coil is U/S

Feb 05, 2013 | Dodge Avenger Cars & Trucks

1 Answer

On my 1991 3.1 chev lumina when it get warm you step on the gas and it die's what the heck? can anyone help


some common problem in the summer when car get hot over and over the ignition (coil) is affected it will make your car cold run fine but cuts off when hot if occurred look for the coil
if you let car cools down for an hour then it started and work fine until cut off when hot again sure it is coil .

Jun 08, 2011 | 1991 Chevrolet Lumina

2 Answers

Will run fine for about 4 mile then start missing and then stop running, aftre letting set for about an hour it will start and run for about another four or five minutes and then quit. acts like it does...


I recently had about the same problem with my c1500. You have a tach watch tach if needle jumps your problem is electical. Test coil, distributor pick-up coil and ignition control module. This time mine was the pick-up coil which requires distributer removal. Both coils can be tested by an Ohmn meter, the module must be removed and tested by auto parts store. All three can cause this problem. As they get hot they short out when they cool they work fine. If you pull the distributer cap look at the wires for the pick-up coil mine were cracked from age, which caused shorting while driving and then it would die. when cooled it would crank.

Jun 23, 2010 | 1995 Chevrolet K1500

1 Answer

No start when hot


ignation control mogule,wen get hot expend and lose conection and will not start after cool down start normal also will cose no fuell presure fuell pump will not run,locatiom under coils.replece it

Mar 13, 2009 | 1991 Buick Skylark

3 Answers

While driving, the engine dies.


I had the same thing happen on a 91 Olds 88. Replaced crank shaft position sensor, coil, and ignition module. That solved the problem. I think the culprit was the CSP Sensor, but changed all three so can't say for sure.

Jan 31, 2009 | 1991 Oldsmobile Ninety Eight Regency

Not finding what you are looking for?
1999 Chevrolet K1500 Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

64034 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...