Question about 2003 Oldsmobile Alero

1 Answer

There is a clicking noise in my engine when I turn it on. My antifreeze is also running out, but it's not running out underneath. I think it's going into the oil and the engine. how much is this going to cost to fix?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,201 Answers

By what information you gave, sounds like a head gasket. To be sure, check the oil, if it has some light brownish color to it, the coolant is leaking past the gasket. The cost? At just guessing, about $300 to $600, depending on where you take it.

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2005 Pontiac that makes a hissing noise underneath the car. you can turn the car ignition on without fully starting car and it still makes hissing noise then stops.HELP!!!!!


There is a distinct sound that has a hissing component when you first turn on the key. It will last a second or two when the key is turned to the run position. When the engine started the sound will return and continue to produce the noise so long as the engine is running.

A relatively low noise is normal. If you are concerned check other like cars for the loudness level.

how to check your fuel pump

The pressure regulator on the fuel rail can also produce a sound when the fuel pump is running. The regulator is under the hood and any reasonable noise would not be a concern, A clicking sound is also normal throughout the fuel system when the engine is running created by the fuel injectors cycling.

Dec 28, 2015 | Pontiac Cars & Trucks

1 Answer

I have aan intermitint antifreeze leak from under my car. their is no hose leaking and the radiator is not leaking


I don't know what you are driving..but sometimes the leak that you see under the car starts in the front area and runs to the lowest point and drops off...try getting under the car or up on a lift..follow the tale tale signs of the water/antifreeze running olong the underneath of your car...my bet it your water pump is starting to go bad..they have a small weep hole at the bottom of its shaft..if the seal/bearing is wearing water will start to leak and run along the underside of the motor..good luck..

Oct 05, 2014 | Cars & Trucks

1 Answer

Why did the motor die while I was driving down the road when I turned on the a/c and fan?


If the engine overheated then the antifreeze may be getting into the engine, indicating a cracked head or block. check for water in oil via dipstick. .

May 12, 2014 | 1993 Honda Accord

1 Answer

I have a 2003 Taurus. For the past couple days it has been leaking anti-freeze and running hot, but not to the point to ehre the needle goes all the way into the red. The puddles underneath the car are...


I dont think the problem was with your water pump, so much as with possibly a leak in your radiator, hoses, possibly the starter/alternator, even loose battery cables, or need a new battery, can cause this and might account for the inability to start now, provided you restored coolant levels, etc. Good thinking, turning heat on to draw it from the engine. Ive done it myself a time or two, and saved the cost of an engine or two. (overheating will cost you dearly in engine repairs) Might think about having a diagnostic run to see what all is wrong with your car,( then have them list repair/replacement in order of importance) and, checking the transmission fluid to be sure its at the correct level.. (The orange fluid made me think of this, also) Just some things to try.

Sep 14, 2013 | 2003 Ford Taurus

1 Answer

Heater not working, 'low coolant' light, gurgling noise, overheating....


It may be a early signs of the intake manifold gasket. Did you check your radiator and water pump. Also if there is any antifreeze around your engine, then it's a intake manifold gasket. As for the hazard light thing and turn signal, something has to be replaced there.

Dec 03, 2011 | 1998 Buick Century

1 Answer

2007 dodge ram fuse problem


my 2008 dodge ram is displaying no fuse underneath the spedometer. it makes a clicking noise about 5 times and turns over fine. runs normal/drives normal. it delays when turning off (i turn the key off and it takes about 5 seconds to turn off) remote entry does not work.

Feb 12, 2010 | 2007 Dodge Ram Truck

1 Answer

Car wont start, fuel line makes sputtering noise


I have a 1986 325e with high mileage 275,000. Car starts fine and idles ok. I'm experiencing an intermittent problem where when placed in drive the car will sputter, lightly backfire, and not move forward until i pump the gas and give it time to correct whatever is not operating properly. Then it runs just fine. I'm thinking it's an air or fuel issue. Just recently tuned up the car and put some bgk44 after the problem started but still experiencing the same problem.

Nov 10, 2009 | 1986 BMW L7

1 Answer

Won't start after stopping


sounds like the thermostate is no good and you probably overheated the car hope you didnt ride to long while overheating ---fill all fluids to normal and try to turn the car over when the engine is cold to see if it starts. if it runs and sounds fine dont let it get to hot watch gage let it go to 180 - 200 if it climbs higher shut car off and have a mechanic check it out or replace thermostate cheapest way out. if car does not run right or makes noise as soon as it starts u have added problems. u didnt mention if there was antifreeze leaking any where

Mar 18, 2009 | 2001 Chevrolet Metro

1 Answer

Antifreeze leaking into car through heater.


yes its your heater core. it went bad and needs to be replaced. it is housed underneath the dash

Oct 19, 2008 | 1999 Kia Sportage

6 Answers

1998 Pontiac Grand Am leaks antifreeze. What is wrong and how do I fix it?


You mentioned that the leak is under the surge tank. I have seen the hose going to the bottom of the surge tank to wear out and leak. If it seems like your leak is coming from the front part of the engine then it sounds like the water pump is in fact leaking out of the weep hole. I would check the hoses going to the surge tank first though.

Oct 06, 2008 | 1998 Pontiac Grand Am

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

182 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...