Question about 1997 Mitsubishi Eclipse

1 Answer

1999 Mitsubishi eclipse spyder terrible idle after warmup.

This Eclipse will run fine when its first started but when it hits 66 deg. it goes to skipping and choking and backfiring but if you unplug the mass air flow sensor it will run all day long with no problem. I put a brand new MAF sensor on it and it did the same thing. What could it be?

Posted by on

  • metasuperman Mar 12, 2009

    it is the stock intake.

  • blueextc3221
    blueextc3221 May 11, 2010

    do you have the stock intake or aftermarket like K&N ?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

It could be the temp sensor. Have you had a diagnostic OBDII computer put on it? You should have your codes checked for easiest troubleshooting and diagnostics. Mabey you have a short in the wiring. Have you checked new maf with digital ohmeter to check wiring for resistance?

Posted on Mar 11, 2009

  • Nate Stansfield
    Nate Stansfield Mar 13, 2009

    If same problem persists with 2 different MAF sensors, and runs with it unplugged. Than it's that sensor to or it has to be the wiring.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car will not start after it runs for awhile, starts fine cold and runs great 2002 eclipse spyder


sounds like my truck. some security code issue. gonna have to take it to the shop

Jan 08, 2013 | 2002 Mitsubishi Eclipse

1 Answer

Engine skips when accelerating and runs fine at idles and top speed


If you feel the engine missfire on acceleration, you could have a weak spark plug and/or plug wire. If you have not replaced them in over 30,000 miles I would start there.

Jun 24, 2012 | Mitsubishi Eclipse Spyder Cars & Trucks

1 Answer

What is the firing order for a 97 eclispe spyder


1997 Mitsubishi Eclipse Spyder GS-T FWD 2.0 liter DOHC Turbo L4

a6519be.gif



1997 Mitsubishi Eclipse Spyder GS FWD 2.4 liter SOHC L4

97f1103.gif

Hope help with this (rememmber rated this).

Apr 12, 2010 | 1997 Mitsubishi Eclipse

1 Answer

2003 Mitsubishi Spyder Eclipse, green wrench/car lt, not running


that means it needs service. also probly means that something is either loose or broken wise. you were probobly receiving a service engine soon signal when you put the keys in the ignition and turn it one slot to where the car is running on battery so the radio should work. and thats where the idicators would of been going on. and you probobly didnt notice those

Aug 07, 2009 | 2003 Mitsubishi Eclipse Spyder

1 Answer

2003 Eclipse V6 Hunting at idle after we replaced the Timing belt


on my sons car it was the idle speed control motor it on the throdebody

Apr 06, 2009 | 2003 Mitsubishi Eclipse Spyder

1 Answer

Coil not firing on 2 cly


Not sure what size of motor you have so please choose what you need:

1999 Mitsubishi Eclipse GS
2.0 liter DOHC L4

6045609.gif
1999 Mitsubishi Eclipse GS-T
2.0 liter DOHC Turbo L4


ac4a9fa.gif

1999 Mitsubishi Eclipse GSX (AWD)
2.0 liter DOHC L4

8a697b1.gif

Mar 17, 2009 | 1999 Mitsubishi Eclipse

1 Answer

Radio code Eclipse Spyder,how do you enter


Contact your local Dealership and ask for Parts. They have all the Codes and can tell you by Running your VIN Number.

Jan 24, 2009 | 2001 Mitsubishi Eclipse Spyder

1 Answer

2003 Mitsubish Eclipse GST Spyder alarm goes off for no reason at all. If you hit the unlock button it quits, but it might go off again at some random time.


I HAVE A SPYDER ALSO. ALTHOUGH, I HAVE NEVER HAD THAT ISSUE, THE ONLY WAY I COULD GET THE ALARM TO STAY OFF WITHOUT GOING OFF AGAIN IS BY INSERTING THE KEY INTO THE DRIVER'S SIDE DOOR. THAT RESETS IT PROPERLY.

Oct 25, 2008 | 2003 Mitsubishi Eclipse Spyder

Not finding what you are looking for?
1997 Mitsubishi Eclipse Logo

241 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6880 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...