Question about 1994 Mercury Grand Marquis

1 Answer

Engine light on when slow running or reverse car shudders when slow need to put in park when at lights or stop signs to keep engine running

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 124 Answers

You could have a bad torque control switch.it should on the front of tranny behind radiator. unplug it and drive around if you have power then that switch needs replaced.

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What causes 1996 Dodge Neon SOHC automatic transmission to delay or slip shifts?


that is a hum dinger, largest ever posted, in one shot.
very good.!
one word , the transmission slips. (never drive a slipping tranny)
overheat indicator.! that is key.
many newer cars will change the transmission shifting any time
the engine over heats.
and overheat wins over transmission , every time.
if the engine burns up, what good is any transmission.? nada.

solve overheat first.

slip or flare.
is when the engine RPM rises fast and the car dont go faster.
SLIPS.
and slipping burns up trannyclutchs and increases the damage. inside the transmission, dont do that. dont allow it,
park it and fix it.

on some tranny there is a temperature sensor that the TCM
watches and changes shift patterns based on AFT fluid temps.
and if the ATF fluid gets too hot , it takes actions. to keep the tranny from harm.

why not get a scan too and see what DTC errors there are..
DTC, engine overheate.
DTC< tranny overheat (caused by above)

Jun 14, 2014 | 1996 Dodge Neon

1 Answer

Shuddering below 1000 RPM??


run fault code as the transmission is not down shifting and the engine is trying to stall under load. Look for a faulty TCM unit.

Feb 23, 2014 | 1997 Toyota Celica

1 Answer

Transmission won't shift out of 1st and service engine light comes on. goes in reverse and park. goes in drive , just will not shift.


Hi Cindy, As the engine check light is coming it is indicating a problem. Have a diagnostic scan carried out and let your technician determine the actual fault. It could be something to do with the state of engine tune or a defective speed sensor, but may also be a problem with the gearbox. Regards John

Sep 09, 2012 | 1993 Jeep Grand Cherokee

1 Answer

Idle is high at start - 1800 rpm. Seems like excessive white smoke from exhaust. Put into reverse and back out of driveway it has a regular shudder (bump bump bump) but not hard metal grinding sound.....


white smoke out of the exhaust would be a sign that it is burning coolant... if it goes away after it warms up, it could just be condensation inside the exhaust pipe. 1800 rpm is a very high idle, maybe have your IAC motor on the throttle body checked... check engine light? if so have the code read at your local auto zone.

Aug 09, 2011 | 1998 Toyota 4Runner

1 Answer

Wiring 4 way flat trailer plug. brown wire running


you got brown for running parking light
green for right turn/stop
yellow for left turn/stop
white for ground
reverse lights are only wired on a 6 or 7 plug connector
make sure you on the dark green for right turn stop not the light green
the light green is for reverse

Jun 24, 2010 | 1999 Chevrolet Tahoe

1 Answer

99 grand caravan. When putting it into gear from


It sounds like you have a torque convertor issue. But you will need to take it to a shop to be 100% certain.

Dec 14, 2009 | 1998 Dodge Grand Caravan

1 Answer

Engine shuts off somtimes when I'm driving.


could be your comp. is your check engine light ever on? or a crankshaft position sensor.

Apr 19, 2009 | 2001 Chevrolet Blazer

3 Answers

Check engine light and it is slow in speeding up. Please help


I have the same problem. ALTHOUGH this will not Solve your problem, it will make things easier. It is apparently a transmission sensor error. It ONLY comes on when you try to go in reverse. I have been driving my car for 4 months now and I don't go in reverse anymore and the problem stopped. of course its hard, I only park in places I can pull out of, or park uphill so I can neutral backwards. Its a hassle but hey I'm a student with no money to fix this ****.

Also, When the light goes on, if you put the car in drive, it usually gets stuck in one gear and cant shift properly. making your engine sound weird. to fix this, you have to find a spot that's uphill. Park on an incline where the front of your car is pointing up. turn off the engine, turn it back on again and it should shift fine now. the engine light will go away in like a day or two after this. and wont come back on unless you go in reverse.

p.s. If you ever feel the need to go in reverse, you should probably put the car in neutral and try pushing it first to see if that works.

Sep 02, 2008 | 2006 Suzuki Forenza

Not finding what you are looking for?
1994 Mercury Grand Marquis Logo

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...