Question about 1993 Mercury Villager

Open Question

Stalling in 1993 mercury villager

My villager keeps stalling. It stalls at any speed or acceleration. I have changed fuel filter, air filter, plugs.

Posted by on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: car stalls and then after

check the coil and spark plug wires

Posted on Jul 30, 2008

  • 2 Answers

SOURCE: engine stalls after cold start-up & release from high speed idle

I had a similar problem.  I found the filter cartridge below the pcv valve had carboned up, and after the crank case pressurized, oil was forced out the pcv supply line to the throttle body.  The idle air control valve solenoid got oil in it and caused my problem, but only when it was cold.  The pcv cartridge is accessed by removing the pcv valve and the rubber fitting that the pcv valve mounts in.  It can then be fished out with a pick set, and it is a pain because you can't see it, but you can get you hand back there.  I hope this helps you.

Posted on Feb 28, 2009

  • 1 Answer

SOURCE: My son has a 2001 Mercury Cougar and it has a

my car has been jerking into gear down the highway and i was told it was my range sensor. Now that the range sensor has been change it is still jerking trying to find what gear it's in.

Posted on Nov 08, 2009

  • 1757 Answers

SOURCE: I have a 2000 Mercury Sable. runs at speed and

There are many possibilities on this. Anything from bad Gas, Bad Ignition Wires, Bad Distributor/IgnitionCoil, Intake Air Leaks, Bad Sensors etc.
It sounds like a malfunctioning Idle Air Control Valve. You can take this off and clean it with Carb Cleaner. Reinstall and check operation. If it helps but does not solve completely the problem: Replace this.
Check your Ignition Wires and Distributor/Ignition Coil.
The Idle Control Valve is available at
(no-I don't work for either store/company)
Autozone Part #TV281 for around $51.
Advance Auto Part #50523 for around $52.
Let me know if this helped, or if you have additional information or questions. Feel free to contact me at FixYa.com!

Posted on Feb 17, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Running rough& stalling


Brenda, this could be a lot of different things to cause hard start and stalling. Faulty crank sensor, idle air control valve, EGR, vacuum leak, injectors, fuel pump, ignition circuit, distributor faulty,plugs,wires,plugged exhaust, etc. Find a good technician check the codes and have them diagnose and give an estimate on repair. Check the attached links,instruction and guides, Good luck
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info.
No Start Engine Stalls Mercury Villager Common Engine Problems
Nissan Quest Mercury Villager Starting Stalling Problems
http://forums.nicoclub.com/1996-nissan-altima-runs-rough-and-stalls-t162761.html

May 06, 2016 | Cars & Trucks

2 Answers

1993 cavalier engine stalls.


Start checking and eventually replacing air filter, spark plugs, and fuel filter, check that air intake is not obstructed.


Oct 12, 2008 | 1993 Chevrolet Cavalier

1 Answer

Truck will crank up but I have to press the accelerator to keep it from stalling out


is this a ford truck? They have an air bypass valve where the air cleaner hooks to throttle body. Dirt builds up over time so you might have to clean it out.

Jan 27, 2013 | 1993 GMC Sierra

1 Answer

Why does it sputter at low speeds and now is stalling out after warming up. Could this be because I let it run low on gas and I need to get a gas treatment?


Amanda: When was the last time the Gas Filter was changed? ...Also has the Distributor rotor been changed? The problem sounds like a clogged fuel filter...Changing the Rotor is a $5 good idea...See photos below...The filter and rotor can both be bought for $20...Once the filter is changed, i would suggest adding a can of SEAFOAM...Cost is $9 a can at most auto part stores...Pour it in the tank the next time you fill...It's an excellent internal cleaning product...
Guru...Saailer



12_5_2011_6_49_13_pm.jpgACDELCO Part # GF712
cost $15...


12_5_2011_6_50_47_pm.jpgACDELCO Part # E403A
cost $5

Dec 05, 2011 | 1993 Mercury Villager

2 Answers

2002 mecury villager stalls at low speeds or on acceleration from a stop. Replaced speed sensor and this was not the issue, but diagnostic code says that it still is. Must turn car off and start it again...


First- Codes do not tell you what to fix. You already found that out.
Second-Logically,why would a speed sensor on a trans cause a stall. The speed sensors and there are several.produce outputs on shaft and drum speeds in the trans. Those signals are part of the PCM input strategy for shift points. At low speed,your not shifting,your stalling.
There is no such thing as baffled. Lacks your vehicles system knowledge, maybe!
Do you have a clean fuel filter?
Do you have fuel pressure during the stall?
Do you have fairly new spark plugs?
What does the data for the Throttle Position Sensor,Mass Air Flow Sensor,Egr Valve Etc look like before the stall.
Got vacuum leaks?

Now --you either need to leave the vehicle at a shop,until they repair it
-Find a good tech at another shop that knows your vehicle
Or get the manuals and start on a life long persuit of auto technolgy. I like the last one.

May 04, 2010 | 2002 Mercury Villager

1 Answer

I have a 93 mercury topaz that stalls while driving


if it only stalls hot relace the ign module on distributor

Oct 05, 2009 | 1993 Mercury Topaz

4 Answers

1993 Lexus LS400 acceleration stalls or surges


I HAD THE SAME PROBLEM WITH MY CAR. 93 LS 400. THAT WOULD BE YOUR FUEL FILTER OR THE FUEL PUMP GOING BAD. TRY CHANGING THE FILTER FIRST. THE DEALER TRIED TO CHARGE ME $980 TO CHANGE FUEL PUMP.

Jul 06, 2009 | 1993 Lexus Ls 400

1 Answer

Lose of power on acceleration like its starving


Sounds like there is a load of dirty fuel in that gas tank. Ran good for a while after changing fuel filter, then began to run poorly again. Remove fuel tank, drain and clean out, replace fuel filter AGAIN. That should cure it. Hope this helps

Jun 18, 2009 | 1993 Mercury Villager

Not finding what you are looking for?
1993 Mercury Villager Logo

Related Topics:

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...