Question about 2001 Ford Expedition

1 Answer

My rear Sub-woofer quit working. Is there a fuse for this?

Posted by on

  • kevmar2000 Mar 11, 2009

    What should I look at now to fix the problem?

  • yadayada
    yadayada May 11, 2010

    if only the sub has quit there is no fuse problem, if the fuse was bad all of the speakers would be inop

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 70,387 Answers

Test the sub woofer and the sub amplifier

Posted on Mar 11, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wipers not working


If the radio and/or window control quit also, its the Body Control Module(BCM), which is under the center console glove box, to the rear of the sub woofer. I wedged a small wood block under the wire plug, they worked! Found 1 wire plug in the plug assembly badly corroded. Same happened to my son's 2000 Yuk. Good Luck, Al

Nov 03, 2013 | 2003 Cadillac CTS

1 Answer

Subwoofer is not playing


It is hard to say. The sub-woofer has its own amplifier, although it is supplied the sound data from the main amplifier. It could have a problem with the battery power circuit (Sub-Woofer Amplifier Connector Pin 6, LIGHT GREEN/VIOLET) or it could have a problem with the GROUND circuit (Pin 2, BLACK/LIGHT GREEN) Or it could possibly not be receiving the signal from the main amplifier (Pin 7, BROWN/ORANGE "+"), (Pin 8, RED/BLACK "-"). Or it could be that either the sub-woofer speaker is blown, or the sub-woofer amplifier is defective.
There is also a "High Audio Mute" circuit that connects between the main amplifier and the sub-woofer amplifier.

Mar 06, 2012 | 2000 Lincoln Navigator

1 Answer

My sub woofer stopped working, please tell me where it is located so i can check the speaker and also check if power is going to it thank you very much joe


The JBL premium sound system has a large woofer in the bottom of each door, a small mid-range speaker next to the woofer, & tweeters next to the front door windows in the corner, & two full-range speakers near the rear seats. The woofer (not sub-woofer) handles all the low end. You can test the woofer by turning the BASS to max and TREBLE to minimum (make sure balance and fader are centered) and put your ear next to each woofer.
The woofer is usually the 1st speaker to have problems after 10 years or so. The outer edge of the woofer starts to degrade. You will usually hear a rattling sound out of the woofer when this happens.
NOTE: If no sound at all out of the woofer (tweeters are OK), you might take your car into a car stereo shop. They can put a speaker on the wires connected to the speaker and make sure your problem is not the radio.
PROBLEM: You can still hear sound out of the woofers but it is distorted
SOLUTION 1: Go to a car audio shop and have them install new woofers. These may cost $30+ each but the dealer cost is over $200 for each woofer (crazy).
SOLUTION 2: More involved but very cost effective. If you or a friend is handy, you can go to www.speakerworks.com and order a new set of speaker outer rings (on the site they are called speaker SURROUND) that will replace the damaged outer rings on the woofers (replace on both woofers). They really work great and your speakers should last for many more years.
Hope this helps.

Feb 07, 2011 | 2001 Toyota Sequoia

1 Answer

CAN NOT REMOVE RIGHT REAR SUB WOOFER?


The sub-woofer is located behind the rear panel, so you will have to pull the rear panel to be able to get to all the bolts that hold the sub and plastic type box in place. It can be a pain to remove, it has about 4-5 bolts in the box.

Aug 28, 2010 | 1998 Ford Expedition

1 Answer

After repair of my radio antenna, sub woofer stopped working


yes probably, check for a fuse probably labeled amp or similar, in your fuse panel.

Aug 08, 2009 | 2002 Lincoln Navigator

2 Answers

How do I remove and replace the rear speaker in my 2002 Lexus ES 300?


Hello, I have a 2000 ES300 and while the body style is different believe the newer model still has the rear deck mounted sub-woofer that you are referring to. The process of removing this speaker would start off the same as if you were going to replace the third brake light also located in this housing. Using a flathead screwdriver work your way around prying/popping up all four corners of the speaker grill covering the speaker that have the retainer clips. Once you disengage the clips work/maneuver the grill up and towards you gently and it should slide out. The bulb for the third brae light will be attached to this speaker grill, disconnect the snap wire from the bulb and you should have a clear visual of the speaker and the four bolthead screws securing it. Remove these screws and your almost home free. The next part might be slightly more difficult. If the speaker s simply connected by a clipped on wiring harness, just detach.On my 2000 ES300 i have the pioneer system(Not Nakimichi) and the 2 wires (one black, and one red) are soldered directly to the speaker. You can take a soldering iron(maybe a battery or gas powered one unless you have an inverter) and remelt the solder to remove the wires or you can elect to simply cut the wires. If you choose to cut them make sure you cut them as close as possible to the soldered joints so you have plenty of wire left to install the replacement speaker.Then install replacement either soldering or using crimp clamps and reassemble. ( Note if you simply want to add a aftermarket amplified sub-woofer you don't need to remove the sub-woofer out of the housing. You can tap into the wire leads and run it directly to the amplifier. Just cut one of the wires leading to the stock sub-woofer so it doesn't also come on and potentially blow while the radio is on. This will also prevent any bass humming when the radio is shut off but the aftermarket amplifier is still on because once one of the wires to the stock sub-woofer is disconnected or cut it breaks the circuit. Hope this helps.

Jun 13, 2009 | 2000 Lexus ES 300

1 Answer

Radio wiring problem 2001 Audi A3


Hi, had total issues with this too! Your back speakers arent going because they are amped by the factory amp in the boot. You have to provide power to the amp so that it will turn the rear speakers on. This was a white and black striped wire in my car (Audi A3 1997) The rear speakers are blue /green and brown/red (left rear) , and the LH rear is brown/red and (forgotten colour) but the wire on the bottom left under those two brown/red wires on the 20pin harness. If you wire it all up like this then your rears should be going :)

Feb 21, 2009 | 2005 Audi A3

1 Answer

Sub woofer not working


maby a fuse or blown speakers try to replace the fuse

Jun 23, 2008 | 1999 Ford Explorer

Not finding what you are looking for?
2001 Ford Expedition Logo

Related Topics:

190 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...