Question about 1995 Chevrolet Caprice Classic

1 Answer

What is going on idle fine an then

My 1995 caprice start fine and idle then it start to sputter and idle down like it is going to cut off. I've change the plugs and the wire though that would fix it did even help, oh and the check engine light stay on. when you hit the gas it sound likr it going to cut off then it take off. The car want let my do the self computer check that the book say you can do

Posted by on

  • mydestini04 Mar 12, 2009

    okay man thanks. Oh about the computer i had one put in a bout a 5 or 6 weeks a go, and it seam to get a little worst it might just be me. and what would be an good distributor to go with its that flat one the under the water pump and the h/b

    pulley

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Bad distributor and/OR coil, I can guess, or the computer.

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 1995 astro mini van, it starts up and idles fine. But when you go to drive it it sputters and boggs down.


sounds like torque convertor control solenoid is locking transmission prematurely try unplugging electric connector on trans to see if condition changes...

Feb 25, 2015 | 1995 Chevrolet Astro

1 Answer

1995 geo tracker sputters and stalls


Have you checked fuel pressure ?

Jan 16, 2014 | Cars & Trucks

1 Answer

I have a 1995 Buick Regal with a 3.8 V6. Car will start just fine on a cold start but will not continue to run unless you hold the engine on at least 3000 rpms for about 30 seconds. it will then idle just...


i think you might be right it sounds like your engine is getting over fed fuel you are probably not getting very good fuel mileage either the 3.8 and 5.0 would defintely require the same volume of fuel it is probably playing havoc on the pressure regulators i would get another fuel pump and start there

Jan 27, 2011 | 1995 Buick Regal

1 Answer

1995 Jeep grand cherokee is missing while running. When it is under a heavy load (driving fast) it runs fine. When idleing and slow driving it spits and sputters.


I have the same problem on my 95 grand cherokee laredo. Sometimes it starts out fine and after about 10 miles it starts spitting and sputtering. Then after a while it seems to clean out and run fine again for a little while. Then other times it starts out spitting and sputtering at the begining. I changed the fuel filter and that was not it. It is a 4.0L 6cyc. Any Ideas?

Thanks,
Broken Arrow, OK

Jul 02, 2009 | 1995 Jeep Grand Cherokee

1 Answer

95 caprice is sputtering


Check vacuum hose to map sensor.

Jun 17, 2009 | 1995 Chevrolet Caprice Classic

Not finding what you are looking for?
1995 Chevrolet Caprice Classic Logo

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...