Question about 1993 Oldsmobile Cutlass Ciera

1 Answer

Car forces me to slow down

I just changed the Spark plugs, wires, and the fuel filter on my 1993 Oldsmobile Cutlass Ciera S and when the car accelerates to around 75-80 mph the check engine light comes on and the car won't accelerate past 70 (ie. it will get to 75-80 mph and starts to have problems so it slows down to around 65-70 mph and won't go past that even if I give it more gas). I originally though it was the coil packs but found out that the noise I was hearing was the A/C and I was told that the speed ssensor could be the issue my car is having. I want to clean off the sensor in hopes that this will resolve the issue. I am having trouble finding the sensor though. Does anyone know where the sensor is located?

Posted by on

  • 10 more comments 
  • SlyrArngrim Mar 11, 2009

    I also don't have ABS so I know its a transmission speed sensor. I just can't find it.

  • SlyrArngrim Mar 11, 2009

    I think it is down shifting because I the engine will still rev but no matter how much gas I give it, it will not accelerate past a certain point. It will stay at a certain speed when I hold on the gas.

  • SlyrArngrim Mar 11, 2009

    Where is that on my car? And how might I check it to see if it is clogged?

  • SlyrArngrim Mar 11, 2009

    I have a brand new fuel filter. The muffler was also recently repaired so it was probably checked and there was no issue. It was repaired at a muffler shop.

  • SlyrArngrim Mar 11, 2009

    Then again you said it was before the muffler. So I'll take a look.

  • SlyrArngrim Mar 11, 2009

    Its dark out today, but I'll check it first thing tomorrow when I get off work then I'll get back to you. Thanks for all the help!

  • SlyrArngrim Mar 11, 2009

    I tried to scan it for the codes but the Check Engine light goes off after I slow down and the computer does not store the code. When I went to have it scanned the machine said there was no problems.

  • Anonymous Mar 31, 2009

    hi im ***

  • mike loshbough
    mike loshbough May 11, 2010

    they didnt check the converter without this problem they never would have checked

  • mike loshbough
    mike loshbough May 11, 2010

    it is part of your exhaust before the muffler .to test if you dont have a back pressure tester which by the sound you dont take to a shop but also check your fuel filter for being clogged

  • mike loshbough
    mike loshbough May 11, 2010

    your catalytic converter may be clogged

  • mike loshbough
    mike loshbough May 11, 2010

    speed sensor wont fix this problem unless your car is down shifting to second gear?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,669 Answers

I doubt it is a speed sensor. It is in the transmission near the passenger side cv axle. Have you scanned it for codes? You can do it with a paperclip.

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My Oldsmobile Cutlass goes really slow when I go up hills. What could be the problem?


Tune up? Might want to start there. Usually on a tuneup I suggest plugs, wires, cap, rotor, air filter, and a fuel filter. Need more info on how it is acting as far as check engine light, bogging down, bucking, just doggy etc.

Mar 08, 2013 | 1990 Oldsmobile Cutlass Ciera

1 Answer

93 cutlass slow to execrate


Have the fuel pressure checked, you may have a plugged fuel filter.

Feb 10, 2012 | 1993 Oldsmobile Cutlass Ciera

2 Answers

Oldsmobile 1993 Cutlass Ciera hasitation when accerlerating from full stop


DIRTY FUEL INJECTORS STOPPED UP FUEL FILTER.BAD PLUGS WILL CAUSE HESITATION ON ACCELERATION.

May 01, 2010 | 1993 Oldsmobile Cutlass Ciera

1 Answer

93 olds ciera stalls when slowing down or stoping


tcc stuck try unpluging it and see if same but dont drive with unpluged will burn up transmission also could be fuel pump . or crank shaft postion sensor . try the tcc first then vheck fuel presure , and then check for codes with scanner

Jan 28, 2010 | 1993 Oldsmobile Cutlass Ciera

1 Answer

When my 1993 Oldsmobile Cutlass Ciera runs for awhile I cannot restart the car until it cools. Any suggestions on what it may be?


Fatcat,You didnt mention what engine you have.
When the no start occurs, try holding the gas pedal all the way to the floor, hold it there and try starting the car.
If it still does not attempt to start, disconnect (1) spark plug wire at the coil and have someone try to start the car, you should see and here a "spark" jump and snap.
If spark is present, air inlet to throttle body or carburetor and check for presence of fuel.
Let me know what you find.
Regards,

Feb 25, 2009 | 1993 Oldsmobile Cutlass Ciera

Not finding what you are looking for?
1993 Oldsmobile Cutlass Ciera Logo

356 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

61292 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...