Question about 2005 Pontiac Vibe

1 Answer

2002 3.8l impala random miss

Car very seldom misses. When it does it feels like it shuts off for half a second or so. Will do it at any rpm. Car has 61,000 on it, motor has 30,000 on it. MAF also has 61,000 on it. Tune up done.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 124 Answers

Try some STP fuel treatment, also make sure the air and fuel filters have been changed

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My impala has been missing. No lights have come on the dash. I tried changing gas and using gas cleaner but that doesn't solve the problem.


Have you tried changing your oil? Depending on the outside temperature, you will also have to use a different viscosity.

Dec 13, 2012 | 2009 Chevrolet Impala

1 Answer

Show Diagram of speed sensor for a 2005 Chevy Impala


I would say you changed the trans fluid to attempt
a fix for something

Old fluid out new in ,NOT A FIX AT ALL

You may have bad trans solenoids,flushing in my
opinion causes that

I never flush some people do

Have the real trans issue properly diagnosed

Your trying to put a band aid on it ,won't work

Mileage has nothing to do with anything,seldom--ever

I have seen cars come of the assy line & stop --before
they got on the car carriers to leave the factory

Dec 01, 2012 | 2005 Chevrolet Impala

1 Answer

Random mulitple misfire


A random miss-fire is almost impossible to diagnose.
You are dealing with fuel and ignition so there is a long list of causes.
You may have to wait until it becomes a solid miss on one cylinder.
a mechanic would need to be able to make the problem happen to find it.

Jul 12, 2012 | Mitsubishi Eclipse Cars & Trucks

1 Answer

97Gt mustang bogs at 4000 rpm no power after 4000 runs not missing but just feel like it won't go does it when the car warms up from a cold run does not do it after 10 minutes it starts to to it c


Sounds like you have the famous cam position failure.Dont rely on a code it wont give you any By the way does the idle roll and surge ? Then its definately your cam postion sensor

Feb 24, 2012 | Ford Cars & Trucks

2 Answers

My car went in for body work due to accident. When I picked it up the check engine light was on. I took it back, they hooked it up and told me they cleared it but it showed that the "Bank one...


Do you actually feel a miss? If not, it could be an open or short caused by either the accident or the repair. If the light didn't illuminate before you had the repair done, it is very possible something is amiss as a result of the repair. If you can feel the engine missing, start it when it's cold and let it run for 15 or 20 seconds then shut it down. Feel the exhaust manifolds. The manifold will be cooler corresponding to the cylinder that is missing. It could be a connection to the coil pack on that cylinder or even a bad coil pack.

Jun 24, 2011 | 2008 Chevrolet Impala

1 Answer

Car starts fine and seems to idle normal with only a small "hitch" or "bounce" in the tachometer every once in a while, meaning the rpm's dip slightly and only for a split second. This happens maybe 15...


Check your fuel pressure regulator, just pull the vacuum line off of it and see if it is leaking fuel, it is found on the fuel rail, will be the only vacuum line on the fuel rail.

Oct 23, 2010 | 1994 Ford Mustang

1 Answer

1994 Mitsubishi Diamante. I had this problem for a while now. When the engine is hot it gets worth. The engine is miss firing, I replaced spark plugs and wires a year ago. i also replaced Air miter. The...


check or relace your coil pack due to the fact that when a coil pack is going bad it usually looses its umph. when it get hot and that would explain random miss fires

Jun 23, 2010 | 1994 Mitsubishi Diamante

1 Answer

1991 Chevy Caprice has a mild miss fire and stall at low rpm: This is my latest update: I checked and cleaned the EGR,PCV,IAC valve, M.A.P sensor and Throttle body(bore/butterfly). with carb cleaner....


Do you have the idle speed turned up to keep it from dying? Because it is high. Check engine light on? Have you checked for vacuum leaks at the gasket under the throttle body? How does the car run under acceleration? You might have a worn distributor shaft.

Jun 22, 2010 | 1991 Chevrolet Caprice

1 Answer

Multiple random miss fire


Now change the distributor. Get one from salvage or e-bay. Did the timing belt jumped a tooth or is it new. Vitally

May 12, 2009 | 2000 Chevrolet Impala

Not finding what you are looking for?
2005 Pontiac Vibe Logo

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...