Question about 2003 Oldsmobile Alero

1 Answer

REAR DEFOGGER NOT WORKING 2000 OLS ALERO

HOW DO I GET THE REARE DEFOGGER TO WORK LIGHT WILL COME ON BREIFLY BUT NOTHING ELSE HAPPENS

Posted by on

  • Anonymous Apr 02, 2009

    Rear defogger will not work. Light comes on but nothing ever happens. Checked fuse and fuse is fine

  • Marc Podeszek May 11, 2010

    check the wiring at the glass clean it up and put back in need more info go to collsionrepairadvice.com

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

There's a junction box behind passenger rear door that has 2 wires that are joined from the front and control the rear defroster and radio antenna.

Posted on Mar 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My rear defroster won't work I have a 2000 Buick Park Avenue


Could be a bad relay !
The rear defogger circuit is protected by a 40A fuse. Voltage is supplied through the fuse to the rear defogger relay. When you press the rear defogger switch, the heater and A/C programmer sends a class 2 message to the body control module (BCM), to ground the rear defogger relay coil output circuit. This in turn closes the relay contacts allowing current to the rear window grid.
Do you know what a class 2 message is ? What a BCM is ?
HTD BK relay in rear fuse box ,location In the center right rear of the passenger compartment, under the rear seat cushion
Watch this video on testing from relay base ( where it plug's into )
Do
VEHICLE RELAYS Testing from the relay base

Oct 05, 2016 | 2000 Buick Park Avenue

1 Answer

My heater only works some of the time and my rear defrost dont work what could be the problem


As by heat only works some of the time , you mean it doesn't blow air out of the vent's . This means you probably have a problem with the blower motor or blower motor resistor or blower motor relay .
Rear Window Defogger Inoperative

    Exchange the rear defogger relay with a known good relay from the under hood junction block.
  1. Turn the ignition switch to the ON position.
  2. Press the rear defogger switch to the ON position.
Does the rear defogger grid warm?
--
Yes Go to Step 2
NO Go to Step 3

2

Replace the faulty relay.
Is the repair complete?
Go to Defogger System Check --

3

  1. Use a fused jumper wire in order to backprobe between terminal A4 of underhood junction block connector C3 and ground.
  2. Use a test lamp in order to backprobe between terminal C5 of underhood junction block connector C3 and ground.
Does the test lamp light?
--
Go to Step 4
Go to Step 23

4

  1. Use a test lamp in order to backprobe between terminal C5 of underhood junction block connector C3 and ground.
  2. Press the rear defogger switch to the ON position.
Does the test lamp light?
--
Go to Step 5
Go to Step 14



Mar 23, 2016 | 1999 Oldsmobile Alero

1 Answer

My 2006 Trailblazers license plate lights, rear window wiper & rear defogger all stop working at the same time & then will start working again whenever it feels like it


This is a thinking mans problem .You have nothing really wrong except a bad ground or connection . I would take a look at the wireing to all of the rear lights make sure they all work all of the time NO other lights haveing problems. If you don't find a problem you need to look at the switches for the rear wiper and defogger .their one over another try unpluging the connecters or wiggleing them around to see what happens this is a good way to isciluate simply a bad connection before you disassamble your dask board. Always do the the easyest and cheapest tests first that give you the most amount of information for the least amount work this will save you time and money everytime

Feb 20, 2015 | 2006 Chevrolet Trailblazer

1 Answer

I have a 2002 alero. Need to know where to plug in the radio antenna.


THE OLDSMOBILE ALERO DONT HAVE A EXTERNAL ANTENNA MAST. THE OLDS ALERO HAVE WIRE GRID ANTENNA INCORPORATED INTO THE DEFOGGER GRID IN THE REAR WINDOW.THE GRID ANTENNA HAVE A REAR WINDOW ANTENNA MODULE MOUNTED BEHIND TOP OF THE REAR SEAT BACK. THE RADIO ANTENNA CABLE GOES TO ANTENNA MODULE LOCATED TOP OF THE REAR SEAT BACK.

Jan 02, 2011 | 1999 Oldsmobile Alero

1 Answer

Rear window defogger dont work replaced relay & fuse still dont work


REAR WINDOW DEFOGGER SWITCH IS BAD OR YOUR REAR WINDOW HAS A BROKEN PLACE IN THE GRID.

Nov 01, 2009 | 1999 Oldsmobile Alero

1 Answer

Rear defrost on olds alero


Remove the interior panel next to the rear window on the passenger side. There should be a small black box (3"x3") bolted there. This box sends power to the rear defogger and carries the signals from teh integrated FM antenna. Often, the end of the plug fries and stops the defoggers from working while the radio has no problems.

The plug into the box is usually melted. It may look like it can be soldered and hardwired to work again, but more often than not the box is fried too. You can get them on the cheap from a JY or get them through GM.

Jul 13, 2009 | 1999 Oldsmobile Alero

2 Answers

Rear defroster on 2002 alero does not work


I found this on another site... it seems like a credible post so I thought I'd share... I'm going to check it out next weekend.

"Just an FYI. The rear defroster issue is due to a bad Antenna Buffer Module / Antenna Module. The power to the rear defogger goes through a module that separates the antenna amplifier signal from the 12 volt power to the defogger. The defogger elements also act as the antenna. The module is behind the rear pillar right behind the rear passenger door. The inside plastic has to be gently pulled off, the seat needs to be folded down to get the lower part of the trim off. One screw at the bottom, unplug the wires... (two connect to the window grid, mark which one is which)... and the module is free.
The module may require re-soldering of the pins joining the main power connectors to the internal circuit board. If you feel you can do this (or have a friend do it for you), go for it... else get another module from the dealer to replace it."

This is the most credible of the several posts that I've seen talking about this module. I know its there... I saw it yesterday when I was working on the car.

Jan 02, 2009 | 2003 Oldsmobile Alero

1 Answer

Rear window defogger stopped working


More than likely something has scratched the film that heats up to do the defrosting, Look to make sure it has both wires attached, and use either a test light (make one out of a 12volt bulb and wire if you do not have one.) See if you have electricity to the wires at the ends. If you do, you have a break in the film. You should be able to see where it is broken or scratched. There is an after market repair kit for this, that is not really expensive.

Dec 21, 2008 | 2003 Oldsmobile Alero

1 Answer

2002 Alero defogger


A common thing to fial on these- assumning the grid is ok, and wires are still attched to grid, is the rear def / antenna module. It is behind rt. rear quarter trim panel. The modules burn up, and also melt the connector. the module and connector would need to be replaced.

Dec 06, 2008 | 2003 Oldsmobile Alero

1 Answer

2003 olds alero rear windoe defogger


the rear passager panel the one that cover the side rear window there a relay connector in there that were the power to window go that defectif that gonna FIXYA our post thank you pierre

Jul 06, 2008 | 2003 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

798 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...