Question about 1993 Geo Prizm

Open Question

100 amp Fuse blown in FL block.

My daughter has a 93 prizm that will not start. When I first looked at it, it made no noise at all when we turned the ignition. On further inspection, I found the 100a fuse in the "FL Block" section of the fuse box open. When attempting to remove the fuse, it broke and I was not able to extract it. When I shorted the two posts together, the engine will turn over nicely, but will not fire. What component do you think is most likely the cause of the burnt 100a fuse? Could it be the primary side of the coil, and therefore no spark?

Posted by on

1 Suggested Answer

ftw1952
  • 10319 Answers

SOURCE: blown 60 amp main fuse while crussing at 60 mph.

if you have good coils and no spark are the wires ohming out to at least 28,000 ohms per foot?

Posted on Jun 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Full electrical power loss to everything.


Were the cables accidently hooked up backwards ? The main fuse at the fuse block may have blown. Check where your positive cable hooks at the main fuse block and there should be a fuse rated over 100 amps for the fuse block feed.

Jul 31, 2015 | 2004 Chevrolet Chevrolet Impala

3 Answers

My tail lights are not working, and the light on my dash doesn't come on when the headlights are on.


this car has a tail light control relay that if it failed would cause the tail light and dash lights to fail. see http://caphector.com/atoyota/techinfo.toyota.com/ileaf/02toyrm/02toypdf/02rmsour/2002/02echorm/di/theft/tailligh.pdf
Also there is a second fuse in the engine bay that if it blows it will cut power to the fuse in the interior fuse panel for the tail light fuse .If you look at the circuit diagram it is labeled fl block ALT.

see link below for most likely location of FL block alt fuse
http://caphector.com/atoyota/techinfo.toyota.com/ileaf/02toyrm/02toypdf/02rmsour/2002/02echorm/be/hatsy/loca.pdf

See also relay location in link below
http://i.fixya.net/uploads/images/8237dd51-a3bb-4248-bfce-ef01d4b805d7.jpg
Having also read a few other forum suggestions on a yaris the fuse may be under a red cover on the red wires coming out of the battery. There are 2 60 amp fuses possibly under the cover.
These can be damaged when a car is jump started incorrectly I do not know if you have jump started your car but this is a possible cause.

Nov 26, 2014 | 2001 Toyota Echo

1 Answer

Toyota rav4 fuses


You need to check your alt fuse. It is going to be a big one, I think it is on the positive cable attached to your battery. should be 100-120 amp fuse. If it even looks suspect then I would change it out. You will also have a alt fuse in the main fuse block under the hood. Should be a 40 amp. There is a kill fuse it should be numbered 1 and 2 or just number one. If that one is blown you will not be going anywhere.

May 11, 2014 | 1999 Toyota RAV4

1 Answer

I have 93 geo prizm and no turn signal at all what do i have to look for


there is a blinker can that controls the turn signals. if this can quits, so do your turn signals
this is easy and cheap to replace
it is usually found in or near fuse panel under dash

Jan 04, 2011 | 1994 Geo Prizm

1 Answer

Daughter tried to jump start her 97 protege with a jumper box and now there is no power through the ignition


the jump box may have been hooked up backwards and blown the main fuse (100 amp)

Jan 24, 2010 | 1997 Mazda Protege

1 Answer

I blew my 80a fuse on my 93 civic. i have replaced it and replaced the battery, now my lights turn on but my car won't start up. there is absolutely no sound at all from the car jus silence but my lights...


you should look in the under hood fuse-relay box the iignition or the start fuse is also blown usually those high amp fuses blow from jumping the batt backwards

Oct 16, 2009 | 1993 Honda Civic 4 Door

1 Answer

How do i change the alt 100a fuse on a 1995 geo prizm


you have to raise the fuse block up and flip open the sides to get to the two small bolts on each side of 100 amp fuse to change it. a little tight working area.

Jun 03, 2009 | 1995 Toyota Corolla

1 Answer

Car will not start after installing CD player into a 1999 Saturn!


Check your Ignition 1 & ignition 3 fuses in the inside fuse block,also check the body fuse 10amp in the inside fuse block.Keyless entry should take back off once you found the blown fuse.hope this helps

May 26, 2009 | 1999 Saturn SL

Not finding what you are looking for?
1993 Geo Prizm Logo

Related Topics:

203 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...