Question about 1993 Mazda Protege

2 Answers

I have replaced fuel pump'new fuel filter' new fuses' spark plugs' cap an roter'.on my 1993 mazda potege .fuel does not turn on' it has spark but will not start .could any one tell why.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The relay is under the kick pannal on the passenger side under the radio by the computer and its like $98 dollars

Posted on Feb 06, 2013

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,118 Answers

Might want to chk. for a fuel pump relay or maybe a fuel shut off switch, when you just turn key to on position (not to start) you should hear pump run and then a click that click will be the relay, if you don't hear either one you May have to test light plug on pump to see if you got power there, also chk. your ground wire at pump.Its possible to have gotten a defective pump.

Posted on Mar 09, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 1993 BMW 325i that turns over very strong but will not start?


Hello Edward:
The two magic ingredients are spark at the plugs and fuel in the jugs. Pull a plug...... if it is wet there is no spark, if it is dry, there will be no fuel. There can be a lot of reasons for either problem, so let's try to figure out which one we're dealing with first. Cheerfuls!

Mar 30, 2015 | 1993 BMW 325

4 Answers

What would cause 93 chevy c1500 rough idle smells of excess gas at exhaust


Does the truck seem fine when you first start it & then acts up when it reaches operating temp?
That would lead me to look at my oxygen sensor, a bad sensor can cause the truck to run "rich" which would explain the fuel smell in the exhaust.

Jun 28, 2014 | 1993 Chevrolet K1500

3 Answers

Our of gam


Need to see if you have spark at the spark plugs. Then check fuel pressure at the engine. Do you hear the fuel pump run a few seconds when turn the key on (without cranking)? If you don't hear ir running, could be pump, relay, fuse.

Dec 13, 2013 | 1993 Mercedes-Benz 190

1 Answer

Intermittent Misfire


Spark plugs are burnt? How do they look? Do they have black sooty deposits? It sounds like a an EFI problem. Like maybe the MAF (mass air flow) sensor. Located on the main intake after the air filter. Or possibly a vacuum leak? Does it miss at idle only or does it surge and miss while you are driving too? Is there any codes?

Jan 23, 2012 | 1997 Mazda Protege

2 Answers

My jimmy wont start have 58 psi of fuel pressure good spark but the spider injection wont open to spary the fuel brand new 280 bucks for it have checked grounds two broken one fixed those still no start...


check your ecm-ign fuse.if it is ok check to see if you have power to your spider injector.if you have power, you either have a bad computer or a bad connection between the computer and the inj.do you have spark??.if you have no spark check your ign module or bad connection at the ign module.i have seen that before.

Feb 01, 2011 | 1993 GMC Jimmy

1 Answer

95 jeep wrangler 4cyl takes two minutes of cranking before it turns over. changed plugs , wires,distributer cap and roter , fuel pump. still having same problem???


check the coil output. you should have a good healthy spark both from the coil and at the plug ends of the wires (should easily bridge a 1/4" or most times even wider gap.) I would also check the engine compression.
You did change the fuel filter when you did the pump? How does the air filter look?
if everything I mentioned checks out as good, then you will need to get a chiltons, haynes or other manual and individually test all sensors etc to see if anything is out of range. Obviously with numerous items that can potentially cause the same problem, no one can guess what exactly the problem is but I hope one of my suggestions points you in the right direction.
Good luck!

Nov 16, 2009 | 1993 Jeep Wrangler

1 Answer

Heavy steady shaking


check for blockage in catalytic convertor.there will be restricted exhaust flow and alot of heat

Nov 03, 2009 | 1997 Nissan Maxima

1 Answer

Mazda mx3 wont start


VSS or vehicle speed sensor aka cam sensor or crank position sensor. Test the battery and alternator. You should also check for blown fuses, bad wires and grounds on a car as old as yours. If you find it's getting spark and fuel after further testing, check the timing belt. It could have slipped or broke even if it was changed recently so either pull off the cover or at least do a compression test.

Apr 16, 2009 | 1992 Mazda MX-3

Not finding what you are looking for?
1993 Mazda Protege Logo

321 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

70347 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6876 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...