Question about 1988 Chevrolet C1500

1 Answer

Engine has dead spot in throttle under load acts like there is water in the gas (I checked there is not) I have replaced the cop& roter wires fule pump fule filter and both injectors its throttlebody I still need to change plugs but they are less then a year old. runs ine otherwise any thoughts?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 3,679 Answers

Have you checked the ignition timing ?

Posted on Mar 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Won't start or send out any water


Colin, RE POST make model # and your complete question, so we at Fixya can answer your question effectively.
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."

Apr 24, 2016 | Cars & Trucks

4 Answers

What would cause 93 chevy c1500 rough idle smells of excess gas at exhaust


Does the truck seem fine when you first start it & then acts up when it reaches operating temp?
That would lead me to look at my oxygen sensor, a bad sensor can cause the truck to run "rich" which would explain the fuel smell in the exhaust.

Jun 28, 2014 | 1993 Chevrolet K1500

1 Answer

E150 hesitates under light throttle


Did it occur the MAF (will not set code) is defective or the fuel pressure is low?

Apr 08, 2014 | 2003 Ford E150

1 Answer

My 96 grand cherokee acts like it is not getting gas


I have a 96 also and also had that problem #1 get the fule filter replaced.. #2 get some car/injector cleaner in the gas. #3 get some spray for carb and open up the air filter and shoot the cleaner in while running the engine.. You also can change the spark plugs and roter and cap and do a nice tune up and it will run like a new car..

Dec 02, 2013 | 2003 Mitsubishi Eclipse Coupe

2 Answers

I have a 1996 ford escort lx that wont maintain power after 2-5 mins of driving and is ripping through gas, i have replaced plugs, wires cleaned throttle body, checked the fule and air filters and the cat,...


Check/replace your O2 sensors. They regulate how much fuel is fed to the engine and if they are bad it may cause your vehicle to burn more gas and run poorly.

Apr 16, 2011 | 1996 Ford Escort 4 Door

1 Answer

2000 blazer Radum missfire untill hot.


Check the gas cap, take the cap back off the distributor and check to see if there is any play in the shaft (back and forth) and check for excessive play in the pinion gear. If it seems fine you can also check for play in the timing chain. If you are in the habit of not keeping the fuel tank full it may be a water in the fuel problem or could be water in the fuel. Double check your work on the tune-up, make sure that you didnt foget something. It happens to the best of us. Is the air filter fine? You can also check vacuum lines and the ducting between the MAF sensor and the plenum. Well good luck.

May 28, 2009 | 2000 Chevrolet Blazer

1 Answer

Engine Stalls When stopped and in Drive


Question, did you replace the throttle body, or clean the throttle plate, it will carbon up and block air needed for the idling speed to be correct. Also check for vacuum leaks, as the older vehicles didn't have good vacuum hoses. Good luck

Apr 18, 2009 | 1990 Chevrolet Astro Extended

1 Answer

Throttle had dead spot on Daewoo Lanos 1999 1.6SX


Sounds like you are you referring to the,"Throttle Position Sensor". You can check that with an ohm meter to try and verify dead spot. remove connector, hold probes on pins, have someone slowly & steadily push gas pedal. Readings should go up & down smooth & gradual, any sudden loss or jump in reading would indicate dead spot.

Apr 12, 2009 | 1999 Daewoo Lanos

3 Answers

88 F-150 stutters at speed


could possible be a bad fuel pump or a bad fules filter a dirty fuel filter can cause the same effects as a quick solution try running vehicle with dry gas when u get down to a quater tank should evaperate any water and also replace that fuel filter before a good fuel pump goes bad and will cost you alot more than a filter

Feb 10, 2009 | 1988 Ford F 150

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...