Question about 2007 BMW 525xi Sedan

1 Answer

Humming sound in radio

I reset computer in bmw 525i by disconnecting battery after reconnecting car started , but now have loud humming sound in radio could this the radio need to be rest how?? Help

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • BMW Expert
  • 206 Answers

If you have a bluetooth phone paired to the vehicle, try deleting all bluetooth devices. Sometimes a battery reset can cause bluetooth synchronizing issues.

Posted on Mar 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 525i Sports Edition. Yesterday as I was trying to go faster my rpm gauge only went to 3 and wouldn't go any faster also losing power please help


Check engine light on? Have codes scanned to help isolate problem area. Possible throttle actuator motor problem. You can try disconnecting/reconnecting battery to reset and see if it helps

Jul 12, 2015 | BMW Cars & Trucks

1 Answer

2003 BMW 325i series 43 main computer reset


remove the battery cables and touch them together to remove residual voltage leave disconnected for 1 hour then reconnect and read codes in computer

Sep 02, 2012 | 2003 BMW 325

1 Answer

RESET MESSAGES AFTER DISCONNECTING THE BATTERY IN MY 2007, 525i. when I put it back on a whole bunch of warning messages shows up.


    • 1 Turn your ignition key to the accessory position when the lights and radio come on (before starting the car).
    • 2 Press and hold the "Trip" button on the instrument panel until the red light comes on.
    • 3 Press the "Trip" button a second time and hold until "Reset" appears.
    • 4 Press the "Trip" button a third time. The computer is now reset.

Oct 06, 2011 | 2007 BMW 525xi Sedan

1 Answer

Transmission fault sign came on the screen, after slow start because of dying battery. Only drive to and from work, 11 miles each way. Car is 2004 525i with 63k miles. I bought it in 2007 with only 26k...


Sounds like it went into "limp mode" when your battery went low. BMW or any good specialty shop needs to reset your computer. (they don't reset themselves) most will do it for free. NOTE: if it does come back on, it's notifying you there is a pending issue that occurred coincidently.

Mar 05, 2011 | BMW 525 Cars & Trucks

1 Answer

How do I reset the radio code on a 94 BMW 525i


remove the radio, call in the serial numbers to the dealer, they will give you the code.

Nov 20, 2009 | BMW 525 Cars & Trucks

1 Answer

93 bmw 525i, knocking sound by radiator hose/engine


sounds like the vanos does the sound go under load.

Jul 08, 2009 | BMW 525 Cars & Trucks

1 Answer

2003 BMW 525i--could an improper jump start blow a fuse?


new altenator,sounds like you put the cables on the wrong way round

Jun 14, 2009 | 2001 BMW 5 Series

1 Answer

Radio won't turn on


if you have the anti theft code for your radio (if its stock) disconnect your negative battery terminal for 30 minutes.....reconnect and enjoy....did you use a reset tool or did you jump the diagnostic pins to reset?

Jan 07, 2009 | 2001 BMW 330

1 Answer

Air mass sensor


try this it may work for you. disconnect the battery , plug in the sensor and reconnect the battery
also make sure the sensor is installed with the air flow going the rite way

Dec 10, 2008 | 2001 BMW 5 Series

Not finding what you are looking for?
2007 BMW 525xi Sedan Logo

323 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Fred Sops

Level 2 Expert

271 Answers

Al Clark

Level 2 Expert

290 Answers

Doberman

Level 2 Expert

246 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...