Question about 2007 BMW 525xi Sedan

1 Answer

Car dead Just had new battery installed, 2 weeks ago, friday had outside temp gauge replaced guy said he had to reset computer now sunday go to start car and totally dead, whats up with this its 1999 528i help

Posted by on

  • 1 more comment 
  • beachluvin22 Mar 08, 2009

    car started after hooking battery back up, but now have loud humming sound in radio speakers which wasnt there before

  • DRRXR May 11, 2010

    I would get in touch with the fella that did the work, sounds like theres a short to ground.

  • DRRXR May 11, 2010

    Dunno, try diconnecting the battery for 5 minutes and then reconnect it and try it again.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 214 Answers

Probably gonna need a re-flash on the puter.. anytime ya change a battery on a beemer, you must keep voltage on the car from an additional source.. If ya dont.. Ur security system will kick in..

Posted on Mar 08, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Remote car opener


Does, "batteries ok" mean that you've replaced the battery in your remote? If not, worth doing.

Sep 03, 2014 | 2010 Toyota iQ 1.0

1 Answer

Renault scenic 1.9 td '03 starting problems in cold weather


coolant temp sensor, you have one for your gauge and another for your ecu, it adjusts air fuel ratio dependant on the outside temp as colder air is denser than warm.

Dec 29, 2013 | Cars & Trucks

1 Answer

1999 Jeep Cherokee Classic - car stalls intermittenly. Just had the CPS changed, could it be as simple as the battery cable?


Sounds like a bad ground. When it wont start run a jumper cable from the negative side of the battery to a good ground on the motor and try the body also. Rule that out first.

Dec 10, 2013 | 1999 Jeep Cherokee

1 Answer

My 2007 honda accord which was bought a few months ago,the outside temperature gauge has stopped working, also i noticed a week earlier a spot of oil on my driveway which came from the car near the drivers...


the outside temp could be the outside sensor, if you don't worry about knowing the outside temp its no problem, the oil leak is something to look into and repair

Sep 03, 2013 | Honda Accord Cars & Trucks

1 Answer

2004 Yukon XL 1500, with the car off the radio circuit draws alot of current and drains my new battery in 2-3 days. Also maybe seprate issue my oil presure gage does not reset to zero.


With the problem with the battery draining, Get the chargeing system check out, End tell them all so to check for a short, As for the problem with the oil gauge change the oil pressure sending unit,

Nov 26, 2012 | GMC Yukon Cars & Trucks

1 Answer

Have something draining my car battery. I have a 1999 Pontiac Bonneville, and I have to get a new battery about every 18 months. I had a new alternator put in, new not used, about 20 months ago. I replaced...


If you have a drain on your battery , it would not take 18 months for the battery to go dead . What do you mean The battery gauge in the dash shows only about 1/2 power, When ? When the vehicle is running ? Not charging ! The battery gauge as you call it has nothing to do with the Battery . That's showing how much the charging system is putting .The volt's indicator is controlled by the PCM - engine computer . With the engine running should show 14.1 volts .if your only seeing 7 the charging system isn't working. The alternator is controlled by the PCM as well ! Have it check by a GM dealer .

Mar 08, 2017 | 1999 Pontiac Bonneville

1 Answer

Battery keeps going dead.


obviously there is an abnormal drain on the vehicles electrical system. Examples of this are a glove box or conso;e light staying even though you closed it, is there a reading or compartment light on ? Anybody that just says "you need a battery without ALSO testing the electrical system for integrity is not helping,

Apr 05, 2009 | 2003 Land Rover Range Rover

1 Answer

Turn Signals are not working/Flashers are working


I would check a for a loose wire coming off the alternator. such as a bad ground or a loose connection.

Mar 24, 2009 | 1999 Chevrolet Cavalier

Not finding what you are looking for?
2007 BMW 525xi Sedan Logo

178 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...