Question about 1988 Cadillac Sedan DeVille

1 Answer

4.5 liter engine runs ruff intemitent seems rich. smokes at firewall. Runs fine when cold. Runs ruff after 4 or so miles.

Posted by on

  • 6 more comments 
  • nixorob Mar 08, 2009

    does not overheat when you gun engine ehaust smoke blows out back of engine and it skips it is running real rich. after it cools down it runs ok again. No water in oil. coolant ok. black smole coes out tailpipe only when problem occurs when warmed up.

  • nixorob Mar 08, 2009

    no. and if we did .... we don't know how to read them??

  • nixorob Mar 08, 2009

    Yup! I bet I have some trouble codes. Check engine lite is out. Does not come on at startup as it used to.



    Where do I buy the tester?

  • nixorob Mar 09, 2009

    Thanks I will get one. Running OK today. Just need to read the codes. I will let you know what they say.







  • yadayada
    yadayada May 11, 2010

    You can buy them on line, also they are availiable at Ebay motors under GM OBD 1 scanners, try and get one that can read live data so u can see what is going on when it smokes, I suspect u have a break in the engine wiring harness or a poor connection, OBD 1 stands for on board diagnostics generation one. The scanner may not work if the check engine light isn't functiona.

  • yadayada
    yadayada May 11, 2010

    if u don't konw how to read them how do u know u have no trouble codes, a little confused here. U need to buy an OBD 1 scanner they are about $75-100

  • yadayada
    yadayada May 11, 2010

    do u have any system trouble codes?

  • yadayada
    yadayada May 11, 2010

    smoke at the firewall is oil getting on the exhaust, does it overheat? does it seem to use coolant?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi I own a cadillac with the same motor. Never smoked but had all the same issues, ran fine cold but after a little driving (less than 2 miles) it shook like nothing else. The cause was the motor self destructed had to replace valves all 8 bosh injectors 2000 dollars later she is like new. Sorry about the bad news goodluck.

Posted on Aug 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2.3 liters, 4 cylinder turbo coupe engine idles erratically and cuts off. Black smoke comes out of exhust pipe. One of the radiator electrical fan comes on even when the motor is cold,


Sounds like you have two issues.

Black smoke and erratic tickover is a rich mixture.

Radiator fan is a separate issue and is the thermostat switch that is connected to that fan. If you have two fans, you need to make sure the other one actually runs as the switch may control both.

Mar 09, 2016 | 1988 Ford F 150

1 Answer

2005 lincoln ls ruff cold start then smooths out


Check out the preheater for the choke circuit. It closes the choke to give a rich mixture at cold start.

Jan 22, 2013 | 2002 Lincoln LS

1 Answer

My 2002 Hyundai Santa Fe with a 2.4 motor (110.000 miles) runs very ruff when the engine is cold. I have to keep the gas pedel pushed down to keep it running. When it runs about 4 minuites it will ru


Could be a problem with the fuel system or a vac leak.
The engine requires more fuel when the engine is cold.
You may need to replace the fuel filter and have the fuel pressure checked with a gauge.

Aug 23, 2012 | Hyundai Cars & Trucks

1 Answer

Truck runs ruff when cold but runs good after it warms up


the choke or cold engine fuel enrichment circuit is either too rich or too lean. someone who knows what they are doing needs to adjust it. for this i would suggest a dealer as they have tech bulletins and have no doubt seen this before.

Feb 18, 2011 | 2004 Ford F250

2 Answers

Hi i have a 2002 isuzu trooper when i start it from cold it smokes a lot the smoke is black, the car runs a bit lumpy for a bit and then the smoke clears and the car then runs fine, there seems to be no...


You didn't say whether it is gasoline or diesel, So I will guess it is a gasoline engine. It sounds as though the fuel injections system is leaking fuel into the manifold or combustion chambers while the car sit idle for a while. This would cause the black smoke on start up. After it burns off the extra fuel the smoke would clear up and the engine would run smoothly. The only way to find out if the injectors are leaking is to take it to a mechanic. If the car runs ok, it would not hurt to drive it like it is until such time you could have it repaired.

Dec 29, 2010 | Isuzu Trooper Cars & Trucks

1 Answer

I bought a second car for utility use; B6000, 1994, p/u, standard trans. Only when starting and running when the engine is cold, it runs very rough and difficult to idle. At normal operating temperatures...


a coolant tempurature sensor will make it run to rich if it is bad. run rough at idle, and produce black smoke, engine may stall out. it also causes retarded timing, slow idle speed, cold hesitation or stumble, poor fuel milage. good-luck!! if light is on check for problem code. this will guide you in the right direction. if no scanner, any auto parts store will scan for free. repost if need be. have a good day!!

Aug 13, 2010 | 1994 Mazda 2WD B Series Pickup

2 Answers

Problem with cold start and blowing smoke, runs fine after warm


You may need a tune up if its been longer than 12,000 miles since the last one.

Apr 23, 2010 | 1990 Honda Civic

1 Answer

95 aerostar 4.0L EFI 109k --- OBD I, code #556


Might check the coolant sensor. Make sure it is reading correctly. If it is still reading cold on your coolant sensor it will tell the computer to run as if it were cold telling the computer to send more fuel when in fact it doesnt need any because the engine is already warmed up.

Sep 06, 2009 | 1995 Ford Aerostar

1 Answer

I have a 1985 voltzwagon jetta ,trying to get running for my daugter(first car).Seems to have an intermident problem.Runs fine at times-Then runs totally rich (Black Smoke),missing some times-seems to be...


first; there are two) oil pressure switches on the car. you can replace the one till your blue in the face, and it will still come on. we ground that one; so it won't scare people to death.(1 in head.1 in block).<P>
Change fuel filter, and add a can of SEAFOAM to FULL tank of PREMIUM gas. Help it to idle 3-5 minutes.(this is the firsr year of the body change and engine change1.8, but they are good cars.)<p> After idle; drive somewhere where you can open it up for 10 miles or so. that should help alot.In he future, respond at rlmvbc@hotmail.com<p>
i've was a service writer,parts pro and salesman for VW for 10 years. I've also owned 4 bugs,6 rabbits, 1 scirroco, and 5 jettas. the older ones are better.

Aug 31, 2009 | 1985 Volkswagen Jetta

1 Answer

Lack of power


You need to check a service manual on this but it sounds a bunch like a cold-start valve isn't closing once the engine is warm and this would cause an overly rich fuel-air mix that would gag a warm engine. I don't know if your car is equipped with  one or not. 

Jan 06, 2009 | 1996 Oldsmobile Cutlass Supreme Coupe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

286 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...