Question about 1990 Ford Ranger SuperCab

1 Answer

1990 ranger 2.3L runs rough.at idle and when cruising. good acceleration. changed out the obvious, plugs, cap, filters etc. no luck. runs fine for awhile with egr sensor disconnected than reconnected, but after a minute or two back to running rough.

Posted by on

  • Anonymous Mar 14, 2014

    runs well when cruising but idles rough

  • Anonymous Mar 25, 2014

    P had a service engine light. I replaced the spark plugs and reset the computer. I drove it less than ten minutes and the light came back on. I had it scanned and it gave me a camshaft sensor code. I disconnected the battery changed the sensor and reconnected the battery. I ;et it idle for about 20 minutes (rough idle) and soon as I started to drive it the service engine light started blinking. What have I done?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,050 Answers

There will be an egr control solenoid that allows vacuum to reach the egr solenoid, sometimes it will be called the egr vent solenoid. It is probably bad.

Posted on Mar 08, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 96 ford bronco runs rough on acceleration,idles fine. Runs good under light acceleration but if hit the gas hard runs bad and pops. Changed fuel filter no change.what next?


givit a tune--new distributer cap--new plugs and cables--------also have air intake cleaned plus idle control--use a nonchlorinatd solvent sold a napa etc

Jul 22, 2014 | 1996 Ford Bronco

1 Answer

1990 Grand Prix starts but doesnt run no power stumbles dies


Could be clog catalytic converter.Tune up fuel filter,coils,air filter.

Apr 02, 2013 | 1990 Pontiac Grand Prix

2 Answers

Runs rough at idle when i drive it runs fine until i come to red light then it wants to stall. if it is idling it will stall to just bought it havent did any maintenance yet


Those El Caminos are nice. If you haven't done any maintenance, I would make sure that the oil is full, check and replace any bad carb. vacuum lines, check for any fuel, intake, vacuum, etc. leaks. Maybe check and replace spark plugs, wires, dist. cap + rotor, also check timing, etc. Good luck.

Nov 20, 2010 | 1983 Chevrolet El Camino

2 Answers

Ford F150 engine backfiring, running/idling rough


I Have a 1999 ford f150 4.6 that back fires and is just running really ruff when idling alot of nack fire a sord of like a pulse going on what is my problem?

Apr 16, 2010 | Ford F-150 Cars & Trucks

2 Answers

01 ford ranger 4x4 4.0V6-- rough idle like it wants to cut off. loses power or studders under acceleration. struggles to get up to 55 or 60


I agree. Try replacing the spark plugs, install new spark plug wires, change the air filter, change the fuel filter, and test the battery and alternator. Run a bottle of fuel system cleaner and water remover through it. To replace the spark plugs you'll most likely have to go through the wheel wells cause of their hard accessibility from the top. The fuel filter is located on the inside of the frame on the driver's side. Hope this helps. God bless

Oct 22, 2009 | 2000 Ford Ranger SuperCab

1 Answer

1990 ford ranger 2.3L running rough at idle and while driving


Hi check all the fuse. fi the fuse are ok . remove the coil pack and reverce if the cly missifire change replace the coil if not chage replace the electronic comtrol module ok.

Apr 20, 2009 | 1990 Ford Ranger SuperCab

1 Answer

90 2.9 Ranger No Power


when you replaced the distributor did you mark is well with paint you could be off a tooth or two in the distributor which would throw off the ttiming.

Apr 11, 2009 | 1990 Ford Ranger SuperCab

Not finding what you are looking for?
1990 Ford Ranger SuperCab Logo

Related Topics:

452 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

64034 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...