Question about 1999 Lexus RX 300

1 Answer

Little or no HEAT!!!!

We have a 1999 RX300, it ocassionally blows warm air. The check engine light is on, what can be the easiest and cheapest solution to fix this problem

Posted by on

  • samacan7 Mar 06, 2009

    Thank You Toyota Guy

    Yes my engine does warm up

  • Toyota Guy
    Toyota Guy May 11, 2010

    Sounds like you have an open thermostat. this would cause an engine light and no heat.
    Does your engine warm up?


×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Possibly the new pink style antifreeze that turns into gunk and systems needs flushing mayb blocking the heater core

Posted on Mar 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Front and rear blow little to no heat


If you know for sure the thermostat is working, it could be low on coolant and has air pockets in the system. Only one radiator hose should be warm until the engine reaches normal temp, and both heater hoses should be very warm.

Feb 19, 2015 | 2004 Dodge Durango

1 Answer

No heat but blows cold air


Sound like 1 of a few things. The easiest is air in the cooling system. Bleed it and while car is idling and heat is on full blast. (another posibility is head gasket gone bad)

Dec 09, 2013 | BMW X5 Series Cars & Trucks

1 Answer

I am having a problem with heat in my 99 RX300. When I turn it on, it blows cold air. I can't seem to get the heat to come on...


Check coolant level, if that is acceptable,, then the problem may be a thermostat or the deflector mechanism inside the heater which should be checked by a qualified mechanic.

Sep 23, 2011 | 1999 Lexus RX 300

2 Answers

1999 lexus rx300. fan won't blow. ac light is on


Possibly the connector to the blower unit has been diconnected or is loose.

Apr 13, 2010 | 1999 Lexus RX 300

1 Answer

Heat isn't working


Common Jeep problem. Blend doors are either jammed or broken. Dashboard removal is require to repair.

Jan 14, 2010 | 1999 Jeep Grand Cherokee

3 Answers

Why my heater in 2000 plymouth breeze only gives a little heat? Could it be a hose ? I know it's not the thermostat,the blowers ar working. I am wonding if theres some hoses that could be leaking?I don't...


it could be the cold air blend door or the thermostat is the engine temp up to the middle of the gauge or close to it if so then thermostat is ok if not then go ahead and replace it.

Jan 07, 2010 | 2000 Plymouth Breeze

1 Answer

Heater not working right in 1999 silverado. Blower works fine,not over heating, blows cool air when idling blows warm air when moving.


First check the coolant level if the engine is hot check the reserve jug on the firewall--if cold before start up remove the radiator cap and check coolant level add as needed. If the thermostat has been removed it needs to re-installed. It is possible that the heater hose(s) is stopped up. After letting it run for a period of time both heater hoses should be hot to the touch if they aren't something is restricting the flow of coolant the system needs to be drained and flushed. I have also see some vehicles form an air lock in the coolant system causing the same thing. It then needs to be (burped). This can be checked/done by removing the radiator cap while the vehicle is idleing and watching the water level in the radiator squeeze the upper radiator hose to see if the water/coolant level rises in the radiator. When you release the hose you may need to add some coolant this forces out the air. Hope one of these things. These are some of the cheapest fixes and if they don't work/help then you need to start looking at the heat control selector.

Oct 19, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Check engine light on


You need to have it hooked to a scan tool and find out why it came on. Could be a 1000 things.

May 28, 2009 | 1999 Lexus RX 300

1 Answer

1994 gmc safari,no heat


sounds like a blend door problem gm uses plastic clips to hold actuator rods that tend to break easiest thing to do is take it to a shop that offers free heater checks. and let them check it out

Jan 16, 2009 | 2000 GMC Safari

Not finding what you are looking for?
1999 Lexus RX 300 Logo

Related Topics:

210 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexus Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Lexus Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...