Question about 1999 Ford Expedition

2 Answers

99 Expedition - Stutters and loses power when accelerating

My 99 Expedition stutters and loses power when accelerating then I have to ease up on the gas, then start to accelerate again to overcome power loss. Two codes showed up when diagnostics were run: light fuel and heavy fuel errors. The mechanic had no clue. Not sure if its a cylinder mis-fire, spark plug etc...

Posted by on

  • Anonymous Mar 18, 2014

    I towed it to a mechanic, but as soon as they turned the key, it started right up. Diagnostics turned up zilch. After paying 200 bucks, I brought it back home and it ran for 3-5 days, and now it won't start again. when it is running it runs smooth, with no loss of power. Any suggestions?

  • Michael withrow
    Michael withrow Jul 27, 2014

    My expedition will not accelerate unless like you say I tap the pedal slowly then it will start to move but no power at all did you try replacing your plugs and wires

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

My was doing the same thing, it was an EGR valve and a misfire on the #2 cylinder which required a new spark plug and a coil pack
t

Posted on Mar 13, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 149 Answers

Always start with the simple first, change out the spark plugs one of them could have a hairline crack that opens up whenever it gets hot. Next try plug wires, lastly the coils. My bet is on the coils.

Posted on Mar 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Do you know what the problem may be?


Ford Focus cutting out and losing engine power, mileometer going ...

www.rac.co.uk > ... > Technical and Maintenance Questions
RAC Limited 10 posts - ‎6 authors
About five weeks ago, after driving for 1/2 mile, my car cut out with no warninh ... 26-08-11, 12:04 #1 ... I have a 51 Ford Focus 1.6 petrol, about 77000 miles on the clock. ... to check it wasn't anything I was doing, and whilst it wasn't half as bad, he did ... My main concern is the power failures causing the car to actually cut out ...Missing: kuga ‎11600 ‎stutters

Petrol in a diesel car - Guide and Videos - Auto Fuel Fix

My Escape is sputtering / losing power. - Ford Forums - Mustang ...www.fordforums.com/f59/my-escape-sputtering-losing-power-191329/Old 07-08-13, 07:22 PM Thread Starter. Escape2009. Registered User. Join Date: Jul 2013. Posts: 5. My Escape is sputtering / losing power.Engine power loss and sputtering - CarGurus

Dec 01, 2015 | Cars & Trucks

1 Answer

99 gmc savana stutters at consistant high speed.


My 99 GMC savana 1500 was chugging at like 50 60 mph and gas gauge was stuttering ..it turned out to be computer..I had it re flashed by GMC for 150 bucks ..that fixed all...hope this helps

Oct 09, 2012 | 1999 GMC Savana

1 Answer

Code p0300


I tinck yours ignition coils. before you get news echange the coil position of the number 2 and 8 if the codes change to the others cilynders numbers buy news .if nothing change check the conectors and sparck plugs of number 2 and 8.

Jul 22, 2012 | 2005 Ford Expedition

1 Answer

WHY IS THERE DRY BLACK SOOT ON NISSAN SENTRA 1996 CAR STUTTERS AND LOSES FOR SO IT EVENTUALLY TURNS OFF


Black soot coming from the exhaust would be excessive fuel.
The list includes injectors, fuel pressure regulator, fouled plugs, faulty coil, dirty air filter, and so on.

Jul 06, 2012 | 1996 Nissan Sentra

1 Answer

2003 Focus stutters accelerating between 60-80 km


Had similar problem on '04 Zetec. Turned out to be coil pak.

May 15, 2012 | 2003 Ford Focus

1 Answer

It stutters under mild acceleration, it smoothes out when accelerating hard


I would check your coil packs and plug wires. These newer motors even the spark plug gap will cause problems. Change your fuel filter. A easy way to check for misfires have your codes read but if there is no codes it has to be something simple like plugs or wires.

Feb 28, 2011 | 1999 Ford Expedition

2 Answers

Loss of power when accelerating


the problem was caused by a loose ignition wire
Carl

Jan 10, 2009 | 2005 Subaru Impreza

Not finding what you are looking for?
1999 Ford Expedition Logo

1,399 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...