Question about 2003 Ford Escort

1 Answer

A/C AND HEAT WILL NOT BLOW OUT WITH ANY FORCE

This is the second time this has happened it seemed to just fix itself the first time. The heat and air only come out when the car is moving it still doesn't come out enough to warm the car or defrost the windows. It is like the bellows or something are stuck. When I turn the speed control nothing changes but hot air does come out.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 37 Answers

Sounds like you need a blower motor and blower resistor.

Posted on Mar 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

My 93toyota camery overheated cause of split n radiator replaced with new radiator but still blows water out of overflow think could b waterpump n sounds like missing could that b because of the water blew...


Possibly blew a head gasket allowing combustion gases to enter the cooling system and force coolant out of the overflow tank. This can be verified by doing a compression check on each cylinder.

Jan 31, 2015 | Cars & Trucks

3 Answers

1995 buick park ave. 3800 series II. After letting the car reach full temp I turn on the heat and it is nice and warm for about 30 seconds, then I hear the sound of the air change, and the display...


Hello: The air mix door/temp door actuator has stripped gears and the force of the air by the blower motor is pushing the door to the Air Conditioning position. If you will remove the glove box and the panel under the dash and start the car and duplicate the condition you described you will see the action. you will need to replace the actuator. If you have passenger temp control then you will have two actuators, the one on the bottom for driver and the one on top for passenger.

Jan 20, 2011 | 1992 Buick Park Avenue

1 Answer

It seems that the A/C fan is blowing with less force/power on the driver side of the interior (both front and back). Is this possible and what could be causing this problem? Thanks.


Under the dash is a heat/a/c box, which has pneumatic doors that open and close allowing either heat or cold a/c air to flow to the vents of the vehicle.
If a door is not opening all the way this can happen, could be a sticking door or vacumn control module.
If the doors seem ok I would then check the duct work that carries the air to the vents on the drivers side its possible it is half off on the backside of the vent or the heat/a/c box.

Jun 13, 2010 | 2001 Chrysler Town & Country

1 Answer

No problem with heat.there is no force from blower motor on heat but blows great on cold. as you turn from cold to heat you lose the air flow


The blend door will not open to give you heat it seems t ome.The electrical solenoid has gone bad so a replacement is necessary

Jun 01, 2010 | 1997 Chevrolet Venture

1 Answer

No interior heat in my 2000 daewoo nubira


3 possible issues here,

the first is that your thermostat is stuck open, when this happens the air will barely be warm, luke warm at best, replacing the thermostat will fix this problem

the second, is that you have low coolant levels, when your coolant levels are way low, your heater core doesn't get the proper amount of coolant (if any) and the system blows cold air instead of heated air.

The third and final possibility, is that your heater core has clogged up (usually happens when stop leak or some type of radiator sealant is used) when this happens you can feel warm air when accelerating (test this by gently reving the vehicle and holding the rpm's when it is in park and holding your hands over the defrost vent to check for heat.

If you can tell me what symptom your vehicle is having I can help with instruction on how to fix it thanks cnc_couple@live.com


Jan 09, 2010 | 2000 Daewoo Nubira

2 Answers

A/C will suddenly send out heat. Fiddling with knobs seems to help. What's wrong?


You have a broken wire connection between the temperature control knob and the circuit board behind the center dash console. Vibration causes the failure and once the control knob gets loose the solder connection fails.

For someone that knows how to remove the dash unit and can re-solder a couple of new wires this fix should take no more than 1 hour. Make sure that you apply loctite to the heat control knob spindle nut when you re-assemble it.

The dealer quoted me 750 dollars to fix this issue and I found out that it's a common failure for this year. I fixed mine virtually for free but it took some tools and about an hour of my time.

Jun 02, 2009 | 2005 Toyota Highlander

2 Answers

Heat Shuts itself off


check ur coolant level and make sure getting coolant flow thru heater hoses

Jan 04, 2009 | 1998 Dodge Ram 1500 4WD

1 Answer

Heat and AC do not blow


blower motor not working ..blower relay or switch issue  very  likely..good  luck

Nov 18, 2008 | 2003 Ford Explorer

5 Answers

2006 Ford explorer/No heat /overheating


Sounds like you are either low on coolant, or a head gasket failure.

Nov 18, 2008 | 2006 Ford Explorer Sport Trac

2 Answers

Delayed or intermittent heat


after checking the heater core hoses they were both hot I went in to look at the blend door and noticed it wasn't moving on hot or cold so I simply disconnected the lincage and moved to hot and its working ok. but its not completely repaired

Oct 27, 2008 | 2003 Jeep Liberty

Not finding what you are looking for?
2003 Ford Escort Logo

112 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

70365 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...