Question about 1994 BMW 3 Series

1 Answer

Hi i have a L reg 325 td which was fine when it went to a garage for some minor mot repairs,after spending hundreds of pounds on various bits its never run right since. I replaced a fuel valve,had a hole in the exhaust welded and a new pipe fitted from the fuel tank to the filler. Now it idles okay for a couple of minutes then starts rough idling and cuts out as if it cant get fuel,after it cuts out the fuel comes back up the see through pipe from the engine back to the filter with a funny noise,when it is running it looks like the fuel going through has air in it,its sat with a flat battery for months and id like to understand what makes it cut out then start then cut out

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had this problem when I bought my 325td. When the fuel level got below 1/2 tank, it began to **** air through the fuel lines. Turns out it needed a new fuel pump. Wasn't a big problem to fix, just got a new filter (I think from eurocarparts) and changed it under the backseat.

Hope it helps.

Posted on Jun 29, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hello, I have a Ford escort 1.8 55D van. A few months back I fitted a new indicator stalk unit for the MOT as the high beam use to flicker on its own, all then fine. A couple of weeks ago the indicators...


typical UK reg motor they corrode like ?-?-? ,i suspect that your horn has stuck up with corrosion and the indicators is the hazard light warning switch faulty .But i could be wrong and often am but check it out anyway.I try not to repair UK or northern europeon vehicles anymore as i spend more time cutting off rusty bolts and seized bits than whats the cars worth compared to spanish vehicles that can be 20 yrs old and i just whistle and the bits come undone

Jul 18, 2011 | Ford Escort Cars & Trucks

1 Answer

Blow head asket on "N@ reg legacy


use $33 head gasket repair from Bar's Leaks. It worked for my car's seepage of antifreeze into the cylinder. It might help you for a reasonable cost.

Just pour it in and let it work for 15 minutes and hopefully your car's coolant system will be fine.

Otherwise, it may cost hundreds of dollars if not over $1000.

Good luck to you on this.

Jul 04, 2010 | 1990 Subaru Legacy

2 Answers

Problem with emmisions on a renault megane scenic 54 reg


Hi

From what you have described in your post and speaking from personal experience and without using a diagnostic tool there is a high possibility there is a problem with your camshaft sensor,
Part number 8200285798 for this is a common problem on these models.
DF119 or code DTC 0340 is the code given for this fault by Renault's diagnostic tool in some cases the code does not store itself into memory making diagnosis of the problem more difficult.

It would be interesting when you solve your problem to let us know.
Hope this information was helpful!

May 27, 2010 | 2004 Renault 181

1 Answer

Suzuki Grand Vitara 1999:


Going by your description I think it could be something different, I would have the brake master cylinder checked, if you are suffering brake failure and shuddering it sounds like your callipers arent getting equal pressure when you apply the brakes. Or a freat lack of pressure to suffer brake failure. I hope this helps.

Nov 02, 2009 | 1999 Suzuki Vitara

2 Answers

Abs fault on vw passat


I had the same problem. I took out the speed sensors on the underside of the hub, cleaned them as they were covered with iron fillings, put them back in and problem solved....

Feb 06, 2009 | 2004 Volkswagen Passat

1 Answer

Ford Mondeo failed its MOT exhaust emisson test


The advice that the garage gave you seems right. If any bushes were worn they would show up on the MOT Test. Try taking it to another garage to check out the Cat for your peace of mind.

Nov 21, 2008 | 2000 Ford Escort

2 Answers

1997 16v ford escort with zetec engine-r reg


remove and clean the idle valve control consult a haynes manual this should fix the problem!!!!

Nov 06, 2008 | 1998 Ford Escort

1 Answer

Chrysler voyager 2.5 td 2003


i had the same problem and my mechanics did change the drop links hope this helps

Oct 19, 2008 | 2003 Chrysler Voyager

Not finding what you are looking for?
1994 BMW 3 Series Logo

174 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Fred Sops

Level 2 Expert

271 Answers

Al Clark

Level 2 Expert

290 Answers

Doberman

Level 2 Expert

246 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...